Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
George Cristea

Changed the mobo cpu and psu... Now something is wrong

Recommended Posts

Get everything out of the case, build it on a flat surface (have the mainboard rest on a non-conductive surface, a cardboard box usually works) to make sure it all works outside the case. Start with the bare minimum (CPU, single stick of memory, onboard graphics) and work your way up slowly adding the remaining memory, HDDs and finally the GPU.

 

You can power on the PC by temporarily shorting the 2 pins for the power switch on the mainboard with a small screwdriver. If everything works outside the case, put everything back. If it still fails to power on, unplug the HDD led, power led and reset switch. If that still fails, unplug the power switch, and connect the reset switch to the power switch pins, and try again.

Either a piece of hardware is broken, or there is something wrong with the case.

Link to post
Share on other sites
Posted · Original PosterOP

This is a shame... cuz i been so sure that it will work so then i havent even tried it out before doing cable managament... now they all tied up at the back. i want to cry. gosh. will prob do and and if it works will re'assamble it tomorrow. 

 

Thanks tho

Link to post
Share on other sites
Posted · Original PosterOP

i took it  out and the same thing happens. tried a different psu. same thing... so is either the cku or mobo...tho the motherboard receives power... does anyone know how a motherboard reacts with a faulty cpu? im not sure which one is bad..

Link to post
Share on other sites
Posted · Original PosterOP

Now it booted. entered bios and something is strange says im using 2133mhz sticks? tho they are 3200

 

and also doesnt want to boot up my  pen drive windows... it tries to load but then gets stuck when the dots are spinning. and freezes

20190713_052650.jpg

20190713_052410.jpg

Link to post
Share on other sites

Before doing anything at all, you'll need to update the BIOS. According to their website, support for the 9th generation Intel Core processors came with BIOS revision F5 and you're still on F4. Simply update to the latest version F7 and try again.

 

After upgrading the BIOS, try installing Windows again.

 

As for the memory, I'd leave it for now. The speed shown is the speed the memory is running at, not what it's capable of. You'll never get a memory speed higher than your CPU and overclocking settings (ie, enabling XMP) support.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Buy VPN

×