Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Idkwhat2putheresowhatever

VT-x error on all virtual machines

Recommended Posts

Posted · Original PosterOP

For some reason when I tried using my virtual machines a while ago (Memu and Virtualbox) they all said that virtualisation or vt-x was not enabled. I have went into my bios and enabled both virtualisation and vt-d but to no avail. Many suggested disabling hyper-v but I have already did. I have attached the screenshot of the Windows features page. It might be the motherboard as I have RMA'ed it and updated the BIOS. The motherboard is an Asrock H310m-G/M.2

 

Screenshot (84).png


Nothing is here hehe 

Link to post
Share on other sites
8 minutes ago, Idkwhat2putheresowhatever said:

RMA'ed it and updated the BIOS

Some of those options are enabled in the BIOS. Check there for starters?


So rise up, all ye lost ones, as one, we'll claw the clouds

Link to post
Share on other sites
Posted · Original PosterOP
7 minutes ago, Radium_Angel said:

Some of those options are enabled in the BIOS. Check there for starters?

I have enabled this an Intel Virtualisation technology. (I cant post the other pic here for some reason)

20190625_222855.jpg


Nothing is here hehe 

Link to post
Share on other sites

What's important here isn't so much the motherboard but that your CPU supports VT-x/VT-d. If your profile is accurate your CPU does support both so I'm lead to believe there is an issue within Windows.

 

Did you install Windows yourself? Was this a pre-build? It's possible certain features could be disabled within Windows.

 

Also are you on Windows 32-bit or 64-bit?

Link to post
Share on other sites
Posted · Original PosterOP
11 minutes ago, Windows7ge said:

What's important here isn't so much the motherboard but that your CPU supports VT-x/VT-d. If your profile is accurate your CPU does support both so I'm lead to believe there is an issue within Windows.

 

Did you install Windows yourself? Was this a pre-build? It's possible certain features could be disabled within Windows.

 

Also are you on Windows 32-bit or 64-bit?

This was a prebuilt but I installed Windows myself. Its a retail version of Windows 10 Pro 64 bit. And it is the one on my profile which has an i7-8700 which does support VT-x and VT-d supposedly. I have checked with the Leomoon thingy and it says it is supported and enabled.


Nothing is here hehe 

Link to post
Share on other sites
8 minutes ago, Idkwhat2putheresowhatever said:

This was a prebuilt but I installed Windows myself. Its a retail version of Windows 10 Pro 64 bit. And it is the one on my profile which has an i7-8700 which does support VT-x and VT-d supposedly. I have checked with the Leomoon thingy and it says it is supported and enabled.

If you go to Task Manager > Performance > CPU, under "Virtualization: " what does it say?

Link to post
Share on other sites
Posted · Original PosterOP
4 minutes ago, Windows7ge said:

If you go to Task Manager > Performance > CPU, under "Virtualization: " what does it say?

It says enabled


Nothing is here hehe 

Link to post
Share on other sites
4 minutes ago, Idkwhat2putheresowhatever said:

It says enabled

3 minutes ago, Idkwhat2putheresowhatever said:

The error virtualbox gives

So the CPU supports it, Windows detects that it's enabled, but VB just isn't having it. I would try re-installing VB. Make sure you install the 64-bit version.

Link to post
Share on other sites
Posted · Original PosterOP
12 minutes ago, Windows7ge said:

So the CPU supports it, Windows detects that it's enabled, but VB just isn't having it. I would try re-installing VB. Make sure you install the 64-bit version.

Yea ill try this tomorrow. But it seems that other virtualisation applications also dont detect VT-x.


Nothing is here hehe 

Link to post
Share on other sites
10 minutes ago, Idkwhat2putheresowhatever said:

Yea ill try this tomorrow. But it seems that other virtualisation applications also dont detect VT-x.

If it is enabled in the BIOS I can only assume this is a Windows issue. I'm not sure what else to try besides re-installing the applications. I've worked with VB before on W10 Pro x64 and it's usually as easy as enabling VT-x(and/or VT-d) and you're good to go.

Link to post
Share on other sites

I've seen this happen because another hypervisor is currently active, but Hyper-V is currently inactive. You've probably already tried a restart, try safe mode and see what that does?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×