Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
hendre

My graphics card is fricked and i dont know what is wrong

Recommended Posts

Posted · Original PosterOP

I have no idea what happened but it just started showing lines on my screen and it isn’t the screen itselfwhen i boot it the bios screen doesn’t show it but seconds after it does. Like artifacting

Spoiler
Spoiler

 

 

 

Link to post
Share on other sites

Check with another port, ie. displayport /HDMI - check on onboard graphics if you have that - check with other cable.


Ryzen 2700X - Crosshair VII Hero - G.Skill Trident Z RGB - 3200@CL14, 1.35v  

EVGA BE SC 1080 Ti - Samsung EVO 960 500GB - EVGA 750 G3 - Design R6 TG blackout

Cooling: 3x NF-S12A in front - Kraken X62 on CPU (2x NF-A14) - Kraken X42 on GPU (1x NF-A14)

Link to post
Share on other sites
Posted · Original PosterOP
3 minutes ago, DoctorNick said:

Check with another port, ie. displayport /HDMI - check on onboard graphics if you have that - check with other cable.

i tried a hdmi and had no luck

Link to post
Share on other sites

What graphics card do you have?
System specs?

If your CPU has integrated graphics then plug the monitor in to the motherboard output and RMA the card back to the manufacturer.


CPU: Intel i7 6700k  | Motherboard: Gigabyte Z170x Gaming 5 | RAM: 2x8GB 3000MHz G.Skill Ripjaws 5 | GPU: Gigabyte Aorus GTX 1080ti | PSU: Corsair RM750x (2018) | Case: BeQuiet SilentBase 800 | Cooler: Corsair H100i AIO | SSD: Samsung 970 Evo 500GB + Samsung 840 500GB | HDD: Seagate Ironwolf 8TB + 2x Seagate Ironwolf 6TB | Monitor: Acer Predator XB271HU + Samsung BX2450

Link to post
Share on other sites
Posted · Original PosterOP
6 minutes ago, DoctorNick said:

Check with another port, ie. displayport /HDMI - check on onboard graphics if you have that - check with other cable.

I have a 2070

2 minutes ago, Spotty said:

What graphics card do you have?
System specs?

If your CPU has integrated graphics then plug the monitor in to the motherboard output and RMA the card back to the manufacturer.

I have a i5 8600k

and rtx 2070

8g ram 3000mhz

z370 msi motherboard

 

image.jpg

Link to post
Share on other sites
Posted · Original PosterOP
12 minutes ago, Spotty said:

What graphics card do you have?
System specs?

If your CPU has integrated graphics then plug the monitor in to the motherboard output and RMA the card back to the manufacturer.

 

12 minutes ago, Spotty said:

What graphics card do you have?
System specs?

If your CPU has integrated graphics then plug the monitor in to the motherboard output and RMA the card back to the manufacturer.

I have i5 8600k

rtx 2070

8g 3000mhz ram

Link to post
Share on other sites
Posted · Original PosterOP
28 minutes ago, hendre said:

I have no idea what happened but it just started showing lines on my screen and it isn’t the screen itselfwhen i boot it the bios screen doesn’t show it but seconds after it does. Like artifacting

  Reveal hidden contents
  Reveal hidden contents

 

 

 

 

5 minutes ago, hendre said:

 

I have i5 8600k

rtx 2070

8g 3000mhz ram

Its GeForce aorus

 

 

Link to post
Share on other sites
24 minutes ago, hendre said:

I have a i5 8600k

and rtx 2070

Good. Your CPU has integrated graphics and your GPU will be under warranty if you need to return it to the manufacturer for a replacement.

 

Use DDU (DisplayDriver Uninstaller) to fully remove your display drivers and install the latest Nvidia drivers from the Nvidia website.

Try reseating the graphics card in the PCIe slot.

If you've applied any overclocks to the graphics card then remove then and reset the card to defaults/stock.


Also, can you download and run a program called GPU-Z and take a screenshot of the information it gives.


CPU: Intel i7 6700k  | Motherboard: Gigabyte Z170x Gaming 5 | RAM: 2x8GB 3000MHz G.Skill Ripjaws 5 | GPU: Gigabyte Aorus GTX 1080ti | PSU: Corsair RM750x (2018) | Case: BeQuiet SilentBase 800 | Cooler: Corsair H100i AIO | SSD: Samsung 970 Evo 500GB + Samsung 840 500GB | HDD: Seagate Ironwolf 8TB + 2x Seagate Ironwolf 6TB | Monitor: Acer Predator XB271HU + Samsung BX2450

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Buy VPN

×