Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
fael097

(Gigabyte Mobo) system won't post

Recommended Posts

Posted · Original PosterOP

Hi, I have a ryzen 7 1800x / 980ti system on a ga-ax370-gaming k3 mobo, 32gb of ram, 2x16gb ballistix ddr4, nvme, ssd, 2 hdds. it's a relative new system, two years for the cpu/mobo/ram/nvme, maybe almost 3 for the gpu. my psu is an older corsair tx 750w from my last system, and all of a sudden it won't post. No display, nothing. The fans spin, and some LEDs that used to turn off quickly after post, now remain on and blink sometimes as described below. no beeps.

I opened it, dusted off everything, changed ram slots, tried 1 stick only at a time on every slot possible, changed GPU slot, tested the gpu on another system, disconnected all storage drives, tried only a ssd that I know is working, tried powering with a different psu that I know is working, nothing changed. I don't have another x370 mobo to test the cpu, nor any ddr4 mobo to test the ram. can't test the motherboard itself either. all the rest is working apparently. I also tried resetting the CMOS.

the mobo has 4 LEDs for error codes, each one represents CPU/DRAM/GPU/BOOT. when functioning properly, the CPU light turns on when I power the system, and turns off after like 2 seconds or so.

now, the CPU light stays on and blinks like every 5 seconds. The light that means DRAM error blinks on for a fraction of a second whenever the other light blinks off. this repeats for as long as I leave it on.

however these lights don't help at all, they don't narrow the problem, it could be any of the things that I can't test, and cpu ram and mobo are relatively new.

 

what can I do?

Link to post
Share on other sites
Posted · Original PosterOP

Ok so my friend had another x370 motherboard, except it's an Asus, so I managed to test all my components. Everything is working properly when I out it into his system, cpu, ram, gpu, storage drives, boot nvme, psu, everything. And when I put the components of his PC into my mobo, it didn't change anything, lights were blinking the same way.

 

So that pretty much narrows it down to the mobo. It's not dead as it turns on the fans and the lights, but it won't post. Could some of it's VRM have died? Can I test it somehow?

Link to post
Share on other sites
Posted · Original PosterOP

I just stripped everything out of the case, set up an improvised workbench, connected only the psu, cpu/cooler and a system speaker to the motherboard. no ram, no gpu, no storage/boot, no external devices attached.
on turning on, the cooler fans spin, the CPU error light stays on, nothing happens, no beeps, no lights blinking, no other lights are on.
by adding a ram stick into any slot, the error lights behave like before, cpu error light stays on, blinks off every 5 seconds or so, DRAM error light blinks on whenever the cpu error light blinks off.
by adding a graphics card, and connecting it to a monitor, the MSI logo LED turn on properly, cooler fans spin, but no video output of any kind, screens stays black, nothing else in the system changes.
by adding either an ssd/nvme/hdd, nothing changes.

it's worth mentioning again that all the components were tested in other machines individually. cpu, psu, ram, graphics card, storage drives, monitor, everything is working properly.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×