Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
B.Toast

IOGEAR GUCE64 not working?

Recommended Posts

Posted · Original PosterOP

Randomly specific, but my USB over ethernet extender isn't working. Windows 10 says "Unknown USB Device (Device Descriptor Request Failed)." I believe it came with a minidisk for drivers, but I also believe I was a dumbass and threw it away. IOGEAR doesn't have anything on their website for a driver for this device. Anybody know where I might look to find it?

 

PS: I have an email out to IOGEAR but not sure if they'll respond.


Intel Core i7-5820k | Noctua NH-D15 | ASUS X99-PRO | Kingston HyperX FURY DDR4-2400 32GB (8x4GB)
EVGA Geforce GTX 970 SC ACX 2.0 Samsung 850 EVO 250GB x2 | Samsung 860 EVO 1TB | 2TB & 750GB HDDs

Corsair RM750 | Fractal Design Define R5 | Fractal Design GP-14 Case Fans | Cyberpower BRG1500AVRLCD

Corsair Strafe RGB | Logitech G502 | Yamaha HS-8s & Outboard Audio Equipment

Link to post
Share on other sites

Based on the one review on B&H, there aren't drivers for it, and based on what it does, that doesn't surprise me.

 

My money is on failed hardware.


Main System (Byarlant): Ryzen 5 1600X | Asus B350-F Strix | Corsair H80i V2 | 16GB G.Skill DDR4 3200MHz CAS-14 | Reference Nvidia GTX 770 2GB | Samsung 960 PRO 512GB / Samsung 970 EVO 500GB / Seagate 7200RPM 3TB | Corsair CX650M | Mellanox ConnectX-2 10G NIC | Anidees AI-07BW Case | Dell U3415W Monitor | Microsoft Modern Keyboard

 

FreeNAS Server (Veda): Core i3-4170 | Supermicro X10SLL-F | Corsair H60 | 32GB Micron DDR3L ECC 1600MHz | 4x 10TB WD Whites / 1x Samsung PM961 128GB / 1x Kingston SSD 16GB | Corsair CX430M | Mellanox ConnectX-2 10G NIC | LSI 9207-8i LBA | Fractal Design Node 804 Case (side panels swapped to show off drives)

 

Media Center (Jesta): Core i7-2600 | Asus H77M-PRO | Stock Cooler | 8GB No-name DDR3 | EVGA GTX 750Ti SC | Sandisk UltraII SSD 64GB / Seagate 1.5TB HDD | Corsair CX450M | Hauppauge ImpactVCB-PCIe | Syba USB3.1 Gen 2 Card | LG UH12NS30 BD-ROM | Silverstone Sugo SG-11 Case

 

Laptop (Rozen-Zulu): Sony VAIO VPCF13WFX | Core i7-740QM | 8GB Patriot DDR3 | GT 425M | Kingston 120GB SSD | Blu-ray Drive | (Still my favorite typing keyboard)


Tablet (ReGZ): Asus T102HA | Samsung EVO+ microSD 128GB

 

Testbed/Old Desktop (Kshatriya): Xeon X5470 @ 4.0GHz | ZALMAN CNPS9500 | Gigabyte EP45-UD3L | 8GB Nanya DDR2 400MHz | XFX HD6870 DD | OCZ Vertex 3 Max-IOPS 120GB | Corsair CX430M (?) | HooToo USB 3.0 PCIe Card | NZXT H230 Case

 

Camera: Sony A7II (w/ Meike Grip) | Sony SEL24240 (better than most reviews say) | Sony SEL2870 (kit lens) | Sony SEL55F18F (meh, don't buy) | PNY Elite Perfomance SDXC cards

Link to post
Share on other sites
Posted · Original PosterOP
11 hours ago, AbydosOne said:

Based on the one review on B&H, there aren't drivers for it, and based on what it does, that doesn't surprise me.

 

My money is on failed hardware.

I figured that would be the case. I'm doing a quick replacement. If the replacement unit (arriving Monday) doesn't work either, then I'll return it and try a different product. 


Intel Core i7-5820k | Noctua NH-D15 | ASUS X99-PRO | Kingston HyperX FURY DDR4-2400 32GB (8x4GB)
EVGA Geforce GTX 970 SC ACX 2.0 Samsung 850 EVO 250GB x2 | Samsung 860 EVO 1TB | 2TB & 750GB HDDs

Corsair RM750 | Fractal Design Define R5 | Fractal Design GP-14 Case Fans | Cyberpower BRG1500AVRLCD

Corsair Strafe RGB | Logitech G502 | Yamaha HS-8s & Outboard Audio Equipment

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×