Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
shadowbutt7

Minecraft 1.14.1 optifine install

2 minutes ago, shadowbutt7 said:

java.io.FileNotFoundException: C:\Users\Jack\AppData\Roaming\.minecraft\versions\1.14\1.14.json (The system cannot find the file specified)

Looks like Optifine is trying to find a file that does not exist or is misplaced. I would suggest to remove all Optifine versions and reinstall Minecraft and Optifine again.

Recommended Posts

Posted · Original PosterOP

So basically im trying to install the preview version of optifine foir 1.14.1 but i get this message. dunno what it means, tried reinstalling minecraft, googled it, all that standard stuff. still dunno.

java.io.FileNotFoundException: C:\Users\Jack\AppData\Roaming\.minecraft\versions\1.14\1.14.json (The system cannot find the file specified)
  at java.io.FileInputStream.open0(Native Method)
  at java.io.FileInputStream.open(Unknown Source)
  at java.io.FileInputStream.<init>(Unknown Source)
  at optifine.Utils.copyFile(Utils.java:215)
  at optifine.Installer.copyMinecraftVersion(Installer.java:447)
  at optifine.Installer.doInstall(Installer.java:94)
  at optifine.InstallerFrame.onInstall(InstallerFrame.java:425)
  at optifine.InstallerFrame.connEtoC1(InstallerFrame.java:490)
  at optifine.InstallerFrame.access$7(InstallerFrame.java:484)
  at optifine.InstallerFrame$IvjEventHandler.actionPerformed(InstallerFrame.java:46)
  at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
  at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
  at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
  at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
  at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)
  at java.awt.Component.processMouseEvent(Unknown Source)
  at javax.swing.JComponent.processMouseEvent(Unknown Source)
  at java.awt.Component.processEvent(Unknown Source)
  at java.awt.Container.processEvent(Unknown Source)
  at java.awt.Component.dispatchEventImpl(Unknown Source)
  at java.awt.Container.dispatchEventImpl(Unknown Source)
  at java.awt.Component.dispatchEvent(Unknown Source)
  at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
  at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
  at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
  at java.awt.Container.dispatchEventImpl(Unknown Source)
  at java.awt.Window.dispatchEventImpl(Unknown Source)
  at java.awt.Component.dispatchEvent(Unknown Source)
  at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
  at java.awt.EventQueue.access$500(Unknown Source)
  at java.awt.EventQueue$3.run(Unknown Source)
  at java.awt.EventQueue$3.run(Unknown Source)
  at java.security.AccessController.doPrivileged(Native Method)
  at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
  at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
  at java.awt.EventQueue$4.run(Unknown Source)
  at java.awt.EventQueue$4.run(Unknown Source)
  at java.security.AccessController.doPrivileged(Native Method)
  at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
  at java.awt.EventQueue.dispatchEvent(Unknown Source)
  at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
  at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
  at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
  at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
  at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
  at java.awt.EventDispatchThread.run(Unknown Source)

 

anyone knwo whats going on?

 

thanks

Link to post
Share on other sites
Posted · Best Answer
2 minutes ago, shadowbutt7 said:

java.io.FileNotFoundException: C:\Users\Jack\AppData\Roaming\.minecraft\versions\1.14\1.14.json (The system cannot find the file specified)

Looks like Optifine is trying to find a file that does not exist or is misplaced. I would suggest to remove all Optifine versions and reinstall Minecraft and Optifine again.


¯\_(ツ)_/¯

Link to post
Share on other sites
Posted · Original PosterOP
7 minutes ago, Uptivuptiz said:

Looks like Optifine is trying to find a file that does not exist or is misplaced. I would suggest to remove all Optifine versions and reinstall Minecraft and Optifine again.

Im still getting the same error code :(

Link to post
Share on other sites
Posted · Original PosterOP
11 minutes ago, Uptivuptiz said:

Looks like Optifine is trying to find a file that does not exist or is misplaced. I would suggest to remove all Optifine versions and reinstall Minecraft and Optifine again.

Nevermind it works now. i dont know what changed but it worked

Link to post
Share on other sites
2 minutes ago, shadowbutt7 said:

Nevermind it works now. i dont know what changed but it worked

No reason to tinker further with it if it works :D The installer might have misplaced a file ¯\_(ツ)_/¯


¯\_(ツ)_/¯

Link to post
Share on other sites
Posted · Original PosterOP
2 minutes ago, Uptivuptiz said:

No reason to tinker further with it if it works :D The installer might have misplaced a file ¯\_(ツ)_/¯

not gonna touch it lol. just glad its working XD 
anyway something fuckjed up and fixed itself

Link to post
Share on other sites

Run the install as Administrator. When writing to specifically protected folders some files are seen as threatening and are simply not written to the folder. Make sure your antivirus is off as it often delete file on the disk when installing. If it still fail then you can pick up that file from the web and copy it in the directory it need. If you need to do that chances are that your downloaded installer is corrupted or a bad release version. You can install an older version and update from within the startup application.

Link to post
Share on other sites

The whole point of it, is that its "unstable" 


M Y  S T U F F

 

Ryzen  PC |~|  Ryzen 5 1600 | GTX 1060 6GB | G.SKILL Ripjaws V Series 8GB DDR4 DDR4 2400 x2 |  WD Blue 250GB SSD | Barracuda Pro 2TB  EVGA 650W 80+Gold |

Laptop |~| Legion Y530 | i7-8750H | GTX 1050 Ti 4GB | 16GB DDR4 2666MHz | 128GB SSD | 1 TB Hard Disk Drive, 7200rpm |

Macbook Air |~| 2.2GHz dual-core Intel Core i7 | Intel HD Graphics 6000 | 8GB of 1600MHz  512GB SSD |

 

Displays |~| AOC G2460VQ6 24" x2|

Keyboard |~| Corsair Gaming K70RGB 

Mouse |~| Razer Lancehead Pink RG

Audio |~| HyperX Cloud II Audio-Technica ATH-AD700X

Microphone |~| Audio Technica AT2035

 

M y  R e v i e w s 


Lenovo Y530 Legion Laptop.

 

More Coming Soon...
 

 

Link to post
Share on other sites
Posted · Original PosterOP
19 hours ago, Franck said:

Run the install as Administrator. When writing to specifically protected folders some files are seen as threatening and are simply not written to the folder. Make sure your antivirus is off as it often delete file on the disk when installing. If it still fail then you can pick up that file from the web and copy it in the directory it need. If you need to do that chances are that your downloaded installer is corrupted or a bad release version. You can install an older version and update from within the startup application.

s'all good. pretty sure uninstalling the previous versions of optifine worked

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×