Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
ComputerNerdDude158

Broken pc

1 minute ago, ComputerNerdDude158 said:

But it's doing the same thing a like 30 dollar china psu did, and that china one worked for my pc for about 3 years so this should at least get it too boot...shouldn't it?

You basically side graded in quality both are known for said issues.  It's possible it's the RAM too.  One or more of the stick could be faulty.  The CPU can be the problem too, but that's kinda rare.  Even the mobo can cause boot loop issues.

But, going over the list it could possible be the mobo if a better quality psu doesn't fix the problem.

Recommended Posts

Posted · Original PosterOP

Hello peoples, my pc is having trouble with a thing...so, specs are, i5 3570k,

Corsair Vengeance 12 GB (3 x 4 GB) DDR31866 ram, asus p8z77-v lx motherboard, and some 450 watt psu.
So whenever I turn it on, it goes into a boot loop, it will say the normal "press f2 or del to enter bios setting" and then....turns off and turns on again, I have tried different ram that i know is comparable with the MB, taken out my rx 560, taken out all drives, disconnected all usb keyboards, mice, and everthing, and if I press f2 or del it doesn't enter the bios settings, it just goes back into the boot loop! Anyone know what could be wrong?
Link to post
Share on other sites
1 minute ago, ComputerNerdDude158 said:

some 450 watt psu.

So folks can help you out better, what is the model of the psu?


Current, New System

 

Mobo: MSI MEG Z390 Godlike // CPU: i9-9900K // GPU: Galax Hall of Fame RTX 2080 Ti // RAM: 32GB Vengeance LPX // Cooling: D15S with 3 Noctua Fans // Storage: 1TB SSD Samsung 860 EVO, 6TB Seagate Barracuda PRO // PSU: RMi 850w 80+ Gold // Case: TT View 37 RGB Edition

 

Old System (Now Retired)

 

Mobo: Asus B85M-E // CPU: i7-4770K // GPU: Gigabyte G1 1070 // RAM: 16GB Single Channel // Cooling: Stock Intel // Storage: 167 GB SDD OCZ Agility3, 2 TB Seagate Barracuda // PSU: AeroCool Strike X 800w 80+ Silver // Case: Corsair SPEC-03 Blue LED Mid-Tower

 

Peripherals And Others

 

Mouse: Razer Mamba Tournament Edition // Keyboard: Razer Blackwidow X Chroma Mercury White // Headphone: Razer Man'O War 7.1 // Display: LG 2560x1080 25' 60Hz Ultrawide // UPS: Pure Sine Wave, Online Topology 3000VA (2100w) (this shit is heavy as fuck)

 

- Previously ReggieGRS

Link to post
Share on other sites

Have you tried taking out the CMOS battery for a few minutes and reseating it? 


DAEDALUS (2018 Refit) - Processor: AMD Ryzen 5 - 1600 @ 3.7Ghz // Cooler: Cooler Master Hyper 212 LED Turbo Black Edition // Motherboard: Asus RoG Strix B350-F Gaming // Graphics Card: Gigabyte GTX 1060 Windforce 6GB GDDR5 // Memory: 2 x 4GB DDR4 Corsair LPX Vengeance 3000Mhz // Storage: WD Green - 250GB M.2 SATA SSD (Boot Drive and Programs), SanDisk Ultra II 120GB (GTA V), WD Elements 1TB External Drive (Steam Library) // Power Supply: Cooler Master Silent Pro 700W // Case: BeQuiet Silentbase 600 with SilentWings Mk.2 Internal Fans // Peripherals: VicTop Mechanical Gaming Keyboard & VicTsing 7200 DPI Wired Gaming Mouse

 

PROMETHEUS (2018 Refit) - Processor: Intel Core i5-3470 @ 3.2Ghz // Cooler: Cooler Master 212 EVO // Motherboard: Foxconn 2ABF // Graphics Card: ATI Radeon HD 5450 (For Diagnostic Testing Only) // Memory: 2 x 4GB DDR3 Mushkin Memory // Storage: 10TB of Various Storage Drives // Power Supply: Corsair 600W // Case: Bitfenix Nova Midi Tower - Black

 

SpeedTest Results - Having Trouble Finding a Decent PSU? - Check the PSU Tier List!

Link to post
Share on other sites
47 minutes ago, ComputerNerdDude158 said:

ENYLE 450W EN-450F12BK

That's most likely your issue.  Had the same issue recently with another shoddy branded PSU then swapped it for a CXM 550w and it solved the boot loop issue.


Bloodshed and the Fenris-Wolf:

| CPU:  Ryzen 3 2200g(buying a 3900x in January for it) | CPU Cooler:  Stock at the moment(have a dark rock pro 4 for that 3900x) | Paste:  Kryonaut | Motherboard:  ASRock x470 Taichi(replacing with a Gigabyte x570 Aorus Elite) | RAM:  G.Skill Ripjaws V Series 32 GB (2 x 16 GB) DDR4-3200 | Boot Drives:  Crucial MX500 500 GB M.2-2280+Crucial BX500 120 GB 2.5" SSD | Storage Drives:  Toshiba X300 4 TB 128 MB Cache 3.5" HDD+PNY CS900 240 GB | GPU:  Sapphire Radeon VII 16 GB HBM2 Video Card | Case:  Cooler Master MasterBox MB511 RGB | PSU:  EVGA SuperNOVA G2 750 W 80+ Gold Certified Fully Modular ATX Power Supply w/CableMod E-Series Cable Kit (Black/Red) | Case Fans:  2 Corsair SP140 49.49 CFM 140 mm Fans | Displays:  AOC U2879VF 28.0" 3840x2160 60 Hz Monitor+AOC G2460PQU 24.0" 1920x1080 144 Hz Monitor(Replacing with an LG 240 Hz monitor) | Mouse:  Corsair M65 Pro RGB | Keyboard:  Ducky Shine 7 Blackout - MK Exclusive First Release - RGB LED Double Shot PBT Mechanical Keyboard with Silent Red Switches | Mousepad:  Gaya Entertainment Oversized Gaming Mousepad Doom | Audio:  Massdrop x AKG K7XX Audiophile Open-back Headphones+Audio-Technica ATR2500-USB Cardioid Condenser USB Microphone+Kingston HyperX Cloud II 7.1 Channel Headset+iBasso IT01 Dynamic Driver Audiophile In-Ear Monitors/Earbuds (Black)+Pair of Mackie MR624s(came with stands+isolation pads) | OSes:  Windows 10 Pro+openSUSE Tumbleweed |



VashTheStampede(ROG Zephyrus M GU502):

| CPU:  i7-9750h | RAM:  32GB Dual Channel 2666mhz CL 19(Stock+Samsung 16GB DDR4 PC4-21300, 2666MHZ, 260 PIN SODIMM, 1.2V, CL 19 ) | Storage:  1TB SSD with Optane | GPU:  Nvidia RTX 2060 | Display:  144hz 3ms | Mouse:  Corsair M65 Pro |

Link to post
Share on other sites
Posted · Original PosterOP
4 hours ago, valdyrgramr said:

That's most likely your issue.  Had the same issue recently with another shoddy branded PSU then swapped it for a CXM 550w and it solved the boot loop issue.

Okay I'll try that thanks! New psu is something I've been needing probably, and if that's not it, I can use it in my next pc build :D

Link to post
Share on other sites
1 minute ago, ComputerNerdDude158 said:

Okay I'll try that thanks! New psu is something I've been needing probably, and if that's not it, I can use it in my next pc build :D

Grey label CX/CXMs are usually cheap in most regions.  There's all the system power 9s.


Bloodshed and the Fenris-Wolf:

| CPU:  Ryzen 3 2200g(buying a 3900x in January for it) | CPU Cooler:  Stock at the moment(have a dark rock pro 4 for that 3900x) | Paste:  Kryonaut | Motherboard:  ASRock x470 Taichi(replacing with a Gigabyte x570 Aorus Elite) | RAM:  G.Skill Ripjaws V Series 32 GB (2 x 16 GB) DDR4-3200 | Boot Drives:  Crucial MX500 500 GB M.2-2280+Crucial BX500 120 GB 2.5" SSD | Storage Drives:  Toshiba X300 4 TB 128 MB Cache 3.5" HDD+PNY CS900 240 GB | GPU:  Sapphire Radeon VII 16 GB HBM2 Video Card | Case:  Cooler Master MasterBox MB511 RGB | PSU:  EVGA SuperNOVA G2 750 W 80+ Gold Certified Fully Modular ATX Power Supply w/CableMod E-Series Cable Kit (Black/Red) | Case Fans:  2 Corsair SP140 49.49 CFM 140 mm Fans | Displays:  AOC U2879VF 28.0" 3840x2160 60 Hz Monitor+AOC G2460PQU 24.0" 1920x1080 144 Hz Monitor(Replacing with an LG 240 Hz monitor) | Mouse:  Corsair M65 Pro RGB | Keyboard:  Ducky Shine 7 Blackout - MK Exclusive First Release - RGB LED Double Shot PBT Mechanical Keyboard with Silent Red Switches | Mousepad:  Gaya Entertainment Oversized Gaming Mousepad Doom | Audio:  Massdrop x AKG K7XX Audiophile Open-back Headphones+Audio-Technica ATR2500-USB Cardioid Condenser USB Microphone+Kingston HyperX Cloud II 7.1 Channel Headset+iBasso IT01 Dynamic Driver Audiophile In-Ear Monitors/Earbuds (Black)+Pair of Mackie MR624s(came with stands+isolation pads) | OSes:  Windows 10 Pro+openSUSE Tumbleweed |



VashTheStampede(ROG Zephyrus M GU502):

| CPU:  i7-9750h | RAM:  32GB Dual Channel 2666mhz CL 19(Stock+Samsung 16GB DDR4 PC4-21300, 2666MHZ, 260 PIN SODIMM, 1.2V, CL 19 ) | Storage:  1TB SSD with Optane | GPU:  Nvidia RTX 2060 | Display:  144hz 3ms | Mouse:  Corsair M65 Pro |

Link to post
Share on other sites
Posted · Original PosterOP
On 5/17/2019 at 11:18 PM, valdyrgramr said:

Grey label CX/CXMs are usually cheap in most regions.  There's all the system power 9s.

Didn't work, I got a evga 600w br, still the boot loop

Link to post
Share on other sites
1 minute ago, ComputerNerdDude158 said:

Didn't work, I got a evga 600w br, still the boot loop

That's not really a good PSU and known to have problems.


Bloodshed and the Fenris-Wolf:

| CPU:  Ryzen 3 2200g(buying a 3900x in January for it) | CPU Cooler:  Stock at the moment(have a dark rock pro 4 for that 3900x) | Paste:  Kryonaut | Motherboard:  ASRock x470 Taichi(replacing with a Gigabyte x570 Aorus Elite) | RAM:  G.Skill Ripjaws V Series 32 GB (2 x 16 GB) DDR4-3200 | Boot Drives:  Crucial MX500 500 GB M.2-2280+Crucial BX500 120 GB 2.5" SSD | Storage Drives:  Toshiba X300 4 TB 128 MB Cache 3.5" HDD+PNY CS900 240 GB | GPU:  Sapphire Radeon VII 16 GB HBM2 Video Card | Case:  Cooler Master MasterBox MB511 RGB | PSU:  EVGA SuperNOVA G2 750 W 80+ Gold Certified Fully Modular ATX Power Supply w/CableMod E-Series Cable Kit (Black/Red) | Case Fans:  2 Corsair SP140 49.49 CFM 140 mm Fans | Displays:  AOC U2879VF 28.0" 3840x2160 60 Hz Monitor+AOC G2460PQU 24.0" 1920x1080 144 Hz Monitor(Replacing with an LG 240 Hz monitor) | Mouse:  Corsair M65 Pro RGB | Keyboard:  Ducky Shine 7 Blackout - MK Exclusive First Release - RGB LED Double Shot PBT Mechanical Keyboard with Silent Red Switches | Mousepad:  Gaya Entertainment Oversized Gaming Mousepad Doom | Audio:  Massdrop x AKG K7XX Audiophile Open-back Headphones+Audio-Technica ATR2500-USB Cardioid Condenser USB Microphone+Kingston HyperX Cloud II 7.1 Channel Headset+iBasso IT01 Dynamic Driver Audiophile In-Ear Monitors/Earbuds (Black)+Pair of Mackie MR624s(came with stands+isolation pads) | OSes:  Windows 10 Pro+openSUSE Tumbleweed |



VashTheStampede(ROG Zephyrus M GU502):

| CPU:  i7-9750h | RAM:  32GB Dual Channel 2666mhz CL 19(Stock+Samsung 16GB DDR4 PC4-21300, 2666MHZ, 260 PIN SODIMM, 1.2V, CL 19 ) | Storage:  1TB SSD with Optane | GPU:  Nvidia RTX 2060 | Display:  144hz 3ms | Mouse:  Corsair M65 Pro |

Link to post
Share on other sites
Posted · Original PosterOP
12 minutes ago, valdyrgramr said:

That's not really a good PSU and known to have problems.

But it's doing the same thing a like 30 dollar china psu did, and that china one worked for my pc for about 3 years so this should at least get it too boot...shouldn't it?

Link to post
Share on other sites
Posted · Best Answer
1 minute ago, ComputerNerdDude158 said:

But it's doing the same thing a like 30 dollar china psu did, and that china one worked for my pc for about 3 years so this should at least get it too boot...shouldn't it?

You basically side graded in quality both are known for said issues.  It's possible it's the RAM too.  One or more of the stick could be faulty.  The CPU can be the problem too, but that's kinda rare.  Even the mobo can cause boot loop issues.

But, going over the list it could possible be the mobo if a better quality psu doesn't fix the problem.


Bloodshed and the Fenris-Wolf:

| CPU:  Ryzen 3 2200g(buying a 3900x in January for it) | CPU Cooler:  Stock at the moment(have a dark rock pro 4 for that 3900x) | Paste:  Kryonaut | Motherboard:  ASRock x470 Taichi(replacing with a Gigabyte x570 Aorus Elite) | RAM:  G.Skill Ripjaws V Series 32 GB (2 x 16 GB) DDR4-3200 | Boot Drives:  Crucial MX500 500 GB M.2-2280+Crucial BX500 120 GB 2.5" SSD | Storage Drives:  Toshiba X300 4 TB 128 MB Cache 3.5" HDD+PNY CS900 240 GB | GPU:  Sapphire Radeon VII 16 GB HBM2 Video Card | Case:  Cooler Master MasterBox MB511 RGB | PSU:  EVGA SuperNOVA G2 750 W 80+ Gold Certified Fully Modular ATX Power Supply w/CableMod E-Series Cable Kit (Black/Red) | Case Fans:  2 Corsair SP140 49.49 CFM 140 mm Fans | Displays:  AOC U2879VF 28.0" 3840x2160 60 Hz Monitor+AOC G2460PQU 24.0" 1920x1080 144 Hz Monitor(Replacing with an LG 240 Hz monitor) | Mouse:  Corsair M65 Pro RGB | Keyboard:  Ducky Shine 7 Blackout - MK Exclusive First Release - RGB LED Double Shot PBT Mechanical Keyboard with Silent Red Switches | Mousepad:  Gaya Entertainment Oversized Gaming Mousepad Doom | Audio:  Massdrop x AKG K7XX Audiophile Open-back Headphones+Audio-Technica ATR2500-USB Cardioid Condenser USB Microphone+Kingston HyperX Cloud II 7.1 Channel Headset+iBasso IT01 Dynamic Driver Audiophile In-Ear Monitors/Earbuds (Black)+Pair of Mackie MR624s(came with stands+isolation pads) | OSes:  Windows 10 Pro+openSUSE Tumbleweed |



VashTheStampede(ROG Zephyrus M GU502):

| CPU:  i7-9750h | RAM:  32GB Dual Channel 2666mhz CL 19(Stock+Samsung 16GB DDR4 PC4-21300, 2666MHZ, 260 PIN SODIMM, 1.2V, CL 19 ) | Storage:  1TB SSD with Optane | GPU:  Nvidia RTX 2060 | Display:  144hz 3ms | Mouse:  Corsair M65 Pro |

Link to post
Share on other sites
Posted · Original PosterOP
Just now, valdyrgramr said:

You basically side graded in quality both are known for said issues.  It's possible it's the RAM too.  One or more of the stick could be faulty.  The CPU can be the problem too, but that's kinda rare.  Even the mobo can cause boot loop issues.

But, going over the list it could possible be the mobo if a better quality psu doesn't fix the problem.

I tried other ram, and a new cpu, so either the MB or still the psu

Link to post
Share on other sites
Just now, ComputerNerdDude158 said:

I tried other ram, and a new cpu, so either the MB or still the psu

Ya, try one of the ones I mentioned if that fails then it's most likely the mobo.  


Bloodshed and the Fenris-Wolf:

| CPU:  Ryzen 3 2200g(buying a 3900x in January for it) | CPU Cooler:  Stock at the moment(have a dark rock pro 4 for that 3900x) | Paste:  Kryonaut | Motherboard:  ASRock x470 Taichi(replacing with a Gigabyte x570 Aorus Elite) | RAM:  G.Skill Ripjaws V Series 32 GB (2 x 16 GB) DDR4-3200 | Boot Drives:  Crucial MX500 500 GB M.2-2280+Crucial BX500 120 GB 2.5" SSD | Storage Drives:  Toshiba X300 4 TB 128 MB Cache 3.5" HDD+PNY CS900 240 GB | GPU:  Sapphire Radeon VII 16 GB HBM2 Video Card | Case:  Cooler Master MasterBox MB511 RGB | PSU:  EVGA SuperNOVA G2 750 W 80+ Gold Certified Fully Modular ATX Power Supply w/CableMod E-Series Cable Kit (Black/Red) | Case Fans:  2 Corsair SP140 49.49 CFM 140 mm Fans | Displays:  AOC U2879VF 28.0" 3840x2160 60 Hz Monitor+AOC G2460PQU 24.0" 1920x1080 144 Hz Monitor(Replacing with an LG 240 Hz monitor) | Mouse:  Corsair M65 Pro RGB | Keyboard:  Ducky Shine 7 Blackout - MK Exclusive First Release - RGB LED Double Shot PBT Mechanical Keyboard with Silent Red Switches | Mousepad:  Gaya Entertainment Oversized Gaming Mousepad Doom | Audio:  Massdrop x AKG K7XX Audiophile Open-back Headphones+Audio-Technica ATR2500-USB Cardioid Condenser USB Microphone+Kingston HyperX Cloud II 7.1 Channel Headset+iBasso IT01 Dynamic Driver Audiophile In-Ear Monitors/Earbuds (Black)+Pair of Mackie MR624s(came with stands+isolation pads) | OSes:  Windows 10 Pro+openSUSE Tumbleweed |



VashTheStampede(ROG Zephyrus M GU502):

| CPU:  i7-9750h | RAM:  32GB Dual Channel 2666mhz CL 19(Stock+Samsung 16GB DDR4 PC4-21300, 2666MHZ, 260 PIN SODIMM, 1.2V, CL 19 ) | Storage:  1TB SSD with Optane | GPU:  Nvidia RTX 2060 | Display:  144hz 3ms | Mouse:  Corsair M65 Pro |

Link to post
Share on other sites
Posted · Original PosterOP
Just now, valdyrgramr said:

Ya, try one of the ones I mentioned if that fails then it's most likely the mobo.  

I may try putting my psu in another pc and see if it boots for that one

Link to post
Share on other sites
Just now, ComputerNerdDude158 said:

I may try putting my psu in another pc and see if it boots for that one

Question, did you ever try to oc on this board?  Asking cuz it doesn't seem like that great of a board.  The vrms lack properly cooling for a z series board and it's a pretty low phase one too.  


Bloodshed and the Fenris-Wolf:

| CPU:  Ryzen 3 2200g(buying a 3900x in January for it) | CPU Cooler:  Stock at the moment(have a dark rock pro 4 for that 3900x) | Paste:  Kryonaut | Motherboard:  ASRock x470 Taichi(replacing with a Gigabyte x570 Aorus Elite) | RAM:  G.Skill Ripjaws V Series 32 GB (2 x 16 GB) DDR4-3200 | Boot Drives:  Crucial MX500 500 GB M.2-2280+Crucial BX500 120 GB 2.5" SSD | Storage Drives:  Toshiba X300 4 TB 128 MB Cache 3.5" HDD+PNY CS900 240 GB | GPU:  Sapphire Radeon VII 16 GB HBM2 Video Card | Case:  Cooler Master MasterBox MB511 RGB | PSU:  EVGA SuperNOVA G2 750 W 80+ Gold Certified Fully Modular ATX Power Supply w/CableMod E-Series Cable Kit (Black/Red) | Case Fans:  2 Corsair SP140 49.49 CFM 140 mm Fans | Displays:  AOC U2879VF 28.0" 3840x2160 60 Hz Monitor+AOC G2460PQU 24.0" 1920x1080 144 Hz Monitor(Replacing with an LG 240 Hz monitor) | Mouse:  Corsair M65 Pro RGB | Keyboard:  Ducky Shine 7 Blackout - MK Exclusive First Release - RGB LED Double Shot PBT Mechanical Keyboard with Silent Red Switches | Mousepad:  Gaya Entertainment Oversized Gaming Mousepad Doom | Audio:  Massdrop x AKG K7XX Audiophile Open-back Headphones+Audio-Technica ATR2500-USB Cardioid Condenser USB Microphone+Kingston HyperX Cloud II 7.1 Channel Headset+iBasso IT01 Dynamic Driver Audiophile In-Ear Monitors/Earbuds (Black)+Pair of Mackie MR624s(came with stands+isolation pads) | OSes:  Windows 10 Pro+openSUSE Tumbleweed |



VashTheStampede(ROG Zephyrus M GU502):

| CPU:  i7-9750h | RAM:  32GB Dual Channel 2666mhz CL 19(Stock+Samsung 16GB DDR4 PC4-21300, 2666MHZ, 260 PIN SODIMM, 1.2V, CL 19 ) | Storage:  1TB SSD with Optane | GPU:  Nvidia RTX 2060 | Display:  144hz 3ms | Mouse:  Corsair M65 Pro |

Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, valdyrgramr said:

Question, did you ever try to oc on this board?  Asking cuz it doesn't seem like that great of a board.  The vrms lack properly cooling for a z series board and it's a pretty low phase one too.  

I did overclock my cpu.....

Link to post
Share on other sites
10 minutes ago, ComputerNerdDude158 said:

I did overclock my cpu.....

Could be the board then.  Not sure about protections on z77 era boards.  Wasn't heavily focused on Intel at the time.  I didn't jump back to Intel until Haswell.  Which is z97.


Bloodshed and the Fenris-Wolf:

| CPU:  Ryzen 3 2200g(buying a 3900x in January for it) | CPU Cooler:  Stock at the moment(have a dark rock pro 4 for that 3900x) | Paste:  Kryonaut | Motherboard:  ASRock x470 Taichi(replacing with a Gigabyte x570 Aorus Elite) | RAM:  G.Skill Ripjaws V Series 32 GB (2 x 16 GB) DDR4-3200 | Boot Drives:  Crucial MX500 500 GB M.2-2280+Crucial BX500 120 GB 2.5" SSD | Storage Drives:  Toshiba X300 4 TB 128 MB Cache 3.5" HDD+PNY CS900 240 GB | GPU:  Sapphire Radeon VII 16 GB HBM2 Video Card | Case:  Cooler Master MasterBox MB511 RGB | PSU:  EVGA SuperNOVA G2 750 W 80+ Gold Certified Fully Modular ATX Power Supply w/CableMod E-Series Cable Kit (Black/Red) | Case Fans:  2 Corsair SP140 49.49 CFM 140 mm Fans | Displays:  AOC U2879VF 28.0" 3840x2160 60 Hz Monitor+AOC G2460PQU 24.0" 1920x1080 144 Hz Monitor(Replacing with an LG 240 Hz monitor) | Mouse:  Corsair M65 Pro RGB | Keyboard:  Ducky Shine 7 Blackout - MK Exclusive First Release - RGB LED Double Shot PBT Mechanical Keyboard with Silent Red Switches | Mousepad:  Gaya Entertainment Oversized Gaming Mousepad Doom | Audio:  Massdrop x AKG K7XX Audiophile Open-back Headphones+Audio-Technica ATR2500-USB Cardioid Condenser USB Microphone+Kingston HyperX Cloud II 7.1 Channel Headset+iBasso IT01 Dynamic Driver Audiophile In-Ear Monitors/Earbuds (Black)+Pair of Mackie MR624s(came with stands+isolation pads) | OSes:  Windows 10 Pro+openSUSE Tumbleweed |



VashTheStampede(ROG Zephyrus M GU502):

| CPU:  i7-9750h | RAM:  32GB Dual Channel 2666mhz CL 19(Stock+Samsung 16GB DDR4 PC4-21300, 2666MHZ, 260 PIN SODIMM, 1.2V, CL 19 ) | Storage:  1TB SSD with Optane | GPU:  Nvidia RTX 2060 | Display:  144hz 3ms | Mouse:  Corsair M65 Pro |

Link to post
Share on other sites
Posted · Original PosterOP
Just now, valdyrgramr said:

Could be the board then.  Not sure about protections on z77.  Wasn't heavily focused on Intel at the time.

I mean it's a lga 1155 board anyways, I should probably go ahead and rebuild my pc

Link to post
Share on other sites
Just now, ComputerNerdDude158 said:

I mean it's a lga 1155 board anyways, I should probably go ahead and rebuild my pc

Well, Zen 2 is being shown off next monday and probably released around July-September since AMD did state Q3.  However, you could get zen/zen+ or 8th/9th gen intel rig.  Or, if you wanted to stick to DDR3 then Haswell is about as far as you can go .  I'd outright avoid FX from AMD as the single thread is kinda ass on those.   If you meant going with a later gen platform.


Bloodshed and the Fenris-Wolf:

| CPU:  Ryzen 3 2200g(buying a 3900x in January for it) | CPU Cooler:  Stock at the moment(have a dark rock pro 4 for that 3900x) | Paste:  Kryonaut | Motherboard:  ASRock x470 Taichi(replacing with a Gigabyte x570 Aorus Elite) | RAM:  G.Skill Ripjaws V Series 32 GB (2 x 16 GB) DDR4-3200 | Boot Drives:  Crucial MX500 500 GB M.2-2280+Crucial BX500 120 GB 2.5" SSD | Storage Drives:  Toshiba X300 4 TB 128 MB Cache 3.5" HDD+PNY CS900 240 GB | GPU:  Sapphire Radeon VII 16 GB HBM2 Video Card | Case:  Cooler Master MasterBox MB511 RGB | PSU:  EVGA SuperNOVA G2 750 W 80+ Gold Certified Fully Modular ATX Power Supply w/CableMod E-Series Cable Kit (Black/Red) | Case Fans:  2 Corsair SP140 49.49 CFM 140 mm Fans | Displays:  AOC U2879VF 28.0" 3840x2160 60 Hz Monitor+AOC G2460PQU 24.0" 1920x1080 144 Hz Monitor(Replacing with an LG 240 Hz monitor) | Mouse:  Corsair M65 Pro RGB | Keyboard:  Ducky Shine 7 Blackout - MK Exclusive First Release - RGB LED Double Shot PBT Mechanical Keyboard with Silent Red Switches | Mousepad:  Gaya Entertainment Oversized Gaming Mousepad Doom | Audio:  Massdrop x AKG K7XX Audiophile Open-back Headphones+Audio-Technica ATR2500-USB Cardioid Condenser USB Microphone+Kingston HyperX Cloud II 7.1 Channel Headset+iBasso IT01 Dynamic Driver Audiophile In-Ear Monitors/Earbuds (Black)+Pair of Mackie MR624s(came with stands+isolation pads) | OSes:  Windows 10 Pro+openSUSE Tumbleweed |



VashTheStampede(ROG Zephyrus M GU502):

| CPU:  i7-9750h | RAM:  32GB Dual Channel 2666mhz CL 19(Stock+Samsung 16GB DDR4 PC4-21300, 2666MHZ, 260 PIN SODIMM, 1.2V, CL 19 ) | Storage:  1TB SSD with Optane | GPU:  Nvidia RTX 2060 | Display:  144hz 3ms | Mouse:  Corsair M65 Pro |

Link to post
Share on other sites
Posted · Original PosterOP
Just now, valdyrgramr said:

Well, Zen 2 is being shown off next monday and probably released around July-September since AMD did state Q3.  However, you could get zen/zen+ or 8th/9th gen intel rig.  Or, if you wanted to stick to DDR3 then Haswell is about as far as you can go .  I'd outright avoid FX from AMD as the single thread is kinda ass on those.   If you meant going with a later gen platform.

I'll probably do ryzen :)

Link to post
Share on other sites
Just now, ComputerNerdDude158 said:

I'll probably do ryzen :)

If you wanna upgrade right now the tomahawk b450+2600 is a pretty good deal.


Bloodshed and the Fenris-Wolf:

| CPU:  Ryzen 3 2200g(buying a 3900x in January for it) | CPU Cooler:  Stock at the moment(have a dark rock pro 4 for that 3900x) | Paste:  Kryonaut | Motherboard:  ASRock x470 Taichi(replacing with a Gigabyte x570 Aorus Elite) | RAM:  G.Skill Ripjaws V Series 32 GB (2 x 16 GB) DDR4-3200 | Boot Drives:  Crucial MX500 500 GB M.2-2280+Crucial BX500 120 GB 2.5" SSD | Storage Drives:  Toshiba X300 4 TB 128 MB Cache 3.5" HDD+PNY CS900 240 GB | GPU:  Sapphire Radeon VII 16 GB HBM2 Video Card | Case:  Cooler Master MasterBox MB511 RGB | PSU:  EVGA SuperNOVA G2 750 W 80+ Gold Certified Fully Modular ATX Power Supply w/CableMod E-Series Cable Kit (Black/Red) | Case Fans:  2 Corsair SP140 49.49 CFM 140 mm Fans | Displays:  AOC U2879VF 28.0" 3840x2160 60 Hz Monitor+AOC G2460PQU 24.0" 1920x1080 144 Hz Monitor(Replacing with an LG 240 Hz monitor) | Mouse:  Corsair M65 Pro RGB | Keyboard:  Ducky Shine 7 Blackout - MK Exclusive First Release - RGB LED Double Shot PBT Mechanical Keyboard with Silent Red Switches | Mousepad:  Gaya Entertainment Oversized Gaming Mousepad Doom | Audio:  Massdrop x AKG K7XX Audiophile Open-back Headphones+Audio-Technica ATR2500-USB Cardioid Condenser USB Microphone+Kingston HyperX Cloud II 7.1 Channel Headset+iBasso IT01 Dynamic Driver Audiophile In-Ear Monitors/Earbuds (Black)+Pair of Mackie MR624s(came with stands+isolation pads) | OSes:  Windows 10 Pro+openSUSE Tumbleweed |



VashTheStampede(ROG Zephyrus M GU502):

| CPU:  i7-9750h | RAM:  32GB Dual Channel 2666mhz CL 19(Stock+Samsung 16GB DDR4 PC4-21300, 2666MHZ, 260 PIN SODIMM, 1.2V, CL 19 ) | Storage:  1TB SSD with Optane | GPU:  Nvidia RTX 2060 | Display:  144hz 3ms | Mouse:  Corsair M65 Pro |

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×