Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Recommended Posts

Posted · Original PosterOP

I have recently installed Linux MATE on my laptop, instead of the Mint cinnamon. But im experiencing a little bit of problems. It doesnt seem to like when i try to scroll with 2 fingers on the touchpad. It only moves the mouse whenever i try to scroll with 2 fingers, i need to have 3 fingers on the touchpad for it to scroll. I even went to the touchpad settings and looked, there was an option called "two finger scrolling" and it was enabled! Why doesnt it work?

 

EDIT: it seems like even if i disable the option were it disables the touchpad when typing, it still disables it. I go into touchpad settings, and there is an option called "disable touchpad when typing" and ive disabled that option, still doesnt f-ing work!

Link to post
Share on other sites
Posted · Original PosterOP
2 minutes ago, Dat Guy said:

MATE is not "Linux MATE", it is available for a number of operating systems.

well i am new to linux or whatever, so im sorry if i get things worng. but my problem is still here.

Link to post
Share on other sites

what laptop is it? and do you know what brand of touchpad it is? 


DISCLAIMER: ANYTHING I SAY COULD BE WRONG. DO YOUR OWN RESEARCH! 

Have a look at my set up your linux gaming pc from start to finish topic if you want to get started with linux :) 

My Laptop: HP EliteBook 9470m | I5 3437U | HD4000 | 1TB SSD | 16GB RAM | Ubuntu Disco Dingo

My Phone: LG G3 | 16GB | 64GB SD | Lineage OS

Link to post
Share on other sites
Posted · Original PosterOP
Just now, firelighter487 said:

what laptop is it? and do you know what brand of touchpad it is? 

Its the Lenovo Thinkpad l440, i5 4300m etc. And when i had windows and Mint cinnamon i didnt have any problems with using both the touchpad and keyboard at the same time. But anyways, i dont know what kind of touchpad, but if it helps it did use Synaptics program or whatever it is.

Link to post
Share on other sites

try in terminal: synclient VertTwoFingerScroll=1


DISCLAIMER: ANYTHING I SAY COULD BE WRONG. DO YOUR OWN RESEARCH! 

Have a look at my set up your linux gaming pc from start to finish topic if you want to get started with linux :) 

My Laptop: HP EliteBook 9470m | I5 3437U | HD4000 | 1TB SSD | 16GB RAM | Ubuntu Disco Dingo

My Phone: LG G3 | 16GB | 64GB SD | Lineage OS

Link to post
Share on other sites
1 hour ago, Dat Guy said:

MATE is not "Linux MATE", it is available for a number of operating systems.

This^

 

But anyway what distro are you running? I guess Mint?

 

In that case, check whether you are running libinput or synaptics xorg driver by checking the packages installed  `sudo apt list --installed | grep synaptics`

 

Does it return something?

 

 

 

Link to post
Share on other sites
Posted · Original PosterOP
1 hour ago, Chunchunmaru_ said:

This^

 

But anyway what distro are you running? I guess Mint?

 

In that case, check whether you are running libinput or synaptics xorg driver by checking the packages installed  `sudo apt list --installed | grep synaptics`

 

Does it return something?

 

 

 

If i do that "sudo apt list --installed | grep synaptics" all i get back is " WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

Link to post
Share on other sites
Posted (edited)
9 minutes ago, DankDeuxez said:

If i do that "sudo apt list --installed | grep synaptics" all i get back is " WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

Ok so you are using the libinput driver, create a file in /etc/X11/xorg.conf.d/30-touchpad.conf
Paste this
 

Section "InputClass"
    Identifier "libinput touchpad catchall"
    MatchIsTouchpad "on"
    MatchDevicePath "/dev/input/event*"
    Driver "libinput"
    Option "Tapping" "on"
    Option "NaturalScrolling" "true"
    Option "ClickMethod" "clickfinger"
    Option "ScrollMethod" "twofinger"
EndSection
Edited by Chunchunmaru_
Link to post
Share on other sites
Posted · Original PosterOP
13 minutes ago, Chunchunmaru_ said:

Ok so you are using the libinput driver, create a file in /etc/X11/xorg.conf.d/30-touchpad.conf
Paste this
 


Section "InputClass"
    Identifier "libinput touchpad catchall"
    MatchIsTouchpad "on"
    MatchDevicePath "/dev/input/event*"
    Driver "libinput"
    Option "Tapping" "on"
    Option "NaturalScrolling" "true"
    Option "ScrollMethod" "twofinger"
EndSection

 

are the xorg.conf.d a text file or a folder? Either way i cant find it in the X11 folder..

Link to post
Share on other sites
21 minutes ago, DankDeuxez said:

are the xorg.conf.d a text file or a folder? Either way i cant find it in the X11 folder..

/etc/X11/xorg.conf.d is a folder

30-touchpad.conf is a file, you need to create it with a text editor with root

 

like sudo mousepad /etc/X11/xorg.conf.d/30-touchpad.conf

 

mousepad is a text editor but you can use one of your choice

Link to post
Share on other sites
Posted · Original PosterOP
42 minutes ago, Chunchunmaru_ said:

/etc/X11/xorg.conf.d is a folder

30-touchpad.conf is a file, you need to create it with a text editor with root

 

like sudo mousepad /etc/X11/xorg.conf.d/30-touchpad.conf 

 

mousepad is a text editor but you can use one of your choice

I cant find the Xorg.conf.d folder tho? image.png.459583ca9e364bbac0357928e953f084.png

Link to post
Share on other sites
5 hours ago, DankDeuxez said:

I cant find the Xorg.conf.d folder tho? image.png.459583ca9e364bbac0357928e953f084.png

Just create a folder and the file. Proper name and everything then reboot. 


Sudo make me a sandwich 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Buy VPN

×