Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Kindachris

Windows 10 update just flashed my bios

Recommended Posts

Posted (edited) · Original PosterOP

Hi guys i am new to this forum so hopefully this first post will be useful to anyone who has the same query.

 

I recently booted up my asus gl503ge laptop after a week away from home and as expected there were a bunch of updates from this month's patch tuesday. After the update was done i restarted and checked for updates again. Then a weird firmware update came up and started downloading. This was marked as from Asustek(find images in attachment below). I got another restart notification and after clicking it my laptop restarted into the uefi bios and started updating it. I was confused as this was the first time this ever happened. I always assumed that firmware updates were only for surface laptops but has windows update also started providing bios firmware for third-party oems like asus now. I thought it was a virus or some kind of attack but after checking asus site and scanning with antivirus (bitdefender) i cant find any traces of malware activity. Is this some new undocumented feature of windows update and has anyone else gotten it or am i some kinda guinea pig 😂

IMG_20190515_234052.jpg

IMG_20190515_233344.jpg

Screenshot_20190515-233513.png

Edited by Kindachris
General spelling correction. Sorry on mobile.
Link to post
Share on other sites

MSI got it also.

I would suggest, if you dont have any issues don't update the bios


CPU:i7 9700k, Mobo: MSI MPG Z390 Gaming Edge AC, RAM:Corsair Vengeance LPX 16GB 3200MHz DDR4 GPU:MSI RTX 2070 ARMOR 8GB OC, Storage:Samsung SSD 970 EVO NVMe M.2 250GB, 2x SSD ADATA PRO SP900 256GB, SSD mushkin chronos 120GB, HDD WD CB 2TB, HDD GREEN 2TB, PSU:Corsair CS 650 M Gold, Display(s): LG 27UK600-W HDR10 4K, Samsung P2470HD, , Cooling:Fazn CPU Cooler Aero 120T, Keyboard: Corsair K95 Platinum RGB mx Rapidfire, Mouse:Razer Naga Mouse 2014Headset: Razer Kraken 7.1 Chroma, Sound: Logitech X-540 5.1 Surround Sound Speaker

Link to post
Share on other sites
Posted · Original PosterOP
Just now, Constantin said:

MSI got it also.

I would suggest, if you dont have any issues don't update the bios

Hi thanks for the reply. Really didn't intend for a bios update. I assumed it was some driver update but was taken aback when ezflash booted up and started flashing the new bios. I guess this is some new feature of windows updates. Looked around on google but couldn't find any kind of new article suggesting that this was some new windows update feature.

Link to post
Share on other sites
Just now, Kindachris said:

Hi thanks for the reply. Really didn't intend for a bios update. I assumed it was some driver update but was taken aback when ezflash booted up and started flashing the new bios. I guess this is some new feature of windows updates. Looked around on google but couldn't find any kind of new article suggesting that this was some new windows update feature.

It's possible there was some kind of critical bug in the BIOS, thus warranting the update.

I am unsure however.


So rise up, all ye lost ones, as one, we'll claw the clouds

Link to post
Share on other sites
Posted · Original PosterOP
Just now, Radium_Angel said:

It's possible there was some kind of critical bug in the BIOS, thus warranting the update.

I am unsure however.

Couldnt find changelog for the update just the generic stability and security update blurb

Link to post
Share on other sites
Just now, Kindachris said:

Couldnt find changelog for the update just the generic stability and security update blurb

Hmmm..

check perhaps (I don't use Win10, so again, guessing here) your update options and see if you've subscribed to all of them, or just critical stuff


So rise up, all ye lost ones, as one, we'll claw the clouds

Link to post
Share on other sites
Posted · Original PosterOP
21 minutes ago, Curious Pineapple said:

Maybe it's due to the Zombieload exploit, just get every machine possible updated.

Yes that sounds plausible. Only weird thing is the signature is from 2018. Then again the private disclosure was probably done then and the fix was with Microsoft in testing and was probably just released to coincide with all the other bug fixes now that the exploits are disclosed publicly.

Link to post
Share on other sites
Posted (edited) · Original PosterOP
28 minutes ago, Radium_Angel said:

Hmmm..

check perhaps (I don't use Win10, so again, guessing here) your update options and see if you've subscribed to all of them, or just critical stuff

Subscribed to all updates. Including other Microsoft products. Guess this is a part of the Zombieload fix as Curious Pineapple stated below.

Edited by Kindachris
Spelling again
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×