Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
xcvtop

iperf issue

Recommended Posts

Posted · Original PosterOP

Hi I am currently testing speed on my network ahead of an upgrade and are currently running into an issue with Iperf3 and server 2012.

 

I can run Iperf as a client from my server 2012 file server, but when i try to run it as a server and connect to it i get the error "iperf3: error - unable to connect to server: Connection timed out".

 

I have opened the port for inbound on the server with no success.

 

any thoughts?

Link to post
Share on other sites

Maybe your firewall is blocking the connection?


Current PC

CPUIntel Core i7 6700 (@3.4Ghz)

GPUGTX 1080 8GB FTW EVGA

MotherboardGA-Z170-HD3P

RAM: Corsair Vengeance LPX (2x8GB) DDR4 2400 Mhz

Storage: Samsung 970 EVO Plus 1TB,

Storage 2: Samsung 850 EVO 250GB

Storage 3: Hyper X 240GB

Storage 4: 1TB WD Black

PSU: Corsair RM750 80 Plus Gold 750W

Peripherals: Logitech G502 Hero//Corsair K70 MK 2 Cherry MX Red

Display: BenQ XL2430T 24-inch 144Hz

Link to post
Share on other sites

Did you add the rule for tcp, udp or both?

iPerf can use both and I think it uses tcp by default, I just open both udp and tcp for iperf.

Link to post
Share on other sites
Posted · Original PosterOP
1 hour ago, mtz_federico said:

Did you add the rule for tcp, udp or both?

iPerf can use both and I think it uses tcp by default, I just open both udp and tcp for iperf.

I added it as an incoming rule for port 5001 (both TCPand UDP) as stated when i start the iperf2 server but connection still cannot be made

Link to post
Share on other sites

Can you pingteh server from the PC you are trying to iPerf from?


Current PC

CPUIntel Core i7 6700 (@3.4Ghz)

GPUGTX 1080 8GB FTW EVGA

MotherboardGA-Z170-HD3P

RAM: Corsair Vengeance LPX (2x8GB) DDR4 2400 Mhz

Storage: Samsung 970 EVO Plus 1TB,

Storage 2: Samsung 850 EVO 250GB

Storage 3: Hyper X 240GB

Storage 4: 1TB WD Black

PSU: Corsair RM750 80 Plus Gold 750W

Peripherals: Logitech G502 Hero//Corsair K70 MK 2 Cherry MX Red

Display: BenQ XL2430T 24-inch 144Hz

Link to post
Share on other sites
14 minutes ago, xcvtop said:

I added it as an incoming rule for port 5001 (both TCPand UDP) as stated when i start the iperf2 server but connection still cannot be made

Are both clients iperf2? One of them could be iperf3

Link to post
Share on other sites
1 minute ago, mtz_federico said:

Are both clients iperf2? One of them could be iperf3

Yeah to be fair. You do mention using iPerf3 in your first post, but later on you change it to iPerf2?


Current PC

CPUIntel Core i7 6700 (@3.4Ghz)

GPUGTX 1080 8GB FTW EVGA

MotherboardGA-Z170-HD3P

RAM: Corsair Vengeance LPX (2x8GB) DDR4 2400 Mhz

Storage: Samsung 970 EVO Plus 1TB,

Storage 2: Samsung 850 EVO 250GB

Storage 3: Hyper X 240GB

Storage 4: 1TB WD Black

PSU: Corsair RM750 80 Plus Gold 750W

Peripherals: Logitech G502 Hero//Corsair K70 MK 2 Cherry MX Red

Display: BenQ XL2430T 24-inch 144Hz

Link to post
Share on other sites
Posted · Original PosterOP
On 5/15/2019 at 3:20 PM, Ardu said:

Can you pingteh server from the PC you are trying to iPerf from?

yes i can no problem

On 5/15/2019 at 3:32 PM, mtz_federico said:

Are both clients iperf2? One of them could be iperf3

yes both server and client are using iperf2, i switched to iperf2 to see if there were any issues specific to iperf3

Link to post
Share on other sites
4 hours ago, xcvtop said:

yes i can no problem

yes both server and client are using iperf2, i switched to iperf2 to see if there were any issues specific to iperf3

And it still doesn’t work?

weird

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×