Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Seithon

New Build, Chrome does not load pages. Other browsers are fine.

Recommended Posts

Posted · Original PosterOP

Hey folks, 

 

So, fresh install of windows 10 on a newly built PC. Everything is up to date and drivers etc are installed. Edge, steam, discord etc all work fine. We've setup public DNS (tried google 8.8.8.8 and openDNS ones) and while everything else network wise works fine, google chrome just shits the bed constantly.

 

We start it up, go to a website and nothing loads for a very long time, then maybe after a while we get a text only view of the site. So a title and some links etc and then nothing else. 

 

We've tried resetting the DNS, the winsock thing... checked for extraneous extensions that might have been loaded automatically etc. And turned off hardware acceleration and generally followed a few different guides on how to "fix" this issue. But so far no dice :(

 

Anyone here have any good suggestions ?

Link to post
Share on other sites

This doesn't sound like a network issue, more like a chrome issue. Try reinstalling maybe?


75% of what I say is sarcastic

 

So is the rest probably

Link to post
Share on other sites

i have a different issue but i got the chrome beta and it has gone away. now all i gotta do is wait for it to launch into stable....

i read an article on reddit that was from forbes magazine about how ms found a huge bug in windows 10 all browsers and they working on fixing it

Link to post
Share on other sites
Posted · Original PosterOP

Sadly, already tried reinstalling chrome. Whatever it is it seems to persist through installs. Also tried resetting it's internal settings :/

It's almost as if it's trying to run some kind of internal proxy (which i checked for) which fails. Anyhow will try the Beta as Zyco suggested :)

Link to post
Share on other sites
Posted · Original PosterOP

hey folks, 

 

So, tried the suggested fixes, Things are still broken. Its as if chrome has some kind of internal proxy or DNS which is broken.

 

We also tried changing to chromium and the new Edge beta, and anything using the chrome engine is behaving the same way :(

 

Anyone else have any new ideas ?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×