Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
orangekaic

Limited Download Throughput for Desktop

Recommended Posts

Posted · Original PosterOP

So I just moved into a new home and have been setting up the internet here, but it seems like my desktop does not like the new internet environment. Originally, I tested to see if it was the Ubiquiti gear I had set up, but every other hardwired device was getting the expected 500-600 Mbps whereas the desktop was getting somewhere between 140-180 Mbps. This result stays consistent among the devices whether I plug the connection directly into the modem, USG-3P (Router), or US-16-150W (Switch). The Desktop in question is using a Realtek GBE Family Controller with a confirmed 1.0 Gbps LAN connection on both the UniFi controller and the native Windows 10 Network Adapter Properties.

This is what I have tried so far:

  • ipconfig /flushdns

  • Used both ISP and Google DNS

  • Enabled/disabled QoS Packet Scheduler service

  • Updating Realtek Drivers via Realtek's site

  • Used MSI Live Update to update drivers

By the way, the upstream for this desktop is actually the expected amount (25Mbps), which makes it all the more confusing for me. So far, my Googling has failed me. Any troubleshooting ideas?

Link to post
Share on other sites
Posted · Original PosterOP

I was running it to fast, speedtest.net, and dslreports

 

I tried using iperf with the problematic Desktop as the client and another laptop as the server after your suggestion. I'm getting similar results.

 

[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-1.00   sec  14.1 MBytes   118 Mbits/sec
[  4]   1.00-2.00   sec  14.8 MBytes   124 Mbits/sec
[  4]   2.00-3.00   sec  15.2 MBytes   128 Mbits/sec
[  4]   3.00-4.00   sec  14.9 MBytes   125 Mbits/sec
[  4]   4.00-5.00   sec  14.9 MBytes   125 Mbits/sec
[  4]   5.00-6.00   sec  14.9 MBytes   125 Mbits/sec
[  4]   6.00-7.00   sec  15.0 MBytes   126 Mbits/sec
[  4]   7.00-8.00   sec  14.8 MBytes   124 Mbits/sec
[  4]   8.00-9.00   sec  14.9 MBytes   125 Mbits/sec
[  4]   9.00-10.00  sec  15.2 MBytes   128 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-10.00  sec   149 MBytes   125 Mbits/sec                  sender
[  4]   0.00-10.00  sec   148 MBytes   125 Mbits/sec                  receiver
 

 

 

Link to post
Share on other sites
Posted · Original PosterOP

I might as well add that I have checked to see that hardware offloading is enabled on my USG-3P, and whether QoS-related services were running on the network (IPS/DPI/Smart Queue all disabled).

Link to post
Share on other sites
Posted · Original PosterOP

Late post but I actually found out what the problem was. My desktop needed a winsock reset. I don't remember what the tcp/ip reset lines were, but you can type in an elevated cmd

 

netsh winsock reset

 

and then reboot.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×