Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
EpicestGamer411

My pc is not showing a display i have tried everything but nothing is working

Recommended Posts

Gonna need more details

 

What are the specs? What are you connecting your video cable to (where on the pc and what monitor)?


𝓗𝓲 𝓱𝓸𝔀 𝓪𝓻𝓮 𝔂a

Link to post
Share on other sites
Posted · Original PosterOP
5 minutes ago, Slottr said:

Gonna need more details

 

What are the specs? What are you connecting your video cable to (where on the pc and what monitor)?

Fx 8360

8gb ddr3 

powercolor rx 580 8gb

just a random monitor that ive had working for a long time

im connecting it to a 600w psu and im 100% sure everything is plugged in

Link to post
Share on other sites
4 minutes ago, EpicestGamer411 said:

Fx 8360

8gb ddr3 

powercolor rx 580 8gb

just a random monitor that ive had working for a long time

im connecting it to a 600w psu and im 100% sure everything is plugged in

What power supply is that? Do you have any other cards to test?


𝓗𝓲 𝓱𝓸𝔀 𝓪𝓻𝓮 𝔂a

Link to post
Share on other sites
Posted · Original PosterOP
3 minutes ago, Hyper_panda369 said:

your GPU might be on a quiet mode, making the fans not spin

Ok idk how to fix that and im not sure how that makes my display not appear

Link to post
Share on other sites
Just now, EpicestGamer411 said:

Corsair cx650m

and i have a old gt 9500

Give the other card a try


𝓗𝓲 𝓱𝓸𝔀 𝓪𝓻𝓮 𝔂a

Link to post
Share on other sites
7 minutes ago, EpicestGamer411 said:

So does anyone else have anymore ideas

Dude, I can sense stress in you from my chair. Calm down and drink a glass of water.

 

Once your friend gives you a DVI cable, try using your GT 9500 instead of your RX 580. Try eliminating one failure point at a time, rather than rushing everything. Good luck!


Primary Desktop PC: Intel® Xeon® X5675 @ 4.62 GHz 1.4V || NZXT HAVIK 140 & Noctua NA-SRC10 || ASUS P6X58-E WS || Crucial DDR3-1606 8-11-11-28 (2x4GB) || ASUS STRIX GTX 770 || Samsung 860 EVO 1TB 2.5" SSD || WD Green 1TB 3.5" HDD (7.2K RPM) || Fractal Design Meshify C TG (White) || Corsair AX860i & White CableMod ModFlex™ Cables || Logitech G710+ (Cherry MX Browns) || Logitech G502 Proteus Spectrum || Logitech G27 Racing Wheel || Samsung 23.6" 1080p 60Hz PLS (OC'd to 75Hz) || CPU-Z Validation

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×