Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Cupar19

Enable 144hz?

Recommended Posts

Posted · Original PosterOP

so i just bought myself a  Samsung LC27JG52QQUXEN monitor which is 1440p 144hz but i cant get 144hz to work.

advanced display properties and nvidia control panel both show the maximum refresh rate as being 60hz.

i am using displayport and also have 2 60hz monitors, one connected to the nvidia gpu and the other on the intel igpu

im on the latest version of windows 10

 

anybody know how to fix this?

Link to post
Share on other sites

Can you check the monitor's OSD to see if it shows 144Hz or 60Hz?

Otherwise, they do mention this in the manual:

image.png.fc50c32714378f1f053e55c3b54bcfd3.png


"There's no such thing as perfect. You're beautiful as you are Courage. With all your imperfections you can do anything." - Bathtub Barracuda

"How can someone win if winning means that someone loses" - Scatman John

"We’re here to make you think about death and get sad and stuff.” - Scott Pilgrim

Gear:                           .                                                                                                                         .

Spoiler

PC:

CPU: AMD Ryzen 7 1700 || Motherboard: MSI X370 Gaming Pro Carbon || RAM: 2x8GB G.Skill TridentZ RGB 3200Mhz (running at 2933Mhz) || GPU: Gigabyte Auros RX 580 4GB || Storage: Samsung 960 EVO 250GB + Seagate Barracuda 2TB || Cooling: Be Quiet! Dark Rock 3 || Case: Thermaltake Core G21 TG || PSU: Corsair RMx 750W

Peripherals:

Headphones: Beyerdynamic DT-990 250 Ohm || Mouse: Roccat Kiro || Keyboard: Coolermaster Masterkeys Pro S RGB || Mousepad: CM Storm Swift-RX XXL || Graphics tablet: Wacom Intuos Pen Small

Old PC:

CPU: AMD Athlon X2 255 || Motherboard: ASUS M4A89GTD PRO || RAM: 4x2GB DDR3 || GPU: Nvidia Quadro 512MB || Case: Antec Sonata III || PSU: Antec Earthwatts 500W Bronze

Minibois' Digital Art Thread

Reviews: Coolermaster Masterkeys Pro S RGB || Wacom Intuos Pen Small || Roccat Kiro

Threads: Pokémon Thread || Dutch Talk || Super Smash Bros. Melee Thread

Setup: Current setup

Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, Minibois said:

Can you check the monitor's OSD to see if it shows 144Hz or 60Hz?

Otherwise, they do mention this in the manual:

image.png.fc50c32714378f1f053e55c3b54bcfd3.png

oh yea forgot to mention it is on DP 1.2 and 144hz is the set refreshrate

Link to post
Share on other sites
Posted · Original PosterOP
2 minutes ago, MCManiac52 said:

What GPU are you running? Does it definitely support DP 1.2? 

a gtx 1060 6gb, how do i find out if it supports DP 1.2

 

Link to post
Share on other sites
4 minutes ago, Cupar19 said:

oh yea forgot to mention it is on DP 1.2 and 144hz is the set refreshrate

1 minute ago, Cupar19 said:

a gtx 1060 6gb, how do i find out if it supports DP 1.2

 

That has Displayport 1.4, so that shouldn't be the issue..

Did you use the original cable that came with the monitor? In the past I have seen people not use the original cable and not get full Hz.

 

I'm assuming this monitor is connected to your Nvidia GPU? Could you try another Displayport output if you have it?


"There's no such thing as perfect. You're beautiful as you are Courage. With all your imperfections you can do anything." - Bathtub Barracuda

"How can someone win if winning means that someone loses" - Scatman John

"We’re here to make you think about death and get sad and stuff.” - Scott Pilgrim

Gear:                           .                                                                                                                         .

Spoiler

PC:

CPU: AMD Ryzen 7 1700 || Motherboard: MSI X370 Gaming Pro Carbon || RAM: 2x8GB G.Skill TridentZ RGB 3200Mhz (running at 2933Mhz) || GPU: Gigabyte Auros RX 580 4GB || Storage: Samsung 960 EVO 250GB + Seagate Barracuda 2TB || Cooling: Be Quiet! Dark Rock 3 || Case: Thermaltake Core G21 TG || PSU: Corsair RMx 750W

Peripherals:

Headphones: Beyerdynamic DT-990 250 Ohm || Mouse: Roccat Kiro || Keyboard: Coolermaster Masterkeys Pro S RGB || Mousepad: CM Storm Swift-RX XXL || Graphics tablet: Wacom Intuos Pen Small

Old PC:

CPU: AMD Athlon X2 255 || Motherboard: ASUS M4A89GTD PRO || RAM: 4x2GB DDR3 || GPU: Nvidia Quadro 512MB || Case: Antec Sonata III || PSU: Antec Earthwatts 500W Bronze

Minibois' Digital Art Thread

Reviews: Coolermaster Masterkeys Pro S RGB || Wacom Intuos Pen Small || Roccat Kiro

Threads: Pokémon Thread || Dutch Talk || Super Smash Bros. Melee Thread

Setup: Current setup

Link to post
Share on other sites
1 minute ago, Cupar19 said:

a gtx 1060 6gb, how do i find out if it supports DP 1.2

 

The 1060 does support DP 1.2, what about the cable? I've seen cheap cables that aren't properly certified cause issues.

It might be worth trying just the 144Hz monitor plugged in and see if it works then


I ilke trains.

Link to post
Share on other sites
Posted · Original PosterOP
Just now, Minibois said:

That has Displayport 1.4, so that shouldn't be the issue..

Did you use the original cable that came with the monitor? In the past I have seen people not use the original cable and not get full Hz.

 

I'm assuming this monitor is connected to your Nvidia GPU? Could you try another Displayport output if you have it?

 

Just now, MCManiac52 said:

The 1060 does support DP 1.2, what about the cable? I've seen cheap cables that aren't properly certified cause issues.

It might be worth trying just the 144Hz monitor plugged in and see if it works then

cable is the one that came with the monitor , the gpu has only one displayport output and even just the 144hz monitor does not fix it

Link to post
Share on other sites
4 minutes ago, Cupar19 said:

 

cable is the one that came with the monitor , the gpu has only one displayport output and even just the 144hz monitor does not fix it

I did find these instructions; which basically goes over how you change the refresh rate in the Nvidia control panel:

Quote

1. Make sure you are NOT using HDMI... you will need DisplayPort or DVI

2. Go to the NIVIDIA Control Panel (you can easily access this by right clicking on your desktop) 

3. At the top of the NIVIDIA Control Panel will say "1. Select the display you would like to change." make sure you are on the correct display.

3. Under "2. Choose the resolution" on the NIVIDIA control panel, you will need to go to the "Resolution:" section and scroll down to the section titled "PC" (NOT "Ultra HD, HD, SD") from there you can click 1920 x 1080 and the Refresh rate options to the right will change and you will now have the option for 144Hz

You might have done this already, but it's worth double checking.

 

If the monitor came with a HDMI cable too, try that one out (on HDMI of the monitor) and see if that makes a difference.

Otherwise I have seen people online suggest a driver reinstall (using DDU).


"There's no such thing as perfect. You're beautiful as you are Courage. With all your imperfections you can do anything." - Bathtub Barracuda

"How can someone win if winning means that someone loses" - Scatman John

"We’re here to make you think about death and get sad and stuff.” - Scott Pilgrim

Gear:                           .                                                                                                                         .

Spoiler

PC:

CPU: AMD Ryzen 7 1700 || Motherboard: MSI X370 Gaming Pro Carbon || RAM: 2x8GB G.Skill TridentZ RGB 3200Mhz (running at 2933Mhz) || GPU: Gigabyte Auros RX 580 4GB || Storage: Samsung 960 EVO 250GB + Seagate Barracuda 2TB || Cooling: Be Quiet! Dark Rock 3 || Case: Thermaltake Core G21 TG || PSU: Corsair RMx 750W

Peripherals:

Headphones: Beyerdynamic DT-990 250 Ohm || Mouse: Roccat Kiro || Keyboard: Coolermaster Masterkeys Pro S RGB || Mousepad: CM Storm Swift-RX XXL || Graphics tablet: Wacom Intuos Pen Small

Old PC:

CPU: AMD Athlon X2 255 || Motherboard: ASUS M4A89GTD PRO || RAM: 4x2GB DDR3 || GPU: Nvidia Quadro 512MB || Case: Antec Sonata III || PSU: Antec Earthwatts 500W Bronze

Minibois' Digital Art Thread

Reviews: Coolermaster Masterkeys Pro S RGB || Wacom Intuos Pen Small || Roccat Kiro

Threads: Pokémon Thread || Dutch Talk || Super Smash Bros. Melee Thread

Setup: Current setup

Link to post
Share on other sites
5 minutes ago, Cupar19 said:

 

cable is the one that came with the monitor , the gpu has only one displayport output and even just the 144hz monitor does not fix it

Double check your display drivers are up to date, then maybe try factory resetting the monitor, plug it into the PC, set the monitor to the right refresh rate, then set it it Nvidia CP


I ilke trains.

Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, Minibois said:

I did find these instructions; which basically goes over how you change the refresh rate in the Nvidia control panel:

You might have done this already, but it's worth double checking.

 

If the monitor came with a HDMI cable too, try that one out (on HDMI of the monitor) and see if that makes a difference.

Otherwise I have seen people online suggest a driver reinstall (using DDU).

yeah already tried that

Just now, MCManiac52 said:

Double check your display drivers are up to date, then maybe try factory resetting the monitor, plug it into the PC, set the monitor to the right refresh rate, then set it it Nvidia CP

just updated drivers and already tried the rest and nothing changed it

Link to post
Share on other sites
Posted · Original PosterOP

ok wait so after a driver update and a pc restart i now have the option to choose 120hz but still not 144

Link to post
Share on other sites
2 minutes ago, Cupar19 said:

ok wait so after a driver update and a pc restart i now have the option to choose 120hz but still not 144

That's... A weird number.

This is what the different displayport versions support at 1440p:

image.png.4b7c3ec20a50789191e612722b2f4851.png

That's 1.0/1.1, 1.2, 1.3/1.4 respectively and nowhere does it mention 120Hz. max..

 

Apparently this is a know issue with Nvidia cards though, just Googling around about it.

People are suggesting kind of the 'basic' answers; such as reinstalling drivers, trying different cables, rolling back to a previous driver, etc. and sometimes some of the solutions do work for the OP of the thread.

 

If you want to experiment a bit, you could try out loading some older drivers and checking to see if there is a difference in what refresh rate you can choose.

 

Also, when you told me this:

11 minutes ago, Cupar19 said:

yeah already tried that

Which of the three things were you referring to:

13 minutes ago, Minibois said:

I did find these instructions; which basically goes over how you change the refresh rate in the Nvidia control panel:

13 minutes ago, Minibois said:

If the monitor came with a HDMI cable too, try that one out (on HDMI of the monitor) and see if that makes a difference.

13 minutes ago, Minibois said:

Otherwise I have seen people online suggest a driver reinstall (using DDU).

Or was it just all three. Because I am still somewhat curious about connecting the HDMI on your card to HDMI 2 (that's the one next to the Displayport).


"There's no such thing as perfect. You're beautiful as you are Courage. With all your imperfections you can do anything." - Bathtub Barracuda

"How can someone win if winning means that someone loses" - Scatman John

"We’re here to make you think about death and get sad and stuff.” - Scott Pilgrim

Gear:                           .                                                                                                                         .

Spoiler

PC:

CPU: AMD Ryzen 7 1700 || Motherboard: MSI X370 Gaming Pro Carbon || RAM: 2x8GB G.Skill TridentZ RGB 3200Mhz (running at 2933Mhz) || GPU: Gigabyte Auros RX 580 4GB || Storage: Samsung 960 EVO 250GB + Seagate Barracuda 2TB || Cooling: Be Quiet! Dark Rock 3 || Case: Thermaltake Core G21 TG || PSU: Corsair RMx 750W

Peripherals:

Headphones: Beyerdynamic DT-990 250 Ohm || Mouse: Roccat Kiro || Keyboard: Coolermaster Masterkeys Pro S RGB || Mousepad: CM Storm Swift-RX XXL || Graphics tablet: Wacom Intuos Pen Small

Old PC:

CPU: AMD Athlon X2 255 || Motherboard: ASUS M4A89GTD PRO || RAM: 4x2GB DDR3 || GPU: Nvidia Quadro 512MB || Case: Antec Sonata III || PSU: Antec Earthwatts 500W Bronze

Minibois' Digital Art Thread

Reviews: Coolermaster Masterkeys Pro S RGB || Wacom Intuos Pen Small || Roccat Kiro

Threads: Pokémon Thread || Dutch Talk || Super Smash Bros. Melee Thread

Setup: Current setup

Link to post
Share on other sites
Posted · Original PosterOP
3 minutes ago, Minibois said:

That's... A weird number.

This is what the different displayport versions support at 1440p:

image.png.4b7c3ec20a50789191e612722b2f4851.png

That's 1.0/1.1, 1.2, 1.3/1.4 respectively and nowhere does it mention 120Hz. max..

 

Apparently this is a know issue with Nvidia cards though, just Googling around about it.

People are suggesting kind of the 'basic' answers; such as reinstalling drivers, trying different cables, rolling back to a previous driver, etc. and sometimes some of the solutions do work for the OP of the thread.

 

If you want to experiment a bit, you could try out loading some older drivers and checking to see if there is a difference in what refresh rate you can choose.

 

Also, when you told me this:

Which of the three things were you referring to:

Or was it just all three. Because I am still somewhat curious about connecting the HDMI on your card to HDMI 2 (that's the one next to the Displayport).

yeah it was all 3, i can try a hdmi

Link to post
Share on other sites
3 hours ago, Cupar19 said:

nope 60hz

Did you try the HDMI 2 port? In the manual specifically it says HDMI 1 can do up to 60Hz, HDMI 2 can do up to 144Hz.


"There's no such thing as perfect. You're beautiful as you are Courage. With all your imperfections you can do anything." - Bathtub Barracuda

"How can someone win if winning means that someone loses" - Scatman John

"We’re here to make you think about death and get sad and stuff.” - Scott Pilgrim

Gear:                           .                                                                                                                         .

Spoiler

PC:

CPU: AMD Ryzen 7 1700 || Motherboard: MSI X370 Gaming Pro Carbon || RAM: 2x8GB G.Skill TridentZ RGB 3200Mhz (running at 2933Mhz) || GPU: Gigabyte Auros RX 580 4GB || Storage: Samsung 960 EVO 250GB + Seagate Barracuda 2TB || Cooling: Be Quiet! Dark Rock 3 || Case: Thermaltake Core G21 TG || PSU: Corsair RMx 750W

Peripherals:

Headphones: Beyerdynamic DT-990 250 Ohm || Mouse: Roccat Kiro || Keyboard: Coolermaster Masterkeys Pro S RGB || Mousepad: CM Storm Swift-RX XXL || Graphics tablet: Wacom Intuos Pen Small

Old PC:

CPU: AMD Athlon X2 255 || Motherboard: ASUS M4A89GTD PRO || RAM: 4x2GB DDR3 || GPU: Nvidia Quadro 512MB || Case: Antec Sonata III || PSU: Antec Earthwatts 500W Bronze

Minibois' Digital Art Thread

Reviews: Coolermaster Masterkeys Pro S RGB || Wacom Intuos Pen Small || Roccat Kiro

Threads: Pokémon Thread || Dutch Talk || Super Smash Bros. Melee Thread

Setup: Current setup

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×