Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
MagnificentLumi

Unable to launch games from Microsoft Store

Recommended Posts

Posted · Original PosterOP

Hi,

 

I am completely new to this forum, and i joind in hopes to find a solution to a problem that i am having with Microsoft Store and how/where it stores my games.

I have looked through some similar post in this forum but none that i could find had the solution that I was looking for.

 

This is my setup:

  • Win 10 - 10.0.17763 Build 17763
  • Processor - Intel(R) Core(TM) i7-8700K CPU @ 3.70GHz
  • Motherboard - MSI Z370 KRAIT GAMING (MS-7B46)
  • Ram - 32GB
  • Graphics card - MSI 1080ti trio
  • Boot drive (C:) - NVMe Samsung 970 evo 250GB
  • Storage drive 1 (O:) - 2x SSD Samsung 500GB in raid 0
  • Storage drive 2 (P:) - 2x HDD 4TB in raid 0

 

Games tried to install is:

 

- Forza Horizon 4

- Forza Horizon 3

- Gears of War

- Age of Empires: Definitive Edition

 

What do I want to happen:

 

- Store all games installed on my computer on the HDD as my NVMe does not have sufficient space for windows and games.

 

What have I done:

 

- Changed default save location for "apps" in Windows to HDD

- Tried to gain access to "WindowsApps" folder as Administrator, but it did not help

- Formatted SSD disc and tried to set as default again, did not help

- All storage is formatted NTFS

- Tried to call Microsoft support without any results

 

What is happening:

 

- When launching the game if installed on NVMe, the game runs fine

- When launching the game if installed on HDD or SSD, the game tries to launch and a for a brief second the a game window opens for then to crash to desktop

 

 

Thank you all for taking a look and thank you for helping out if you have any idea:)

 

 

 

 

 

Link to post
Share on other sites

Hey, not sure if this is any help but I have a similar issue.  I have an SSD boot drove and a 1TB 5400rpm D drive (I'm on a laptop).

 

I install all my games to the HDD and they work okay for a week or two, then the problem that you describe with a CTD on game launch happens (sometimes a black window appears briefly).

 

The most consistent solution I have found is to uninstall the game from add/remove programs, reboot, and redownload the game.  Sometimes running wsreset.exe (clears the windows store cache, doesn't delete games or log you out) will fix it but I've gotten used to redownloading.  This may not help you since, if I am reading correctly, you can't get the game to start even once.

 

Probably not a lot of help but you definatly aren't alone with WinStore issues.  I wonder if it is a license or DRM issue preventing the game from launching from an auxillary drive.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×