Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Dplyr

Trouble with Port Forwarding (ZTE F609)

Recommended Posts

Posted · Original PosterOP

I have a ZTE F609 router provided by my ISP. the main trouble here is that i want to host a minecraft server (childish i know). the main issue is port forwarding. according to https://portforward.com/zte/f609/ it should look something like this;

Enable [checked]

Name [anything]

Protocol [both]

WAN Host Start IP Address [N/A]

WAN Host End IP Address [N/A]

WAN Connection [omci_ipv4_ppoe_1] (doesnt actually say that but its the one im using, the other is [omci_ipv4_dhcp_2]

WAN Start Port [3074] (xbox live example they use)

WAN End Port [3074]

Enable MAC Mapping [unchecked]

LAN Host IP Address [192.168.1.20] (yes it is static)

LAN Host Start Port [3074]

LAN Host End Port [3074]

 

My Config is the same, however the port is 25565, the minecraft port.

The question i have is what am i doing wrong?

How do i Fix it?

 And how do my friends connect to the server?

 

This is my Server Properties, i'm primarily focusing on just allowing my friends to connect

#Minecraft server properties
view-distance=20
max-build-height=256
server-ip=192.168.1.20
level-seed=
gamemode=0
server-port=25565
enable-command-block=true
allow-nether=true
enable-rcon=false
op-permission-level=4
enable-query=false
prevent-proxy-connections=false
generator-settings=
resource-pack=
player-idle-timeout=0
level-name=world
motd=PLEASE WORK
force-gamemode=false
hardcore=false
white-list=false
broadcast-console-to-ops=true
pvp=true
spawn-npcs=true
generate-structures=true
spawn-animals=true
snooper-enabled=true
difficulty=1
network-compression-threshold=256
level-type=DEFAULT
spawn-monsters=true
max-tick-time=60000
max-players=20
enforce-whitelist=false
resource-pack-sha1=
online-mode=true
allow-flight=false
max-world-size=29999984
 

Link to post
Share on other sites

If I recall correctly you have to change online-mode to false. But I haven't done Minecraft hosting in years.

Making a local server will require something like Hamachi by LogMeIn to work. Atleast that's what I've been doing.

Dedicated servers are paid but can run all day and be publicly available.


You learn from mistakes, and you won't make them if you won't try.

Link to post
Share on other sites

@Dplyr

 

If port 25565 is used by your server, then it needs to be forwarded as well. You might also want to look in to something like No IP, that will make it easier for your friends to connect to your server. Basically you install their software on your computer and it keeps track of IP address changes from your ISP. Then it assigns like a URL you can give out. Makes it a little easier then having to hunt down the WAN IP every time your friends cant connect. Also, depending on what kind of system the server is running on you might need to adjust settings in the local firewall of that machine. Windows XP SP2 on up had a built in firewall and some Linux distro's do as well. So that could also block things. 

 

If you want to make sure the server stays private then doing what @PrinceNorris suggested by using Himachi is a good idea. 


You ever notice that many establishments have a sign that as "No Shirt, No Shoes, No service"? They never say anything about pants............ You know what that implies. You dont have to wear pants. 

Link to post
Share on other sites
Posted · Original PosterOP

@PrinceNorris i've used hamachi before, and its just not something i want to use going forward. setting online mode to false just changes the type of account that can log in, however that cant happen when nobody could log in the first place.

@Donut417 port 25565 is what i'm forwarding in my router. i have checked out No IP and its a great thing to have once the server is up and running, however that isnt possible at the moment. on any port checker, with the server running, it says the server is closed, this is further backed up by the fact that my friends cant join.

a522ae45cdb4a0a82dcb5bfdffa77ad8.png
^^

this is the settings on my router for the port forward

Link to post
Share on other sites

Concider leaving the Server-ip blank in your server config file, I've never had to touch it. 
And I second Donut's motion of checking the pc running the servers firewall.
What OS are you running the server on?
An alternative to NOIP that doesn't require something running on your PC is FreeDNS, I've personally used it with great results.


Show me your LackRack

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×