Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
neoplefuckedup

need help for detecting what causing my fps drops so strangely

Recommended Posts

Posted · Original PosterOP

Hi lovely people

I recently encounter strange "low fps" experience on pretty much every game I have played. Even though I upgraded my parts of my PC, problems still exist. Let me list my build parts then details the problem.

Old----------->>New

b85 asrock anniversary ----------------> Asus X470 Prime Pro

Xeon E3 1230 v3 ------------------------> Amd 2700X (@4.0)

gskill rapjaw DDR3 1600 4gx2 -------> Adata DDR4 3000 8Gx2( both new and old setup work as dual channel)

Evga 600b ---------------------------------> SF-550P14XE (brand name is superflower, ps gets 110w for+3.3v and +5v; 546w for +12v)

HDD WD 7200 Blue 1T-------------> does not change, has been running with care(keep in cool and dry condition)

MSI GTX970 OC --------------------> does not change, has been running with care too, recently I changed paste for it but it did not help out

Windows 7 pro ----------------------------> has keep updated until Nov. 2018 (updates in Dec. 2018 made huge lag even on watching linus on youtube so I uninstalled them via CMD)

 

----------------------------------

Couple noticeable things: 

1) GPU usage never reach about 45% among all game I have played recently: csgo, path of exile, re 2, farcry newdawn, warframe and so on.

2) I have tried all possible solution via software settings such as nvidia control  board, msi afterburner forcing fan running max speed and oc a little bit, all windows setting are proper

3)HDD had been defragged 

-----------------------------------

So these are pretty much all, I hope some good tech geeks can help me detect where is the issue and hopefully comes out a solution...

thank you 

 

Link to post
Share on other sites
Posted · Original PosterOP
2 minutes ago, Arika S said:

when you say "low fps" what kind of numbers and for how long does it stay "low"?

Sorry I forget the most important part, re2 30fps-15fps inside of police office ,csgo 60fps but 20fps when get hitted or fire guns against others, warframe: 40fps and lower everywhere, newdawn : 20-40fps but lagging hard and so on. 

my monitor is xl2411Z benq running at 144hz 

Link to post
Share on other sites

Did you update nvidea drivers till date? This is wierd cause' i have an amd fx 4300 and a nvidea gt610, pretty old and i get 50-60 fps on 720p low.

What about your direct x version??

 

 

Link to post
Share on other sites
Just now, Boy_On_Fire said:

Did you update nvidea drivers till date? This is wierd cause' i have an amd fx 4300 and a nvidea gt610, pretty old and i get 50-60 fps on 720p low(csgo).

What about your direct x version??

 

 

 

Link to post
Share on other sites
18 minutes ago, neoplefuckedup said:

Sorry I forget the most important part, re2 30fps-15fps inside of police office ,csgo 60fps but 20fps when get hitted or fire guns against others, warframe: 40fps and lower everywhere, newdawn : 20-40fps but lagging hard and so on. 

Well, first instinct would be you're running on the CPUs integrated graphics with your monitor plugged in to the motherboard instead of the graphics card... But since neither of your CPUs have integrated graphics, that's not an option :D

That's definitely low FPS. Is it always at the low FPS or does it start out higher like 100+FPS and then after you play a bit it drops down?

 

39 minutes ago, neoplefuckedup said:

Couple noticeable things: 

1) GPU usage never reach about 45% among all game I have played recently: csgo, path of exile, re 2, farcry newdawn, warframe and so on. 

What does the CPU show for usage?
CPU temps? Is the fan on the CPU cooler spinning when the system is turned on?


CPU: Intel i7 6700k  | Motherboard: Gigabyte Z170x Gaming 5 | RAM: 2x8GB 3000MHz G.Skill Ripjaws 5 | GPU: Gigabyte Aorus GTX 1080ti | PSU: Corsair RM750x (2018) | Case: BeQuiet SilentBase 800 | Cooler: Corsair H100i AIO | SSD: Samsung 970 Evo 500GB + Samsung 840 500GB | HDD: Seagate Ironwolf 8TB + 2x Seagate Ironwolf 6TB | Monitor: Acer Predator XB271HU + Samsung BX2450

Link to post
Share on other sites
Posted · Original PosterOP
Just now, Boy_On_Fire said:

Did you update nvidea drivers till date? This is wierd cause' i have an amd fx 4300 and a nvidea gt610, pretty old and i get 50-60 fps on 720p low.

What about your direct x version??

 

All drivers are updated to latest, but some point, I keep relatively new nvidia driver version due to the latest one causing performance issue

 

Link to post
Share on other sites
Posted · Original PosterOP
4 minutes ago, Spotty said:

Well, first instinct would be you're running on the CPUs integrated graphics with your monitor plugged in to the motherboard instead of the graphics card... But since neither of your CPUs have integrated graphics, that's not an option :D

That's definitely low FPS. Is it always at the low FPS or does it start out higher like 100+FPS and then after you play a bit it drops down?

 

What does the CPU show for usage?
CPU temps? Is the fan on the CPU cooler spinning when the system is turned on?

cpu usage varies, because games nowadays not fully support all threads to work hard. but usually around 50+70 i would say

Temp. never reached about 80C and I open the side glass board all the time (but it is super clean in the computer case)

and fps just gets relative low and lower since beginning of playing

Link to post
Share on other sites
4 minutes ago, neoplefuckedup said:

and fps just gets relative low and lower since beginning of playing

What about GPU temp? If it starts out with normal performance then drops it could be thermal throttling as you play and things heat up.

I'd recommend running MSI afterburner with the on screen display enabled showing CPU usage/temp/clock speed and GPU usage/temp/clock speed while you play so you can see exactly what is happening when performance starts dropping.


CPU: Intel i7 6700k  | Motherboard: Gigabyte Z170x Gaming 5 | RAM: 2x8GB 3000MHz G.Skill Ripjaws 5 | GPU: Gigabyte Aorus GTX 1080ti | PSU: Corsair RM750x (2018) | Case: BeQuiet SilentBase 800 | Cooler: Corsair H100i AIO | SSD: Samsung 970 Evo 500GB + Samsung 840 500GB | HDD: Seagate Ironwolf 8TB + 2x Seagate Ironwolf 6TB | Monitor: Acer Predator XB271HU + Samsung BX2450

Link to post
Share on other sites
Posted · Original PosterOP
26 minutes ago, Spotty said:

What about GPU temp? If it starts out with normal performance then drops it could be thermal throttling as you play and things heat up.

I'd recommend running MSI afterburner with the on screen display enabled showing CPU usage/temp/clock speed and GPU usage/temp/clock speed while you play so you can see exactly what is happening when performance starts dropping.

GPU temp is stable and normal (desktop standby 34C gaming never reach above 70)

Link to post
Share on other sites
8 minutes ago, neoplefuckedup said:

I have tried it

no changes

From msi afterburner , what gpu clock speed & usage?

a 970 can run re2 60fps very well (even at 899mhz )

Link to post
Share on other sites
Posted · Original PosterOP
8 hours ago, Boy_On_Fire said:

Also try upgrading to windows 10, maybe the nvidea drivers have issues with win 7.

No i cant do that 

certain software having so many issues on windows 10 and I hate to interface layout on win10 as well.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Buy VPN

×