Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
bradwiggo

Bad performance with 2070

Recommended Posts

Posted · Original PosterOP

I have an RTX 2070 and an i5-8600k and I get 100 FPS in the benchmark in forza horizon 4 at 1080p (using the ultra preset, which isn't max settings). I get 85 FPS in gta v at max settings. This seems far too low for what is basically a 1080. I have seen people online with a 1070 saying they get 120fps in horizon 4, how is that possible when I have a more powerful card and get far less? Also I have seen vids online with a ryzen 1600 and a 1060 running gta v at 85 FPS, which is a much worse system than mine, so why is it only hitting the same FPS? 

 

I was talking to someone on the forza forums who said they got 110fps at 1440p at max settings in forza horizon 4 with a 1080. I get 85fps at max settings at 1080p, so what gives? How are people managing to get this level of performance, when I seem to be getting 1060 performance on a 2070? 


Specs: 

 

  • i5-8600K 
  • Evga Black RTX 2070 
  • 16GB DDR4 2400MHz 
  • ASRock Extreme 4 Z370 
  • Fractal Design Meshify C Light TG 

Location: UK 

Plays: Minesweeper at 1000 fps. 

Link to post
Share on other sites
20 minutes ago, bradwiggo said:

I have an RTX 2070 and an i5-8600k and I get 100 FPS in the benchmark in forza horizon 4 at 1080p (using the ultra preset, which isn't max settings). I get 85 FPS in gta v at max settings. This seems far too low for what is basically a 1080. I have seen people online with a 1070 saying they get 120fps in horizon 4, how is that possible when I have a more powerful card and get far less? Also I have seen vids online with a ryzen 1600 and a 1060 running gta v at 85 FPS, which is a much worse system than mine, so why is it only hitting the same FPS? 

 

I was talking to someone on the forza forums who said they got 110fps at 1440p at max settings in forza horizon 4 with a 1080. I get 85fps at max settings at 1080p, so what gives? How are people managing to get this level of performance, when I seem to be getting 1060 performance on a 2070? 

There's so many variances it could be. Thermals, RAM speeds, drivers, windows updates, ect. Get a baseline benchmark like cinebench for your CPU and something like Firestrike for your GPU and compare them to others, then get your thermals under a stress test.

Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, RAM555789 said:

There's so many variances it could be. Thermals, RAM speeds, drivers, windows updates, ect. Get a baseline benchmark like cinebench for your CPU and something like Firestrike for your GPU and compare them to others, then get your thermals under a stress test.

Thermals seem fine, I will have to run a benchmark when I get home. It's wierd, a lot of the professional reviews online with benchmarks show results like I get but then people on youtube seem to get another 20 FPS for some reason. I have 2 different brand sticks of ram, and I think they have different timings, could this affect it? 


Specs: 

 

  • i5-8600K 
  • Evga Black RTX 2070 
  • 16GB DDR4 2400MHz 
  • ASRock Extreme 4 Z370 
  • Fractal Design Meshify C Light TG 

Location: UK 

Plays: Minesweeper at 1000 fps. 

Link to post
Share on other sites

I'd say memory probably plays the biggest factor here. How much of what RAM are you using at what clocks (is it in dual channel mode?)?

Link to post
Share on other sites
2 minutes ago, bradwiggo said:

Thermals seem fine, I will have to run a benchmark when I get home. It's wierd, a lot of the professional reviews online with benchmarks show results like I get but then people on youtube seem to get another 20 FPS for some reason. I have 2 different brand sticks of ram, and I think they have different timings, could this affect it? 

There's a chance it may cause an effect,  but it less likely as your BIOS should make them match.

Link to post
Share on other sites
Posted · Original PosterOP
8 minutes ago, RejZoR said:

I'd say memory probably plays the biggest factor here. How much of what RAM are you using at what clocks (is it in dual channel mode?)?

It's dual channel (according to CPU z), two different brand sticks, 2400mhz, 16 gb in total. Timings different however. 


Specs: 

 

  • i5-8600K 
  • Evga Black RTX 2070 
  • 16GB DDR4 2400MHz 
  • ASRock Extreme 4 Z370 
  • Fractal Design Meshify C Light TG 

Location: UK 

Plays: Minesweeper at 1000 fps. 

Link to post
Share on other sites

2400MHz is on the low side. In most tests 2666MHz is where most gains are done, but preferably 3200MHz is what you'd want. Timings (same applies for clocks too) will be used the lowest which can be handled by the slowest stick.

 

DDR4 can handle 1.35V without any problem on any board so try bumping that speed up, at least to 2666MHz if it won't go higher. Then it's a matter of luck with the sticks and how willing the board is.

Link to post
Share on other sites
Posted · Original PosterOP
1 hour ago, RejZoR said:

2400MHz is on the low side. In most tests 2666MHz is where most gains are done, but preferably 3200MHz is what you'd want. Timings (same applies for clocks too) will be used the lowest which can be handled by the slowest stick.

 

DDR4 can handle 1.35V without any problem on any board so try bumping that speed up, at least to 2666MHz if it won't go higher. Then it's a matter of luck with the sticks and how willing the board is.

Does that make a huge difference? As I saw someones who got 85 FPS in the forza 4 benchmark at 3440 by 1440 which means they are pushing 2.5x more pixels per second than me with basically the same card. How is that even possible? 


Specs: 

 

  • i5-8600K 
  • Evga Black RTX 2070 
  • 16GB DDR4 2400MHz 
  • ASRock Extreme 4 Z370 
  • Fractal Design Meshify C Light TG 

Location: UK 

Plays: Minesweeper at 1000 fps. 

Link to post
Share on other sites

Well, then you're pushing anything at the limit, everything will make a difference. Also, you only have 6 cores. Many modern games already can use way more cores than that and the boost clock of 8600K isn't like ridiculously high.

 

Something is up coz RX 580 is getting 55+ fps at max 1080p in GTA5 last time I was fiddling with it. That system was running Ryzen R5 2600X tho. 2x threads, about the same turbo clocks probably.

Link to post
Share on other sites
Posted · Original PosterOP
3 minutes ago, RejZoR said:

Well, then you're pushing anything at the limit, everything will make a difference. Also, you only have 6 cores. Many modern games already can use way more cores than that and the boost clock of 8600K isn't like ridiculously high.

 

Something is up coz RX 580 is getting 55+ fps at max 1080p in GTA5 last time I was fiddling with it. That system was running Ryzen R5 2600X tho. 2x threads, about the same turbo clocks probably.

What could be wrong with my pc then? I thought the difference between 8600k and 8700k was small. 


Specs: 

 

  • i5-8600K 
  • Evga Black RTX 2070 
  • 16GB DDR4 2400MHz 
  • ASRock Extreme 4 Z370 
  • Fractal Design Meshify C Light TG 

Location: UK 

Plays: Minesweeper at 1000 fps. 

Link to post
Share on other sites
Posted · Original PosterOP
21 minutes ago, RejZoR said:

Well, then you're pushing anything at the limit, everything will make a difference. Also, you only have 6 cores. Many modern games already can use way more cores than that and the boost clock of 8600K isn't like ridiculously high.

 

Something is up coz RX 580 is getting 55+ fps at max 1080p in GTA5 last time I was fiddling with it. That system was running Ryzen R5 2600X tho. 2x threads, about the same turbo clocks probably.

Just ran cinebench r20 and I got 2382, no idea if that's good lol.

 

I don't have firestrike and you have to pay for it, I will run heaven benchmark, that's free, 


Specs: 

 

  • i5-8600K 
  • Evga Black RTX 2070 
  • 16GB DDR4 2400MHz 
  • ASRock Extreme 4 Z370 
  • Fractal Design Meshify C Light TG 

Location: UK 

Plays: Minesweeper at 1000 fps. 

Link to post
Share on other sites
Posted · Original PosterOP
2 hours ago, RAM555789 said:

There's so many variances it could be. Thermals, RAM speeds, drivers, windows updates, ect. Get a baseline benchmark like cinebench for your CPU and something like Firestrike for your GPU and compare them to others, then get your thermals under a stress test.

2382 on cinebench r20, does that seem about right? 


Specs: 

 

  • i5-8600K 
  • Evga Black RTX 2070 
  • 16GB DDR4 2400MHz 
  • ASRock Extreme 4 Z370 
  • Fractal Design Meshify C Light TG 

Location: UK 

Plays: Minesweeper at 1000 fps. 

Link to post
Share on other sites
1 hour ago, bradwiggo said:

2382 on cinebench r20, does that seem about right? 

I get 2945 in Cinebench with my older i7 5820K @ 4.5GHz (12 threads, 4.5GHz on all cores, quad channel 2400MHz RAM). I have no clue at what core clock 8600K runs when not overclocked and under full load. Probably not at boost 4.3GHz....

Link to post
Share on other sites
Posted · Original PosterOP
10 minutes ago, RejZoR said:

I get 2945 in Cinebench with my older i7 5820K @ 4.5GHz (12 threads, 4.5GHz on all cores, quad channel 2400MHz RAM). I have no clue at what core clock 8600K runs when not overclocked and under full load. Probably not at boost 4.3GHz....

I also ran heaven and got 161fps at 1080p ultra with max tesselation and no aa. 

 

It runs at about 4.10ghz boost. 

 

I overclocked the ram to 2600mhz and it made no difference to fps. 


Specs: 

 

  • i5-8600K 
  • Evga Black RTX 2070 
  • 16GB DDR4 2400MHz 
  • ASRock Extreme 4 Z370 
  • Fractal Design Meshify C Light TG 

Location: UK 

Plays: Minesweeper at 1000 fps. 

Link to post
Share on other sites
2 hours ago, bradwiggo said:

Does that make a huge difference? As I saw someones who got 85 FPS in the forza 4 benchmark at 3440 by 1440 which means they are pushing 2.5x more pixels per second than me with basically the same card. How is that even possible? 

2400mhz to 2666 is a sizable difference, it's likely that the ram is bottlenecking the cpu which bottlenecks the game, ur gpu is likely not running at 100%.

 

you'd have to check usage and provide us with the details.


9900k 1.36v 5.2 83C 185w 1.24v 4.9 60C 135w 1.05v 4.5 90w 50C (doing some testing for hot days) all-2avx cinebench/blender temps. avx voltages in prime. ll D15 ll Z390 taichi ult 1.60 bios fixed LLC voltage gaps ll gskill 2x8gb cl16 ddr4000 bdie 1.42v ll 4x samsung 970 evo 256gb (asus hyper pcie m2 raid card) ll 2x samsung 860 evo 500gb raid 0 (<--i should've went with 1tb nvmemistake of the build) ll EVGA 2080 ti XC (duo fan skinny) 1995//7600 power limited 79C max, stock voltage (really bad ocer) ll Corsair graphite 780T ll EVGA G2 1300w ll Windows 10 Pro ll NEC PA272w (movie, work mon) 2k60 14bit lut ll Predator X27 4k144 hdr (rgb98)

Link to post
Share on other sites
Posted · Original PosterOP
2 minutes ago, xg32 said:

2400mhz to 2666 is a sizable difference, it's likely that the ram is bottlenecking the cpu which bottlenecks the game, ur gpu is likely not running at 100%.

 

you'd have to check usage and provide us with the details.

GPU is running at 98% according to the inbuilt overlay in horizon 4. I overclocked my ram to 2600mhz and it made no difference sadly. 


Specs: 

 

  • i5-8600K 
  • Evga Black RTX 2070 
  • 16GB DDR4 2400MHz 
  • ASRock Extreme 4 Z370 
  • Fractal Design Meshify C Light TG 

Location: UK 

Plays: Minesweeper at 1000 fps. 

Link to post
Share on other sites
1 minute ago, bradwiggo said:

GPU is running at 98% according to the inbuilt overlay in horizon 4. I overclocked my ram to 2600mhz and it made no difference sadly. 

whats the power limit/temps on the gpu?


9900k 1.36v 5.2 83C 185w 1.24v 4.9 60C 135w 1.05v 4.5 90w 50C (doing some testing for hot days) all-2avx cinebench/blender temps. avx voltages in prime. ll D15 ll Z390 taichi ult 1.60 bios fixed LLC voltage gaps ll gskill 2x8gb cl16 ddr4000 bdie 1.42v ll 4x samsung 970 evo 256gb (asus hyper pcie m2 raid card) ll 2x samsung 860 evo 500gb raid 0 (<--i should've went with 1tb nvmemistake of the build) ll EVGA 2080 ti XC (duo fan skinny) 1995//7600 power limited 79C max, stock voltage (really bad ocer) ll Corsair graphite 780T ll EVGA G2 1300w ll Windows 10 Pro ll NEC PA272w (movie, work mon) 2k60 14bit lut ll Predator X27 4k144 hdr (rgb98)

Link to post
Share on other sites
Posted · Original PosterOP
38 minutes ago, xg32 said:

whats the power limit/temps on the gpu?

I'm not sure about the power limit, msi afterburner says it is at 100% on the slider bar. The temperatures don't go above about 65 degrees. 


Specs: 

 

  • i5-8600K 
  • Evga Black RTX 2070 
  • 16GB DDR4 2400MHz 
  • ASRock Extreme 4 Z370 
  • Fractal Design Meshify C Light TG 

Location: UK 

Plays: Minesweeper at 1000 fps. 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×