Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Delicieuxz

Need help with 'run as administrator' issue in Windows 10

Recommended Posts

Posted · Original PosterOP

In my Windows 10 OS, my account is the Admin account, and UAC and Windows Defender are turned off.

 

I'm trying to install Tor Browser downloaded from the official website to C:\Program Files, and the installer can't install the files unless I right-click and choose 'run as administrator'. After I install it by using 'run as administrator', I can't run the program unless I right-click on it and choose 'run as administrator'. The same applies to running it from a shortcut anywhere.

 

Also, accessing the installation folder in C:\Program Files requires me to click on a prompt that says 'continue as administrator', while no other program does this.

 

Also, this only occurs when Tor is installed to the Program Files folder. If I install it elsewhere, administrator permission isn't needed to install or run it.

 

I haven't encountered needing to use 'run as administrator' with any other program before while working in an administrator account with UAC and Windows Defender turned off. I also haven't encountered this issue with Tor Browser in any of my previous Windows 10 installation - it has always installed and run just fine without requiring elevated permissions. Also, I don't know if it makes any sense that the OS is requesting elevated permission since UAC and Windows Defender are both fully turned off.

 

Does anyone have insight into this? And is it possible to turn off all 'run as administrator' prompts for everything, permanently?

 

 

 

Also, is this a bug in the forum software? I clicked to edit my LTT OP here, and this image appeared in the post's uploaded images (but not in the post body). It's not mine, I didn't upload it, and I've never seen it before. Someone else's image somehow appeared in the editor for my LTT thread OP:

 

[picture now deleted]

 

Link to post
Share on other sites
Posted · Original PosterOP

I've worked around the issue by setting the compatibility of Firefox.exe in the Tor folder that's in Program Files to 'Run this program as an administrator'. However, I want to know why it's happening only now (with my latest clean installation), with just this program, and just in the Program Files folder.

 

I asked Microsoft support and the person I talked with said that Tor is for accessing black markets and is identified by Windows as a threat. I don't know if they were just assuming that on their own, but if not then it's ridiculous of Microsoft to be dictating what a person can do on their PC and in what way after they've deliberately disabled Windows' security measures. Reminds me to, in the future, always set the super admin account as the main account after doing a clean installation.

Link to post
Share on other sites

What about permissions of PF folder? Set it as full access, take ownership and you will can install programs that uses their own directories to store data.

Link to post
Share on other sites
Posted · Original PosterOP
8 hours ago, homeap5 said:

What about permissions of PF folder? Set it as full access, take ownership and you will can install programs that uses their own directories to store data.

I did actually change ownership of Program Files from TrustedInstaller to my administrator account, and the issue persisted.

 

Also, when applying the permissions for Program Files, everything sets properly except for the Tor Browser folder.

 

 

1137818051_TorBrowserpermissions.jpg.70350beaeb5d0e40f39ae9bf8bc57303.jpg

Link to post
Share on other sites
Posted · Original PosterOP
15 minutes ago, homeap5 said:

So try to change tor separately.

It already showed as everything being enabled for the administrator group, other than Special permissions.

 

 

739955619_TorBrowser2.PNG.6c9d546044b1b39c6c74c4d90c33cef6.PNG

 

 

I tried disallowing some things for the Tor folder and re-allowing them, and it still needs to be run as administrator when launching the program.

 

759451106_CapturTorBrowser3.PNG.8163c77682b4b104ff109fa28126c83d.PNG

 

Link to post
Share on other sites
Posted · Original PosterOP
20 minutes ago, homeap5 said:

Try (at least just for test) add "everyone" to this folder with full access.

Giving access to the Users group made it possible to launch without needing admin approval.

 

It's specifically the write permission that needs to be enabled for Users for Tor Browser to launch without elevated permission.

 

After allowing Tor Browser for Users, I've lost the ability to edit the Administrators group permissions even after disallowing the Users group permissions again. The checkboxes are all enabled for Administrators but greyed out in the edit permissions windows so they can't be changed. I tried uninstalling and reinstalling Tor Browser and the admin permission boxes are still greyed out and can't be changed. Strange.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Buy VPN

×