Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
JayBee805

Trying to build pc , so lost

Recommended Posts

Posted · Original PosterOP
6 hours ago, CodeNova said:

Dose this help? also there are some great sources on youtube that may help.

Yes not sure if I have those specific cables though ? 

 

34C5ED28-DB0E-43E2-901E-1B731E016EB5.jpeg

Link to post
Share on other sites
5 hours ago, JayBee805 said:

??

<snip>

hey that looks better.

Now find the other end of that sata cable and plug it into your motherbaord.

 

5 hours ago, JayBee805 said:

Yes not sure if I have those specific cables though ? 

To summarize, just so I understand everything.

- You have successfully connected your front panel IO.

- You have successfully connected your aio cooler.

- You have successfully connected your motherboards power.

- You have successfully connected your GPU power.

- You have successfully inserted your Ram into the dim slots.

- You have successfully inserted your GPU into the pci slot.

- Your CPU has successfully been installed.

- You have successfully installed your hard drive's power connector.

what you have yet to do.

- Connect the SATA cable to the hard drive and the motherboard. (in progress)

- Install windows.

Link to post
Share on other sites
Posted · Original PosterOP
5 hours ago, CodeNova said:

To summarize, just so I understand everything.

- You have successfully connected your front panel IO.

- You have successfully connected your aio cooler.

- You have successfully connected your motherboards power.

- You have successfully connected your GPU power.

- You have successfully inserted your Ram into the dim slots.

- You have successfully inserted your GPU into the pci slot.

- Your CPU has successfully been installed.

- You have successfully installed your hard drive's power connector.

what you have yet to do.

- Connect the SATA cable to the hard drive and the motherboard. (in progress)

- Install windows.

Okay, I have couple problems it doesn’t turn on sometimes .. right now it turned on but doesn’t wanna turn off 

 

OkY where do I connect the hard drive to the motherboard ?

0CAAB28F-EA3E-41CC-9A09-A9F4B48A249C.jpeg

Link to post
Share on other sites
3 minutes ago, JayBee805 said:

It shows on the bios now but it won’t start up? 

<snip>

Do you have a copy of windows? its the OS, thats what a pc boots into. Another question, is your drive blank?

Link to post
Share on other sites
Posted · Original PosterOP
2 minutes ago, CodeNova said:

Do you have a copy of windows? its the OS, thats what a pc boots into. Another question, is your drive blank?

I do not have a copy of windows ? And yes brand new 

Link to post
Share on other sites
2 minutes ago, JayBee805 said:

I do not have a copy of windows ? And yes brand new 

Do you have access to another working computer and a usb thumb drive?

windows 10

Link to post
Share on other sites
1 minute ago, JayBee805 said:

But not a usb thumb drive 

You'll need one in order to make a Windows install disk.

Link to post
Share on other sites
5 hours ago, JayBee805 said:

 

Just to make sure,  when you power on the computer,  are the cpu radiator fans spinning?

Link to post
Share on other sites
Posted · Original PosterOP
4 hours ago, zFox said:

Just to make sure,  when you power on the computer,  are the cpu radiator fans spinning?

Yes 

 

4 hours ago, Crunchy Dragon said:

You'll need one in order to make a Windows install disk.

On my way to get one , where do I get the download ? Or what program do I use 

Link to post
Share on other sites
1 minute ago, JayBee805 said:

On my way to get one , where do I get the download ? Or what program do I use 

 

19 minutes ago, CodeNova said:

Click this link ^

Link to post
Share on other sites

With the machine off, insert the usb stick in an appropriate port on the motherboard back panel. Depending on settings once you power up, the machine may boot into the Windows installer. Otherwise in the BIOS set the Boot priority.


80+ ratings certify electrical efficiency. Not quality.

 

Link to post
Share on other sites
Posted · Original PosterOP

I got it working fellas ! Thank you all very much for the help & for being patient !! First time pc builder !! Anything else I need to do now ? What to download ? 

Link to post
Share on other sites
31 minutes ago, JayBee805 said:

I got it working fellas ! Thank you all very much for the help & for being patient !! First time pc builder !! Anything else I need to do now ? What to download ? 

I'm glad you got it working, just make sure your case fans are installed and working (if you have them). Start downloading your drivers, head over to the manufactures website, you can find them there.

 

Edit: You should give a 'shout out' to all those patient people that helped (exclude me please). Than post your build in the build thread. I'm sure everyone else would enjoying seeing the progress you made.

Link to post
Share on other sites

This is the kind of thread we need more of. Real world PC issues!

 

I would recommend looking up some build videos on YouTube, they pretty much walked me through all this.

 

I am impressed you did all the hard stuff like CPU, MoBo and all the PSU/case stuff. I found mounting the cooler the hardest.


i5 8600 - RX580 - Fractal Nano S - 1080p 144Hz

Link to post
Share on other sites
Posted · Original PosterOP
5 hours ago, CodeNova said:

I'm glad you got it working, just make sure your case fans are installed and working (if you have them). Start downloading your drivers, head over to the manufactures website, you can find them there.

 

Edit: You should give a 'shout out' to all those patient people that helped (exclude me please). Than post your build in the build thread. I'm sure everyone else would enjoying seeing the progress you made.

Yes will do this later on today ! Thank you !

Link to post
Share on other sites

If the computer doesnt turn on after you put the sata cable in your mainboard then try to remove it and say if the problem persist.With your mainboard you also get sata cables.These are for the HDD and goes into your mainboard.But i dont think that your pc does not turn on because of hdd.It should be something with power supply. Everything looks fine tho when i look to your bios.At this point when you get into bios you want to install windows.You basically go to windows media tool and format windows for usb stick.After that you put the usb go into your bios find your usb name and install the windows.

 

 

Edit : Congrats on your build.Now you want to install windows.Look above i described you how to do it.Do you want to overclock something the cpu or Ram?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×