Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Diren

GPU not working

Recommended Posts

Posted · Original PosterOP

Hey guys,

So, I recently switched to a meshify case as well as a liquid cooler. The power draw according to PC partpicker is about 350 watts, and my PSU is a 550-watt gold power supply. The graphics card is a 1070 EVGA graphics card. The graphics card was working fine and displaying to my monitor correctly. Then I switched to the new case and it is turning on the RGB lights but the fans are not spinning. Another thing to note is that the monitor is no longer recognizing the GPU. I have not modified the GPU so I might send it back to NVIDIA and get a new better one, and it is under warranty. I do not know what is happening as I tried replugging every thing in and then the liquid cooler stopped working. Here is a link to my build on PC part picker: https://pcpartpicker.com/list/pTbCRJ

Thank you for any advice.

Link to post
Share on other sites

Take everything out of the case and test it on the table (bench).

 

Sounds like you have short somewhere.  

 

If it works on the bench, try re-installing in the case again.  


Main Rig:

Case: Corsair Carbide Air 540 

CPU: Ryzen 5 1600 @ 3.8ghz/1.3V 

Cooler: CoolerMaster MasterLiquid 240

MB: ASRock Killer SLI X370 

Ram: Team Vulcan 16gb DDR4 2400 

GPU: Dual XFX R9 390 8GB in Crossfire

PS: Seasonic FOCUS Gold Plus Series SSR-750FX

SSD: Samsung EVO 840 128gb 

HDD: Hitatchi 2tb 7200RPM + 3x 2TB WD Passport USB 3.0

Optical: Lite-On DVD +/-RW 

Monitors: Dual Acer 24" 1080 

Keyboard: IOgear Mechlite

Mouse: Logitech Wireless
OS: Windows 10 Home x64

 

Linux PC:
Case: Zalman T1  CPU: AMD FX 6300  Cooler: Enermax 95mm tower cooler  MB: Gigabyte Motherboard  RAM: 16GB Gskill DDR3  GPU: R9 390  SSD: Transcend 64gb SSD  HDD: WD 2TB  OS: Debian 9 Custom with Synergy for KB/Mouse

Current Vintage Equipment:  Please ask me about it, I love to talk old tech!
IBM Thinkpad 390, IBM Aptiva A12, IBM PS/2 Model 25-004.  Compaq Contura 4/25C, Presario 7596
Asus P5A-B Socket 7 Box, Tandy 1000RLX-HD "B" & 1200-2FD, VIC20, Zenith ZFL-181-93, Packard Bell 300SX.

Apple II/gs, Mac Plus x2, Mac SE x2, Performa 450

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×