Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
WindirBear

Quadcopter help!

Recommended Posts

Posted · Original PosterOP

Hey guys, I have a tyro99, with an XM+ and a taranis xq7A. My issue is, I can't arm the drone.

 

When I'm connected to beta flight, the receiver won't respond either.

 

I already set to taer and nothing, and removed the arm command in beta flight.

 

Only thing I haven't tried is flashing anything. I don't have internet in my house, just on my phone.

 

 

 

20190310_113519.jpg

20190310_113458.jpg

20190310_113133.jpg

20190310_113613.jpg

20190310_113530.jpg

Link to post
Share on other sites

I believe betaflight now has a feature that disables arming when the FC is plugged into the computer. Try disconnecting and power cycling the board. 

 

edit: I just noticed your receiver is connected to UART 2. SBUS is an inverted protocol so you need to connect it to an inverted UART. In my experience, most FCs only have UART 1 inverted, so try changing to UART 1. That is, unless whatever FC you have specifies UART 2 as the SBUS port.


I used to have guides here

CPU: 4670k 4.4ghz GPU: GTX 970 G.1 1534mhz

Link to post
Share on other sites
Posted · Original PosterOP
3 hours ago, Hackentosher said:

I believe betaflight now has a feature that disables arming when the FC is plugged into the computer. Try disconnecting and power cycling the board. 

 

edit: I just noticed your receiver is connected to UART 2. SBUS is an inverted protocol so you need to connect it to an inverted UART. In my experience, most FCs only have UART 1 inverted, so try changing to UART 1. That is, unless whatever FC you have specifies UART 2 as the SBUS port.

I tried the UART 1 with aetr and the taer and still nothing... The flight controller only came with that paper, so it doesn't say much about UART.

 

And just a dumb question, to arm the device, it's throttle down, right. Right?

I don't have it set to any swithes in beta flight.

20190311_003153.jpg

20190311_003258.jpg

Link to post
Share on other sites
23 hours ago, WindirBear said:

I tried the UART 1 with aetr and the taer and still nothing... The flight controller only came with that paper, so it doesn't say much about UART.

 

And just a dumb question, to arm the device, it's throttle down, right. Right?

I don't have it set to any swithes in beta flight.

 

No  I believe the stock arming in Beta is left stick to the bottom right corner, but the very first thing you should do is setup a 5th channel on your radio and use that channel for arming in the modes tab because using the stock arm/disarm command can get dangerous if you're flying, say inverted yaw spins, for example.

 

Stupid question, did you bind your receiver? The XM+ doesn't really have telemetry (although there's a way you can get RSSI out of it and into your FC's OSD) but I believe the lights on the receiver will indicate when the receiver is bound to the radio.


I used to have guides here

CPU: 4670k 4.4ghz GPU: GTX 970 G.1 1534mhz

Link to post
Share on other sites
Posted · Original PosterOP
On 3/11/2019 at 10:48 PM, Hackentosher said:

No  I believe the stock arming in Beta is left stick to the bottom right corner, but the very first thing you should do is setup a 5th channel on your radio and use that channel for arming in the modes tab because using the stock arm/disarm command can get dangerous if you're flying, say inverted yaw spins, for example.

 

Stupid question, did you bind your receiver? The XM+ doesn't really have telemetry (although there's a way you can get RSSI out of it and into your FC's OSD) but I believe the lights on the receiver will indicate when the receiver is bound to the radio.

Hey I was able to finally get it to work.. I had to bridge 2 point on the flight controller.. but now I have another issue.

 

i calibrated the esc and added more solder to the joints.. it's in DSHOT600

Any help is appreciated. Thanks

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×