Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
desti1337

144Hz + 60Hz Dual Monitor Bug/"Feature"

Recommended Posts

Posted · Original PosterOP

Hi Guys/Lads,

I hope that i can provide some "serious" information for an long lasting Bug and help people to not be annoyed/sad after buying an 144Hz Monitor (while using a second 60Hz Monitor)

(@Mods: to be honest, i posted this as a comment in an another thread, but since it has a different Title it might not get found by interested Users. Please delete my comment if necessary)

 

3 Days ago i realised i have an annoying "issue".
Since Apex Legends is out and i noticed same weird FPS drops/issues, I tried to figure out what is wrong on my PC. (the Hz issues got nothing to do with my FPS drops :P )

 

While searching I came around of some reddit posts dedicated to this 144hz/60hz issues and instant tried finding a solution for it.

 

For me, NOTHING helped to have different Hz on my screens (PG278QR 144hz and VS248H 60hz).

 

I feel like, this is something which needs to get WAY! more attention from Media/Users and in the End needs to be fixed by MS or nVidia asap!
There are several Threads on every Computer related Board and reddit, but after Months/Years there is NO Solution at all.

 

So here is what everybody can test!
Open TestUfo Website (google it for link) on your 144hz and wait for it to be synced to your 144hz Monitor. After its synced, open another Browser instance on your 60hz Screen and open the same Website. You will instant notice, that your 144hz Screen will drop FPS and therefore is downed to 60hz.

So whenever you will try watch Linus YT Videos on your 60hz screen and try gaming on your 144hz, it will automatically drop to 60hz.

 

Another good test is, open a game on your 144hz in "exclusive" Fullscreen (its the only "real" Solution to stop this bug while gaming) while running some sort of FPS overlay (like MSI+RTSS or fraps), enable VSYNC in the  (you must not play with vsync, its just for testing). You should get around 144 FPS if your PC is capable to do so.

Now open testufo again on your 60hz Screen -> your Game should still do 144 FPS if you open it.

Here is the clue, go from Fullscreen to Borderless Window or Windowed at all, and voila it drops to 60 FPS (mostly around 70 fps, cause the Monitor Sync Bug is not capable to properly drop your 144hz screen to 60hz)

 

That means, if you are not able to fix this Problem by lowering to 120hz or are lucky with 2 Monitors with DP (might fix it...) you are not able to make GOOD use of your Dual Monitor Setup, cause u are not able to instant move to your Second Screen while gaming. You always have to Alt-Tab what means the Fullscreen Game gets minimized (for me this is really annoying!) + if you watch a Video on your 60hz and wanna read or do anything else on your 144hz screen (no Fullscreen application) it gets always lowered to 60hz.

You might not notice it, but guess 75%+ of time your 144hz screen is lowered to 60hz.

 

I hope this gets some more attention and maybe Linus or his Staff can research this Stuff cause its simply plain stupid that MS OR Nvidia wont fix this Bug/Feature!

(Sorry for long Post and for "bad" english :P )

Link to post
Share on other sites

So I'm not entirely sure what the issue really is.

I run with a ViewSonic VA2759-SMH 60hz overclocked to 75hz, and an ASUS VG248QE at 144Hz, I've never been stuck at 60Hz on my main monitor. Chrome will report as 72Hz in ufo test because of weirdness but the monitor itself is still at 144Hz when gaming and regular desktop use. I'm sensitive to framerates and notice everytime a driver or update has bumped me back down to 60Hz on my main monitor. I play every game in fullscreen though just because in the past windowed borderless used to give me weird issues.

 

Quote

if you watch a Video on your 60hz and wanna read or do anything else on your 144hz screen (no Fullscreen application) it gets always lowered to 60hz.

You might not notice it, but guess 75%+ of time your 144hz screen is lowered to 60hz.

I'll also clarify, if you don't have to manually reset back to 144Hz, the monitor it self IS NOT running at 60 or 72Hz, the application is being frame limited for some reason. If you have a modern smartphone with slow-mo features you can actually test this yourself. while UFO test is showing 60 or 72hz, the monitor is still at 144hz.

as far as I'm aware windows and other applications cannot just force your desktop refresh to something new, the bug is with the way windowed/ fullscreen windowed works. 

 

I'm on windows 10 with a 2080Ti, DP to 144 and HDMI to 75.

 

I'll also leave that if you change to launch options to apex to "+fps_max 0" you will not be frame limited in anyway, this might be away around your issue. Even with Vsync off apex will still cap you at what it is seeing as your refresh-rate is. with this launch option you will no longer be capped to that.

 

Link to post
Share on other sites
Posted · Original PosterOP

@Labeled
What you say is True, but in my eyes it makes no difference to the fact, that the Applikations run at 60Hz (even if the Monitor itself is still running 144Hz). It is lowered to 60Hz (or whatever your second screen is running) via vsync and therefore you have no benefits of a 144Hz Monitor (my opinion).

 

To the Apex issue: I already use the fps_max 0 but makes no difference (Apex is limited from me via RTSS to 141FPS). Right now it looks like i got the Windows 10 "Standby List" Issue, so that my RAM gets completely full (could fix that with the "Intelligent Standby List Cleaner" Tool)

Link to post
Share on other sites
Posted · Original PosterOP
6 minutes ago, maybethisnamewillwork said:

Does this still happen if you go to NVIDIA Control Panel and then select to scale on GPU instead of Display? 

I think i always have/had it set on GPU scaling, but will look it up later.

Link to post
Share on other sites
5 hours ago, desti1337 said:

@Labeled
What you say is True, but in my eyes it makes no difference to the fact, that the Applikations run at 60Hz (even if the Monitor itself is still running 144Hz). It is lowered to 60Hz (or whatever your second screen is running) via vsync and therefore you have no benefits of a 144Hz Monitor (my opinion).

 

To the Apex issue: I already use the fps_max 0 but makes no difference (Apex is limited from me via RTSS to 141FPS). Right now it looks like i got the Windows 10 "Standby List" Issue, so that my RAM gets completely full (could fix that with the "Intelligent Standby List Cleaner" 

I always disable vsync.. is it just fps_max 0 or +fps_max 0? You do need the + in front of it.

 

I'm not entirely sure what the "standby list" issue you're referring to.

Link to post
Share on other sites
Posted · Original PosterOP

@Labeled

Weird, i only know "+fps_max unlimited" as a Startparameter set in the Origin Launcher. Anyway, my FPS are uncapped if i want to :P

But this Thread should not be about Apex, its about this annoying Dual Monitor "Bug"

Link to post
Share on other sites
21 hours ago, desti1337 said:

@Labeled

Weird, i only know "+fps_max unlimited" as a Startparameter set in the Origin Launcher. Anyway, my FPS are uncapped if i want to :P

But this Thread should not be about Apex, its about this annoying Dual Monitor "Bug"

I'm having a hard time even trying to reproduce this bug, UFOtest is opening in 144hz on either monitor even though 1 is at 75 not 144. I disable every vsync or framecap options I can so not even games are doing this.

 

Windows 10 1809 build 17763.316 with nvidia driver 419.17

75Hz is in HDMI and 144Hz is on DP

 

Any other ways I can try to reproduce this bug?

Link to post
Share on other sites

This bug is caused by windows desktop manager.  I've searched for  everything related to this issue, the only thing that last me to try (I cant) is to put the 60hz(secondary) monitor via displayport, and check if that solves as windows stated on a update that  is because gsync on main monitor + hdmi on second (I dont believe that).

https://forums.geforce.com/default/topic/949367/geforce-drivers/144hz-60hz-stuttering-can-we-soon-get-a-fix-for-this-/3/


Case: Corsair 760T  |  Psu: Evga  650w p2 | Cpu-Cooler : Noctua Nh-d15 | Cpu : 8600k  | Gpu: Gygabyte 1070 g1 | Ram: 2x8gb Gskill Trident-Z 3000mhz |  Mobo : Aorus GA-Z370 Gaming K3 | Storage : Ocz 120gb sata ssd , sandisk 480gb ssd , wd 1gb hdd | Keyboard : Corsair k95 rgb plat. | Mouse : Razer deathadder elite | Monitor: Dell s2417DG (1440p 165hz gsync) & a crappy hp 24' ips 1080p | Audio: Schiit stack + Akg k712pro + Blue yeti.

Link to post
Share on other sites

Possible solutions:

1st pick a 144hz secondary monitor (dont have the money now but it seems that works)
2nd (from reddit) If you don't mind using older drivers, you can use 391.35. That's what I've been stuck on, as anything newer introduces all the issues you've experienced.(I will try this tonight, since I've noticed that some nvidia updates fixed this and then another driver update crashed)
3rd Download nvidia inspector and set main monitor performance to single monitor performance (I think this will be promising and will try tonight).


Things that I've done that are useless:

lowering monitor to 120hz to be multiple, (even my secondary to 55hz and my main to 165hz didnt solve the issue)
Secondary monitor on the igpu.

Disabling vsync on nvcp

Specs

8600k + 1070, | dell s2417dg 1440p gsync @ 165hz  via dp + hp 1080p ips 60hz via hdmi


Case: Corsair 760T  |  Psu: Evga  650w p2 | Cpu-Cooler : Noctua Nh-d15 | Cpu : 8600k  | Gpu: Gygabyte 1070 g1 | Ram: 2x8gb Gskill Trident-Z 3000mhz |  Mobo : Aorus GA-Z370 Gaming K3 | Storage : Ocz 120gb sata ssd , sandisk 480gb ssd , wd 1gb hdd | Keyboard : Corsair k95 rgb plat. | Mouse : Razer deathadder elite | Monitor: Dell s2417DG (1440p 165hz gsync) & a crappy hp 24' ips 1080p | Audio: Schiit stack + Akg k712pro + Blue yeti.

Link to post
Share on other sites

Anyone who can dig a little bit more of this issue? , Its here since 2012 or more, not yet fixed or "highlighted" , giving 144 + 60 hz setups are more and more common , this can be one hughe ore vein :P @Crunchy Dragon sorry for bothering you , but since you are a moderator If can you aid us to find any guru on this forum with knowledge of this issue it would be awesome.

 I think someone with high knowledge of windows10 (or any OS like wendell from level1techs) could figure out this, there are few people talking with microsoft and nvidia but seems they are busy throwing the guilt to eachother.... Its known that bug happen when you have 2 different monitor frequency and try to run any hardware acelerated app(like youtube on any browser), windows desktop manager tells to the first screen that renders at secondary raters (60hz), This happen on win10 and 7 , but you can disable aero on 7 and that solves it but not on 10, and since intel 6gen , going back to win7 will put more problems than fixing :( 

Links: 


Updated Reddit thread on /monitors 
 

Up to date Nvidia forum thread

 

Reddit from 4 months ago on /windows10


Case: Corsair 760T  |  Psu: Evga  650w p2 | Cpu-Cooler : Noctua Nh-d15 | Cpu : 8600k  | Gpu: Gygabyte 1070 g1 | Ram: 2x8gb Gskill Trident-Z 3000mhz |  Mobo : Aorus GA-Z370 Gaming K3 | Storage : Ocz 120gb sata ssd , sandisk 480gb ssd , wd 1gb hdd | Keyboard : Corsair k95 rgb plat. | Mouse : Razer deathadder elite | Monitor: Dell s2417DG (1440p 165hz gsync) & a crappy hp 24' ips 1080p | Audio: Schiit stack + Akg k712pro + Blue yeti.

Link to post
Share on other sites

What is your primary display set to in Windows? Which is display number 1?

 

I have a 75Hz display and a 60Hz display, due to some small difficulties, my 60Hz display is Display 1 and my 75Hz is Display 2. My 75Hz display is set as my main display in Windows, and I never have problems with it dropping to 60.

Link to post
Share on other sites

main display (1 on windows ) : 165 1440p  via 1070 dp
secondary : 60hz 1080p . now its via igpu hdmi


Case: Corsair 760T  |  Psu: Evga  650w p2 | Cpu-Cooler : Noctua Nh-d15 | Cpu : 8600k  | Gpu: Gygabyte 1070 g1 | Ram: 2x8gb Gskill Trident-Z 3000mhz |  Mobo : Aorus GA-Z370 Gaming K3 | Storage : Ocz 120gb sata ssd , sandisk 480gb ssd , wd 1gb hdd | Keyboard : Corsair k95 rgb plat. | Mouse : Razer deathadder elite | Monitor: Dell s2417DG (1440p 165hz gsync) & a crappy hp 24' ips 1080p | Audio: Schiit stack + Akg k712pro + Blue yeti.

Link to post
Share on other sites

@desti1337 I think it worked!!! :D:D:D   @Labeled

downlo
d nvidia inspector and try , no need to explain much with this 2 images.

 

 

 

first.png

second.png


Case: Corsair 760T  |  Psu: Evga  650w p2 | Cpu-Cooler : Noctua Nh-d15 | Cpu : 8600k  | Gpu: Gygabyte 1070 g1 | Ram: 2x8gb Gskill Trident-Z 3000mhz |  Mobo : Aorus GA-Z370 Gaming K3 | Storage : Ocz 120gb sata ssd , sandisk 480gb ssd , wd 1gb hdd | Keyboard : Corsair k95 rgb plat. | Mouse : Razer deathadder elite | Monitor: Dell s2417DG (1440p 165hz gsync) & a crappy hp 24' ips 1080p | Audio: Schiit stack + Akg k712pro + Blue yeti.

Link to post
Share on other sites

Mine is Multi display performance mode, however I'm not getting this bug with a 2080Ti and 7700k latest Nvidia drivers and windows updates. So if this works to fix it, great. However it isn't what is causing it.

I'll also put out there that my display is not G-Sync or Free Sync. 

 

My power management is Prefer maximum performance, however.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×