Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Incredibly weird problem with USB-C dongle

Recommended Posts

Posted · Original PosterOP


So... Recently I changed my PC setup to a thunderbolt setup with my laptop. I use two dongles. One with two DP 1.4 and one with USB, Ethernet, power passthrough and sd card slots. After setting it up everything worked fine up until I disconnected my laptop from the dongle with the ethernet port. After I did that my network stopped working (WIFI and LAN, my Routers LAN ports weren't working anymode so it didn't have a connection to the modem anymore). I found out that this was caused by unplugging the laptop from the dongle but leaving it plugged in to the power outlet. I've tried multiple dongles of the same type and the problem kept happening. If I plug the ethernet cable directly into my modem it works fine and the modem continues working after I unplug my laptop.

My current theory as to why it happens:
I believe the dongle receives too much power and transfers it over PoE to the router which my specific router can't handle and it just sits around doing nothing.


My router:

Netgear R6800


My USB dongle:

Satechi USB-C Aluminium Multiport Adapter


Does anyone have an idea how I could try to fix it?

In addition to not knowing how to fix it I have absolutely no idea what keywords to search on google for my problem...



Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now