Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
princemc

So many questions..

Recommended Posts

Posted · Original PosterOP

So I'm not sure if this will be in the right thread or not. Its kind of a network issue but could be a Windows issue. 

 

So I have some files on my laptop that I'd like to try to transfer over to my desktop. It's about 60gb worth and I have slow internet at home so I'm trying to avoid using any type of cloud service for this. (10:1 DSL connection)

 

I read conflicting information about transferring files between PC's using a USB-C to USB-C cable, and couldn't find a definitive guide so I abandoned that idea. For some odd reason my 32gb USB 3.0 flash drive cannot be used by my laptop, but does show up on my desktop when plugged in. So I then started trying to transfer files over LAN.

 

I made sure to turn Network Discovery on for both devices (Windows 10 on each), enabling every possible sharing option I could find. I mapped one of my Desktop's drives to the Network, and it's not discoverable by my laptop. My laptop cannot be accessed by my desktop due to permissions limitations I have no idea how to disable. Clicking the help link takes me to Microsoft support page but not to any article explaining how to fix it. I tried network sharing the folder I'm trying to transfer, and that doesn't show up on my desktop either.

 

I'm at a complete loss here. I have no idea how to transfer these files without it taking 4 days due to my horrible upload speeds into a cloud service. I'd like to try to go the LAN route if anyone has any suggestions on what to do. I'd really appreciate it.

Link to post
Share on other sites

How about a flash drive? If you have USB-C, it shouldn't take long. They happen to come in a convenient 64GB size!

 

https://www.bhphotovideo.com/c/product/1303886-REG/sandisk_sdddc2_064g_a46_dual_drive_usb_c_64gb.html

 

 


Screwdriver specs: Long, pointy. Turns things. Some kind of metal.

 

My rig:

Xeon  E5-1630v4 | Quadro P4000 | Asus X99-E WS | 4x8GB G-Skill DDR4-2400 | Samsung 960 EVO 250GB | 8TB spinning rust

 

HTPC:

i7-4790 | GTX1650 | Dell Sadness | 20GB DDR3 1600 | Samsung 860 250GB | 1TB magnetic storage | James Loudspeaker SPL3 x2

 

Autodesk 3ds Max, AutoCAD, Inventor, Revit, Recap, and Fusion

Adobe Photoshop, Premiere, AfterEffects, Illustrator, Brackets, Dreamweaver

Matlab, MS Visual Studio, Davinci Resolve

 

And MS Paint

Link to post
Share on other sites

do you get an error when trying to use usb or what? more details, please. also, take a screenshot of the disk management settings thing after you plug in usb. 

Link to post
Share on other sites

What error are you getting on the network share? That's probably the best way of doing it.


PC Specs:

CPU: AMD 1700x Cooler: Corsair H100i V2 Motherboard: Asus Crosshair VI Hero RAM: 4 * 8GB G.Skill RGB DDR4 Graphics: EVGA GTX 1080 Ti SC2 Storage: Samsung 960 EVO 500GB Case: Fractal Design Meshify C PSU: EVGA 750w G3 Monitors: Dell SG2716DG +  2x Dell U2515H

 

Freenas specs:

CPU: Intel Xeon E5-2650 V2 Cooler: Some noctua cooler Motherboard: Supermicro X9 SRL-F RAM: 8 * 8GB Samsung DDR3 ECC Storage: 6 * 4TB Seagate 7200 RPM RAIDZ2 Controller: LSI H220 Case: Phanteks Enthoo Pro PSU: EVGA 650w G3

 

Phone: iPhone 6S 32 GB Space Grey

Link to post
Share on other sites

Set up a FTP server on one computer, doesn't matter which one. Filezilla FTP server is free and super easy to set up.

Set up an account. If ftp server on pc with data, set the drive as user's folder. If ftp server on destination pc,set user's folder the folder where you want to transfer data to (and check all boxes to allow creation of files and folders)

 

Use ftp client on other pc and connect to ftp server using the other pc's ip address.

 

if you want follow this video: http://savedonthe.net/a/tutorial.mkv

Has no sound because i originally made it for a friend and i spoke in my native language, so it would be useless to you (most likely)

Link to post
Share on other sites
Posted · Original PosterOP
On 2/21/2019 at 9:27 PM, Lord Mirdalan said:

How about a flash drive? If you have USB-C, it shouldn't take long. They happen to come in a convenient 64GB size!

 

https://www.bhphotovideo.com/c/product/1303886-REG/sandisk_sdddc2_064g_a46_dual_drive_usb_c_64gb.html

I'm looking to do this without spending money since I should have a wide variety of tools at my disposal, I just can't seem to get any of them to work correctly. 

 

On 2/21/2019 at 9:26 PM, ChewToy! said:

Take your hard drive or SSD out of laptop, hook it up to desktop and copy the files over?

 

On 2/21/2019 at 9:27 PM, dgsddfgdfhgs said:

do it the old way.

pull out hard disc from laptop and plug it in.

 

to be more lazy, use phone sd card storage to transfer 

Laptop is a Dell XPS 13, I don't know if the storage is even removable in it, and if it is it's probably an M.2 Drive, so I would have to take my boot drive out of my PC to plug it in for file transfer.

 

On 2/21/2019 at 9:27 PM, Saksham said:

do you get an error when trying to use usb or what? more details, please. also, take a screenshot of the disk management settings thing after you plug in usb. 

I don't get any errors when I plug in the USB drive. Windows plays the notification sound that I plugged in a new device, but the drive doesn't show up on "This PC" nor does it show up in Disk Management. It shows up in Device Manager with a yellow triangle error sign and I believe it says drivers are outdated but I can't get it to install new ones either. My USB dongle for a wireless mouse still works fine but 2 separate flash drives do not.

 

On 2/21/2019 at 9:29 PM, ThatFlashCat said:

What error are you getting on the network share? That's probably the best way of doing it.

After turning on Network Discovery and removing password authentication for file sharing, I try to browse the files on each PC from the other, an error like this appears

K5aSL-e1417787881492.png

 

On 2/21/2019 at 9:43 PM, mariushm said:

Set up a FTP server on one computer, doesn't matter which one. Filezilla FTP server is free and super easy to set up.

Set up an account. If ftp server on pc with data, set the drive as user's folder. If ftp server on destination pc,set user's folder the folder where you want to transfer data to (and check all boxes to allow creation of files and folders)

 

Use ftp client on other pc and connect to ftp server using the other pc's ip address.

 

if you want follow this video: http://savedonthe.net/a/tutorial.mkv

Has no sound because i originally made it for a friend and i spoke in my native language, so it would be useless to you (most likely)

Thanks a lot, I'll give this a go in a little while

Link to post
Share on other sites

As previously stated, it would be a good idea to take a screenshot of your disk management before the USB key is inserted, then insert the USB key and take another screenshot, there is a possibility that when u insert your USB key, its trying to grab a drive letter that your laptop is already using.

 

If you take the screenshot of disk management with the USB key inserted u should be able to see it in the list, and then you can change the drive letter if thats what the issue is.

Link to post
Share on other sites
Posted · Original PosterOP
11 hours ago, mariushm said:

Set up a FTP server on one computer, doesn't matter which one. Filezilla FTP server is free and super easy to set up.

Set up an account. If ftp server on pc with data, set the drive as user's folder. If ftp server on destination pc,set user's folder the folder where you want to transfer data to (and check all boxes to allow creation of files and folders)

 

Use ftp client on other pc and connect to ftp server using the other pc's ip address.

 

if you want follow this video: http://savedonthe.net/a/tutorial.mkv

Has no sound because i originally made it for a friend and i spoke in my native language, so it would be useless to you (most likely)

So I've tried to use Filezilla and after watching your tutorial and about 6 others, I can't seem to get it to connect. Originally I was getting "Connection Refused" errors, but now it just times out when I try to connect and I'm not sure what I'm doing wrong here.

Link to post
Share on other sites

On the computer where you install the Filezilla FTP Server, go to WIndows Firewall and add Filezilla FTP Server.exe to the whitelist (allow programs to connect to it).

Look in Network Connections and determine what IP address that computer receives from the modem/router/switch

In Windows 7, it's in Network Connections, click on Local Area Connection or whatever is called and then click on Details. You see there IPv4 IP address.  On Windows 10, it may be slightly different, but should be easy to find the information.

 

image.png.9d2e199fdbe211a79eb99751c860b6af.png

 

You can see in the details that my IP address is 192.168.0.10 , so that's what I'd use on another computer in the ftp client, if the server software is installed on this pc.

 

On the other computer, you start Filezilla FTP Client and enter that computer's IP address.

 

In the video, i used "localhost" because I installed both server and client on same computer, and "localhost" is a "nickname"/shortcut for "this pc's ip address" - if you enter that in your ftp client, the ftp client will try to connect to a ftp server on same computer, and you probably don't have one.

 

Link to post
Share on other sites
Posted · Original PosterOP
1 hour ago, mariushm said:

On the computer where you install the Filezilla FTP Server, go to WIndows Firewall and add Filezilla FTP Server.exe to the whitelist (allow programs to connect to it).

Look in Network Connections and determine what IP address that computer receives from the modem/router/switch

In Windows 7, it's in Network Connections, click on Local Area Connection or whatever is called and then click on Details. You see there IPv4 IP address.  On Windows 10, it may be slightly different, but should be easy to find the information.

 

image.png.9d2e199fdbe211a79eb99751c860b6af.png

 

You can see in the details that my IP address is 192.168.0.10 , so that's what I'd use on another computer in the ftp client, if the server software is installed on this pc.

 

On the other computer, you start Filezilla FTP Client and enter that computer's IP address.

 

In the video, i used "localhost" because I installed both server and client on same computer, and "localhost" is a "nickname"/shortcut for "this pc's ip address" - if you enter that in your ftp client, the ftp client will try to connect to a ftp server on same computer, and you probably don't have one.

 

I finally got the connection up, but now I'm left with the 425 error saying it can't connect to the directory

Link to post
Share on other sites

In Filezilla FTP Server after you create the account and add the folder you want for that user,  click on the folder and then check the List and +Subdirs, so that users can browse the contents of folders:

 

ftp_folders.png.d01b11797adbcc2e23f23214ced46403.png

 

 

And as a tip, if you have multiple drives or folders in different locations you can use this trick:

 

Create a folder somewhere, and leave it empty ... for example C:\Temp\FTP  ... add that folder in the window from the picture.

Right click on folder and select  "Set as home dir"  if that H icon isn't already set to the left of the folder name.  In the picture above, my folder is "C:\Programs\FTP"

Now, add your hard drives or various folders. Make sure you check List and +Subdirs for each one you add.

By default, they won't be visible but you can make them show up by telling Filezilla to create fake folders in your home folder (the first folder you added)

Right click on each drive or folder that you added and select Edit aliases option and type a name for your fake folder name, with a / character in front.

For example you could add D:\ and set alias to /music , E:\ can be /movies  , your optical drive if you have any let's say F:\ can get the alias /dvd-drive   

Once you hit OK and refresh the folder view in your FTP client, you'll see those show up as regular folders in your FTP client.

 

In the picture above, you can see I added all my hard drive letters as folders my simply giving each a letter after the / character.

Link to post
Share on other sites

uninstall usb drivers, restart computer, (windows automatically installs usb driver), update drivers manually, check windows update for new drivers. 

Link to post
Share on other sites
Posted · Original PosterOP
22 hours ago, mariushm said:

In Filezilla FTP Server after you create the account and add the folder you want for that user,  click on the folder and then check the List and +Subdirs, so that users can browse the contents of folders:

 

And as a tip, if you have multiple drives or folders in different locations you can use this trick:

 

Create a folder somewhere, and leave it empty ... for example C:\Temp\FTP  ... add that folder in the window from the picture.

Right click on folder and select  "Set as home dir"  if that H icon isn't already set to the left of the folder name.  In the picture above, my folder is "C:\Programs\FTP"

Now, add your hard drives or various folders. Make sure you check List and +Subdirs for each one you add.

By default, they won't be visible but you can make them show up by telling Filezilla to create fake folders in your home folder (the first folder you added)

Right click on each drive or folder that you added and select Edit aliases option and type a name for your fake folder name, with a / character in front.

For example you could add D:\ and set alias to /music , E:\ can be /movies  , your optical drive if you have any let's say F:\ can get the alias /dvd-drive   

Once you hit OK and refresh the folder view in your FTP client, you'll see those show up as regular folders in your FTP client.

 

In the picture above, you can see I added all my hard drive letters as folders my simply giving each a letter after the / character.

I'll give that a try later tonight once I get out of work. I really appreciate all your help so far. I've kinda been wanting to set up and FTP server for a while now but I never thought I would have to do it just to transfer some files to another pc on my network. 

 

So far, I've tried to set up the server on my laptop, because that's where the files are, and running the client on my desktop. I think tonight I'm going to do the reverse and set up the server on my desktop instead and use my laptop as a client and see if I can get it to work that way. Although I'll have to go change my port forwarding options, I think it might work out a little better. I've had network issues with that laptop since I got it so there could be something on it that's preventing inbound connections but outbound connections might work a little better for me.

 

15 hours ago, Saksham said:

uninstall usb drivers, restart computer, (windows automatically installs usb driver), update drivers manually, check windows update for new drivers. 

I'll give that a shot. I also haven't had the time yet to check and see if my flash drive is using a letter assignment that my laptop is currently using so I'll have to try to reassign paths on my desktop and see what happens. It's hard to imagine that's the case, because I have about 6 drives total in my PC and only one on my laptop, but I suppose there could be partitions with other letter assignments that are hidden on my laptop, but are not hidden on my desktop. 

Link to post
Share on other sites

If the two computers are within your home network, then there's no reason to deal with port forwarding - you only need to do that if you want the ftp server to be accessible from outside your home.

 

Inside your apartment, you can simply connect to the server using the local IP address, not the external one (which you can determine using a site like ping.eu or by googling "my ip address" )

 

Whatever you do, you must allow the ftp server executable to listen for connections and accept connections, by adding the executable "FileZilla Server.exe"  in the firewall rules.

Maybe check your antivirus as well, it could have a built in firewall or something.

Link to post
Share on other sites
Posted · Original PosterOP
11 minutes ago, mariushm said:

If the two computers are within your home network, then there's no reason to deal with port forwarding - you only need to do that if you want the ftp server to be accessible from outside your home.

 

Inside your apartment, you can simply connect to the server using the local IP address, not the external one (which you can determine using a site like ping.eu or by googling "my ip address" )

 

Whatever you do, you must allow the ftp server executable to listen for connections and accept connections, by adding the executable "FileZilla Server.exe"  in the firewall rules.

Maybe check your antivirus as well, it could have a built in firewall or something.

I've added both the server, and the client through the firewall on each respective PC. The connection completes now, but I keep getting the "425: Can't open data connection for transfer of /" error. I have been using local IP to attempt the connection and that's where I get stuck at is the 425, and subsequent 421 disconnect error.

Link to post
Share on other sites

The only other thing I can think of would be changing Transfer mode from Passive to Active, or the other way around.

 

In Filezilla FTP Client, options, Connection > FTP > Transfer mode. 

By default, it's set to Passive mode and should work fine.  Change it to Active and restart the client and try again. If it's already set to active, try with Passive mode.

 

It's just two different modes of creating the data connection between the computers which is used to transfer file listings, actual files and so on.

 

As an older design, FTP was designed from the start to have a command connection (the one through which client says "show me files in folder xyz, go inside folder xyz, resume download") and separate data connections which are created as needed.

 

Link to post
Share on other sites
Posted · Original PosterOP
44 minutes ago, mariushm said:

The only other thing I can think of would be changing Transfer mode from Passive to Active, or the other way around.

 

In Filezilla FTP Client, options, Connection > FTP > Transfer mode. 

By default, it's set to Passive mode and should work fine.  Change it to Active and restart the client and try again. If it's already set to active, try with Passive mode.

 

It's just two different modes of creating the data connection between the computers which is used to transfer file listings, actual files and so on.

 

As an older design, FTP was designed from the start to have a command connection (the one through which client says "show me files in folder xyz, go inside folder xyz, resume download") and separate data connections which are created as needed.

 

I'll try a couple different things when I get home tonight. I'll try the things you suggested and I will also try making my desktop the server instead of the laptop being the server

Link to post
Share on other sites
Posted · Original PosterOP
On 2/23/2019 at 12:20 PM, mariushm said:

The only other thing I can think of would be changing Transfer mode from Passive to Active, or the other way around.

 

In Filezilla FTP Client, options, Connection > FTP > Transfer mode. 

By default, it's set to Passive mode and should work fine.  Change it to Active and restart the client and try again. If it's already set to active, try with Passive mode.

 

It's just two different modes of creating the data connection between the computers which is used to transfer file listings, actual files and so on.

 

As an older design, FTP was designed from the start to have a command connection (the one through which client says "show me files in folder xyz, go inside folder xyz, resume download") and separate data connections which are created as needed.

 

Okay, I finally got it to work. I had to setup the server on my Desktop and run the client on my laptop. I also had to disable IP checks because it was preventing me from getting the proper connection. I know that isn't the safest option but I'll figure it out if I plan on running it in a more permanent fashion later on. Thank you for all the help!

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×