Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Morph Tollon

I need gpu driver help!

Recommended Posts

Posted · Original PosterOP

Was playing a game early today and then the game crashed, I have a 660 ti,  and then the computer blue screened. i re boot and then dose not turn on again without graphical artifacts and instant blue screening. it happened after a system reboot so i am lead to believe than Nvidias newest driver is in some way corrupt or something. i can no longer boot the computer unless it is in safe mode. shall i just reinstall windows, unplug the Ethernet cable so it cant auto update and just install drivers from half a year ago to play it safe? any help will be greatly appreciated,

Link to post
Share on other sites

It may be that your drivers are corrupt, clean them out with DDU and attempt a reinstallation. If it persists, try a rollback to a previous version.


~Remember to quote posts to continue support on your thread~

CPU:  Intel  i7-4790k | RAM: 4x4GB G.Skill Ripjaws Z | Cooling: XSPC/EK/Bitspower loop | MOBO: MSI Z97-G45 | PSU: Seasonic Prime 750 Titanium  

SSD: 250GB Crucial MX200 (OS) | 1TB Crucial MX500 | Case: Phanteks Evolv X | GPU: EVGA GTX 1080 Ti FTW3 (with EK Block) | HDD: 1x Seagate Barracuda 2TB

Link to post
Share on other sites
Posted (edited) · Original PosterOP

i have re installed windows and it still wont make a difference and you cat disable updates in safe mode.

 

At the fresh re install it worked the it installed some drivers and restarted and blue screened

Edited by Morph Tollon
more info
Link to post
Share on other sites
Posted · Original PosterOP
6 minutes ago, Morph Tollon said:

i have re installed windows and it still wont make a difference and you cat disable updates in safe mode.

 

At the fresh re install it worked the it installed some drivers and restarted and blue screened

 

17 minutes ago, Morph Tollon said:

Was playing a game early today and then the game crashed, I have a 660 ti,  and then the computer blue screened. i re boot and then dose not turn on again without graphical artifacts and instant blue screening. it happened after a system reboot so i am lead to believe than Nvidias newest driver is in some way corrupt or something. i can no longer boot the computer unless it is in safe mode. shall i just reinstall windows, unplug the Ethernet cable so it cant auto update and just install drivers from half a year ago to play it safe? any help will be greatly appreciated,

 

PC HARDWARE:

 

ryzen 7

 

a gigabyte GA-A320M-S2H (rev. 1.x )

 

A gtx 660TI from msi

 

3 hdds and a sata dvd drive

 

600w psu

 

Win 10 home premium

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×