Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Remedies

Identifying which h50 to use for kraken g12

Should be the correct part number you referenced, but there a sticker on the endtank to double check.  I'd recommend changing out the current fan installed in the photo to either an SP or ML.  The one in the photo is an AF (air flow) and not ideal for radiator mounting.

Recommended Posts

Posted · Original PosterOP

Hello, I received a 1080 from my friend when he upgraded and love the card but it is a FE card and is either loud or hot, sometimes both. I have been looking for a water cooler a and found a h50 on craigslist that is said to be compatible with the kraken g12 mounting kit, but only in the CW-906006-WW model only. I have a picture linked below. Do you think this is the correct one and will mount to the graphics card. Also will this cool my GPU better than my current FE cooler? Should I not get the mounting kit and just do the "ghetto way" with the blower fan's end still attached? Thanks.

1

Link to post
Share on other sites

alternative: arctic vga cooler?


PSU Tier List//Graphics card (cooling) tier list//Build Guide Megathread//Motherboard Tier List//Linux Guide//Build logs///Before troubleshoot//Mark Solved//Off Topic//Community standards

Don't forget to quote or mention me

 

Primary PC:

Spoiler

CPU: I5-8600k  @4.5 ghz  GPU: GTX 1070 ti EVGA SC Gaming   RAM: 8+8 3360 mhz DDR4 Trident Z   MOBO: MSI Gaming Pro Carbon AC   HDD: 1 TB 7200 RPM Seagate Baracudda, 1 TB 5400 RPM Samsung ECOGREEN   SSD: Samsung 860 EVO 500 GB   Soundcard: built in   Case: Cooler Master Masterbox Lite 5 RGB   Screen: Salora 40LED1500

 

Second PC: Cedar mill

Spoiler

CPU: i3-2130   GPU: Intel HD graphics   RAM: 4+2 GB 1333 mhz DDR3    MOBO: HP H series   HDD: 320 GB WD Black 7200 RPM   PSU: HP 250 watt   Soundcard: built in   Case: Sunbeam Quarterback   Screen: IIyama Prolite T2240MTS, Samsung SyncMaster710N

 

Server: CookieVault

Spoiler

CPU: core2dual E8400   GPU: Intel HD graphics   RAM: 2+1+1+1 gb 1333 mhz ddr3   MOBO: HP Q series   HDD: 4x 1tb 5400 RPM Samsung Spinpoint Ecogreen   Soundcard: built in   Case: Compaq 6000 pro mt   Screen: Samsung SyncMaster710n

 

Laptop : Acer TravelMate 8573t

Spoiler

CPU: I3-2330M   GPU: Intel HD graphics   RAM: 8+2 GB 1333 mhz DDR3   MOBO: Acer   SSD: 250 gb mx500 sata   Soundcard: built in   Case: Acer TravelMate 8573t   Screen: TN 768p

 

Game consoles:

Spoiler

PS4 slim glacier white 500 gb, PS4 FTP Special Edition 500 gb, Xbox, 3 DS lites, DSI XL, Gameboy Advanced Color, PS Vita v2, Wii, PS3 500 gb

 

Link to post
Share on other sites
Posted · Original PosterOP
9 minutes ago, LukeSavenije said:

alternative: arctic vga cooler?

That is a good option but I've seen people do a water cooling swap and get very similar results. Id definitely  try that if the water cooling fails. I also forgot to mention I found that h50 for $15 and would at least want to give it a try(given that it will mount) as opposed to instantly putting down 80 bucks on the arctic cooler.

Link to post
Share on other sites
2 minutes ago, Remedies said:

That is a good option but I've seen people do a water cooling swap and get very similar results. Id definitely  try that if the water cooling fails. I also forgot to mention I found that h50 for $15 and would at least want to give it a try(given that it will mount) as opposed to instantly putting down 80 bucks on the arctic cooler.

yeah... you're probably right

 

I would suggest to ask the seller what model it is

 

and i'll add @Corsair Nick here just to be sure


PSU Tier List//Graphics card (cooling) tier list//Build Guide Megathread//Motherboard Tier List//Linux Guide//Build logs///Before troubleshoot//Mark Solved//Off Topic//Community standards

Don't forget to quote or mention me

 

Primary PC:

Spoiler

CPU: I5-8600k  @4.5 ghz  GPU: GTX 1070 ti EVGA SC Gaming   RAM: 8+8 3360 mhz DDR4 Trident Z   MOBO: MSI Gaming Pro Carbon AC   HDD: 1 TB 7200 RPM Seagate Baracudda, 1 TB 5400 RPM Samsung ECOGREEN   SSD: Samsung 860 EVO 500 GB   Soundcard: built in   Case: Cooler Master Masterbox Lite 5 RGB   Screen: Salora 40LED1500

 

Second PC: Cedar mill

Spoiler

CPU: i3-2130   GPU: Intel HD graphics   RAM: 4+2 GB 1333 mhz DDR3    MOBO: HP H series   HDD: 320 GB WD Black 7200 RPM   PSU: HP 250 watt   Soundcard: built in   Case: Sunbeam Quarterback   Screen: IIyama Prolite T2240MTS, Samsung SyncMaster710N

 

Server: CookieVault

Spoiler

CPU: core2dual E8400   GPU: Intel HD graphics   RAM: 2+1+1+1 gb 1333 mhz ddr3   MOBO: HP Q series   HDD: 4x 1tb 5400 RPM Samsung Spinpoint Ecogreen   Soundcard: built in   Case: Compaq 6000 pro mt   Screen: Samsung SyncMaster710n

 

Laptop : Acer TravelMate 8573t

Spoiler

CPU: I3-2330M   GPU: Intel HD graphics   RAM: 8+2 GB 1333 mhz DDR3   MOBO: Acer   SSD: 250 gb mx500 sata   Soundcard: built in   Case: Acer TravelMate 8573t   Screen: TN 768p

 

Game consoles:

Spoiler

PS4 slim glacier white 500 gb, PS4 FTP Special Edition 500 gb, Xbox, 3 DS lites, DSI XL, Gameboy Advanced Color, PS Vita v2, Wii, PS3 500 gb

 

Link to post
Share on other sites
Posted · Best Answer

Should be the correct part number you referenced, but there a sticker on the endtank to double check.  I'd recommend changing out the current fan installed in the photo to either an SP or ML.  The one in the photo is an AF (air flow) and not ideal for radiator mounting.

Link to post
Share on other sites

I'd buy a new one, like a Thermaltake Water 3.0, you'll get warranty, and one that isn't so old.


PC (Main)

 

CPU: i5-8400 CPU Cooler: Cryorig M9 Plus   Motherboard: Gigabyte B360M DS3H | RAM: Crucial Ballistix Sport 2x8 DDR4-2400

 Boot/OS SSD: Inland 480GB SSD | Video Card: RX 570 4GB Strix OC | Case: Fractal Design Meshify C White TG (11/10) PSU: EVGA SuperNOVA G3 750

Monitor: Sceptre 24" 1080p 75hz

 

NAS:

Synology DS418J w/ 4x WD Red Pro 6TB RAID 10 (used 7.3/12TB)

 

Phone/Tablet:

iPhone 8 64GB iPad Mini 4 128GB

 

Laptops:

Dell XPS 15 9570 i7-8750H + 1050 ti + 20GB ram (16+4) + 1TB EX920 SSD

 

My old computers:

Athlon x64 + R9600 Pro 256MB Core 2 Quad Q8400 @ 3.4ghz + GTX 275 | i5-3570k @ 4.4ghz + GTX 670

Link to post
Share on other sites
Posted · Original PosterOP
6 minutes ago, Corsair Nick said:

Should be the correct part number you referenced, but there a sticker on the endtank to double check.  I'd recommend changing out the current fan installed in the photo to either an SP or ML.  The one in the photo is an AF (air flow) and not ideal for radiator mounting.

Alright, I'll have the seller confirm the model and I already have a new fan ready to go. Thanks!

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×