Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Squanchy

Cables from g3 650w / 850w

Recommended Posts

Posted · Original PosterOP

Hello all, 

Quick question before i pull the trigger on buying a new psu. I currently have a 650w g3 psu, will those exact cables work with the 850w g3 model? Can I just unplug and plug in the new psu without rerouting all my cables?


Current System: i7 8700k (OC'd 5ghz), GTX 1070 Ti, Z370 Hero Maximus, 16GB 3000mhz Ram, corsair 460x, 500gb 960 EVO, 750w HXi PSU, 5x ML140 fans, 1440p 144hz Gsync Monitor.

Link to post
Share on other sites

Why are you replacing a 650w G3 with a 850w G3?


CPU: Intel i7 6700k  | Motherboard: Gigabyte Z170x Gaming 5 | RAM: 2x8GB 3000MHz G.Skill Ripjaws 5 | GPU: Gigabyte Aorus GTX 1080ti | PSU: Corsair RM750x (2018) | Case: BeQuiet SilentBase 800 | Cooler: Corsair H100i AIO | SSD: Samsung 970 Evo 500GB + Samsung 840 500GB | HDD: Seagate Ironwolf 8TB + 2x Seagate Ironwolf 6TB | Monitor: Acer Predator XB271HU + Samsung BX2450

Link to post
Share on other sites

Your PC doesn't need 850w. The only reason I would change the PSU is because of the issues inside of the G3, not the wattage. 650w is perfectly fine for your system, even with the 8700k overclocked.


PSU Tier List

 

  PCs and other things:

Spoiler

Current PC

CPU: AMD A8-6600k (@4.2Ghz)

GPU: GTX 1070Ti 8gb FTW2 iCX

Motherboard: GA-F2A78M-HD2 

RAM: 8gb Patriot DDR3-1600mhz

Storage: Samsung 830 EVO 120gb, WD Blue 1tb 7200RPM 

PSU: SeaSonicM12II 620w (I wish I didn't buy this)

 Peripherals: Logitech G305//Corsair K55 RGB 

Displays: Asus MG248QR//Dell 1905FP

Spoiler

New PC (getting parts)

CPU: i7-8086k [✓]

Cooling: EVGA CLC 280 RGB [✓]

GPU: EVGA GTX 1070Ti 8gb FTW2 iCX [✓]

Mobo: GIGABYTE Z390 AORUS PRO [✓]

RAM: XPG SPEXTRIX X41 2666mhz (Grey) [✓]

 Storage: T-Force Delta 250gb, WD Blue 1tb 7200RPM [✓]

PSU: 650w+ and ranked well

Case: Fractal Design Meshify C White

Peripherals: Logitech G305//Corsair K55 RGB [✓]

Displays: Asus MG248QR//Dell 1905FP [✓]

Extra: Sky blue front panel, sky blue cable extensions [✓]

Spoiler

Other

Phone: Huawei Mate 10 Lite (China steal my data???)

Dog: Irish Water Spaniel, Lucy, 9 years old (I didn't know what to write)

School Laptop: Acer Chromebook R11 ((less RAM than my phone)

 

Link to post
Share on other sites
1 hour ago, Atreyix said:

Hello all, 

Quick question before i pull the trigger on buying a new psu. I currently have a 650w g3 psu, will those exact cables work with the 850w g3 model? Can I just unplug and plug in the new psu without rerouting all my cables?

Are you doing VEGA 64 LC Crossfire or what's your plan?
Dual LGA2066??


"Hell is full of good meanings, but Heaven is full of good works"

Link to post
Share on other sites
Posted · Original PosterOP

My pc isnt updated, i apologize. I now have a 2080 ti with my 8700k. That is the reason I want a bigger psu. 650w is hitting the limits. Now... will the cables work between the two models?


Current System: i7 8700k (OC'd 5ghz), GTX 1070 Ti, Z370 Hero Maximus, 16GB 3000mhz Ram, corsair 460x, 500gb 960 EVO, 750w HXi PSU, 5x ML140 fans, 1440p 144hz Gsync Monitor.

Link to post
Share on other sites
1 minute ago, Atreyix said:

My pc isnt updated, i apologize. I now have a 2080 ti with my 8700k. That is the reason I want a bigger psu. 650w is hitting the limits. Now... will the cables work between the two models?

You are not going to push a 650W PSU to its limits by powering a ~350W PC with it. You don't need to upgrade. 


 

Quote

Women. They are a complete mystery.

-Stephen Hawking

 

I think the hoomans put their builds here?

Why do you hoomans give your builds a name? Here's my build, which I shall call "Do as I Say, Not As I Do" (seriously, don't get this build)

Spoiler

Ryzen 1500X @3,925 GHz

Cooler Master Hyper 212 Evo + 2x ML120

MSI B350 Tomahawk Arctic

2x8GB Corsair Vengeance LPX 3000 MHz CL15 (Micron B-die) @2933 MHz

Sapphire Radeon R9 280 Dual-X @1120 MHz / 1450 MHz

120GB 850 Evo

120GB Kingston SSD

500GB WD Blue

Cooler Master Elite 430

Seasonic Prime Titanium 650W

Logitech G710 with Kailh Box Jade

Logitech G502

HyperX Cloud

And my laptop, which I shall call "If It's Stupid But It Works" (It can actually play CS:GO at 50 FPS, and Civ V at 25 FPS)

Spoiler

Lenovo Thinkpad L460

Intel Core i3 6100U

4GB (probably) DDR4 2133 MHz

Intel HD Graphics 520 0.3-1.0 GHz

128GB Samsung MZ7LF128HCHP

Corsair M65 Pro RGB (worst mouse I've ever had)

Sennheiser CX 5.00G

And here would be where I would put a picture of my cat. But apparently, images are not allowed here. So take this instead (*ΦωΦ*)

Hello fellow night theme users

Link to post
Share on other sites
1 minute ago, Atreyix said:

My pc isnt updated, i apologize. I now have a 2080 ti with my 8700k. That is the reason I want a bigger psu. 650w is hitting the limits. Now... will the cables work between the two models?

How often are you running LN2 cooling on your CPU? Because that's the only way you'd be "hitting the limits" of a 650W PSU with a single 2080 ti and 8700k.


CPU: Intel i7 6700k  | Motherboard: Gigabyte Z170x Gaming 5 | RAM: 2x8GB 3000MHz G.Skill Ripjaws 5 | GPU: Gigabyte Aorus GTX 1080ti | PSU: Corsair RM750x (2018) | Case: BeQuiet SilentBase 800 | Cooler: Corsair H100i AIO | SSD: Samsung 970 Evo 500GB + Samsung 840 500GB | HDD: Seagate Ironwolf 8TB + 2x Seagate Ironwolf 6TB | Monitor: Acer Predator XB271HU + Samsung BX2450

Link to post
Share on other sites
Posted · Original PosterOP
2 minutes ago, Spotty said:

How often are you running LN2 cooling on your CPU? Because that's the only way you'd be "hitting the limits" of a 650W PSU with a single 2080 ti and 8700k.

My OC on my 8700k and my old 1070 ti was fine, ran perfectly fine. Now with my 2080 ti and my OC on the cpu, when I load up anything intensive, like BF5 after 2-3 minutes I bluescreen. Took the OC off, now running fine. 

 


Current System: i7 8700k (OC'd 5ghz), GTX 1070 Ti, Z370 Hero Maximus, 16GB 3000mhz Ram, corsair 460x, 500gb 960 EVO, 750w HXi PSU, 5x ML140 fans, 1440p 144hz Gsync Monitor.

Link to post
Share on other sites
Just now, Atreyix said:

My OC on my 8700k and my old 1070 ti was fine, ran perfectly fine. Now with my 2080 ti and my OC on the cpu, when I load up anything intensive, like BF5 after 2-3 minutes I bluescreen. Took the OC off, now running fine. 

 

Sounds like a stability issue with the overclock then. Run Prime95 for a few hours when you set your CPU overclock to test the stability of the system. You may need to lower your clocks or increase the voltage slightly.

Stock 2080Ti is ~250W. 8700k overclocked to 5GHz is ~175W while running Prime95, and way less during gaming loads. There's no way you're hitting >650W. You'd just be wasting your money on a new PSU that won't solve your issue.
 

Spoiler

image.png.5637f61b93b768cdb4e87116f046a2a4.png

 

image.png.bd1883e04b11234ad801a4f8a937ae6e.png

 


CPU: Intel i7 6700k  | Motherboard: Gigabyte Z170x Gaming 5 | RAM: 2x8GB 3000MHz G.Skill Ripjaws 5 | GPU: Gigabyte Aorus GTX 1080ti | PSU: Corsair RM750x (2018) | Case: BeQuiet SilentBase 800 | Cooler: Corsair H100i AIO | SSD: Samsung 970 Evo 500GB + Samsung 840 500GB | HDD: Seagate Ironwolf 8TB + 2x Seagate Ironwolf 6TB | Monitor: Acer Predator XB271HU + Samsung BX2450

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×