Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Kreed

Force Razer Blade to use GPU over Thunderbolt 3

Recommended Posts

Posted · Original PosterOP

I'm having an issue where my Razer Blade 15 refuses to use my GPU over thunderbolt 3. I have a 4k monitor connected. It works great in game, but when I'm on the desktop my GPU sits at 0% and my CPU spikes to 100% when I try to drag a window or watch a youtube video. 

I've tried setting my default to be the 1060 via Nvidia Control Panel but it doesn't seem to work. Does anyone have any insight?

Link to post
Share on other sites

whats the gpu in the enclosure, the blade 15 has a 1070 right?


PC (Main)

 

CPU: i5-8400 CPU Cooler: Cryorig M9 Plus   Motherboard: Gigabyte B360M DS3H | RAM: Crucial Ballistix Sport 2x8 DDR4-2400

 Boot/OS SSD: Inland 480GB SSD | Video Card: RX 570 4GB Strix OC | Case: Fractal Design Meshify C White TG (11/10) PSU: EVGA SuperNOVA G3 750

Monitor: Sceptre 24" 1080p 75hz

 

NAS:

Synology DS418J w/ 4x WD Red Pro 6TB RAID 10 (used 7.3/12TB)

 

Phone/Tablet:

iPhone 8 64GB iPad Mini 4 128GB

 

Laptops:

Dell XPS 15 9570 i7-8750H + 1050 ti + 20GB ram (16+4) + 1TB EX920 SSD

 

My old computers:

Athlon x64 + R9600 Pro 256MB Core 2 Quad Q8400 @ 3.4ghz + GTX 275 | i5-3570k @ 4.4ghz + GTX 670

Link to post
Share on other sites
Posted · Original PosterOP
5 minutes ago, Firewrath9 said:

whats the gpu in the enclosure, the blade 15 has a 1070 right?

There is no enclosure. I'm using a normal thunderbolt 3 dock and want it to use the 1060 that's already in my laptop.

Link to post
Share on other sites
10 minutes ago, Kreed said:

There is no enclosure. I'm using a normal thunderbolt 3 dock and want it to use the 1060 that's already in my laptop.

oh, i see, im not sure.


PC (Main)

 

CPU: i5-8400 CPU Cooler: Cryorig M9 Plus   Motherboard: Gigabyte B360M DS3H | RAM: Crucial Ballistix Sport 2x8 DDR4-2400

 Boot/OS SSD: Inland 480GB SSD | Video Card: RX 570 4GB Strix OC | Case: Fractal Design Meshify C White TG (11/10) PSU: EVGA SuperNOVA G3 750

Monitor: Sceptre 24" 1080p 75hz

 

NAS:

Synology DS418J w/ 4x WD Red Pro 6TB RAID 10 (used 7.3/12TB)

 

Phone/Tablet:

iPhone 8 64GB iPad Mini 4 128GB

 

Laptops:

Dell XPS 15 9570 i7-8750H + 1050 ti + 20GB ram (16+4) + 1TB EX920 SSD

 

My old computers:

Athlon x64 + R9600 Pro 256MB Core 2 Quad Q8400 @ 3.4ghz + GTX 275 | i5-3570k @ 4.4ghz + GTX 670

Link to post
Share on other sites

Are you having issues when dragging around windows? If you aren't it's perfectly normal for the dGPU to be idle when a game or other GPU intensive task isn't running. Nvidia Optimus switches between the iGPU and dGPU on the fly to reduce power consumption.


¯\_(ツ)_/¯

 

 

Desktop:

Intel Core i7-3820 | Corsair H100i | ASUS P9X79-LE | 16GB Patriot Viper 3 1866MHz DDR3 | MSI GTX 970 Gaming 4G | 2TB WD Blue M.2 SATA SSD | 2TB Hitachi Deskstar HDD | 1TB WD Black HDD | Corsair CX750M Fractal Design Define R5 Windows 10 Pro / Linux Mint 19 Cinnamon

 

Laptop:

Dell XPS 15 9560 4K Touch | Intel Core i5-7300HQ | 12GB Generic (Crucial?) 2133MHz DDR4 | Nvidia GTX 1050 | 256GB Toshiba M.2 NVMe SSD | Windows 10

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×