Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Backstretch

Games crashing

Recommended Posts

Posted · Original PosterOP

Recently my games have been crashing. Battlefield 5, COD4, and now Apex Legends. Being as how it's across multiple games i figured it wasn't their fault. I'm really at a loss here. I don't know what else to do as my trouble shooting experience isn't really seasoned. The games crash after an hour or more of playing, and i'm checking HWinfo after they crash for the numbers. Zero thermal throttling on anything. The games freeze, crash, and send me back to the desktop packing. Most of the time there's no reason or popup given,sometimes there is (see pics). Please let me know what to try. This problem is getting annoying. 

 

OS -Windows 10 64 bit

only Windows 10 ever on the system, not activated cause fuck that.

Most of the hardware was bought in November. Upgraded the CPU within the last 2 weeks. 

I have re-installed the OS one time, because enmotus royally screwed my StoreMI and corrupted my single bootable drive, so I had to start over. Don't use the service anymore.

CPU - Ryzen 5 2600X OC to 4.2ghz@1.45v cooled by Corsair H110i. I have never seen anything higher than 72C on it. And that was after hours of small data sets with OCCT. It never gets above 60C when gaming.

GPU - Powercolor RX580 Red Devil golden sample running at stock. Never gets above 75C when gaming due to my fan profile. On Adrenalin 19.2.1.

Mobo - Msi B450M Mortar on BIOS 1.2.

PSU - Corsair CX650M. 

RAM - G Skill TridentZ RGB 16gb @3000mhz

Storage - Kingston 240gb Ssd (boot) and WD 1tb for games. 

Case - Fractal Design Meshify C. 

dfhbzdfg.png

Untitled.png

Link to post
Share on other sites

something similar happen to me but not while gaming, when i change video settings on Apex and i hit Apply, i get this kind of message.

And this,, form yesterday....

Weird. 


CPU:i7 9700k, Mobo: MSI MPG Z390 Gaming Edge AC, RAM:Corsair Vengeance LPX 16GB 3200MHz DDR4 GPU:MSI RTX 2070 ARMOR 8GB OC, Storage:Samsung SSD 970 EVO NVMe M.2 250GB, SSD ADATA PRO SP900 256GB, HDD WD CB 2TB, HDD GREEN 2TB, PSU:Corsair CS 650 M Gold, Display(s):Samsung P2470HD, SAMSUNG LS24E390HL, Cooling:Fazn CPU Cooler Aero 120T, Keyboard: Corsair K95 Platinum RGB mx Rapidfire, Mouse:Razer Naga Mouse 2014Headset: Razer Kraken 7.1 Chroma, Sound: Logitech X-540 5.1 Surround Sound Speaker

Link to post
Share on other sites
22 minutes ago, Backstretch said:

imageproxy.php?img=&key=17c10421afdc6db8Recently my games have been crashing. Battlefield 5, COD4, and now Apex Legends. Being as how it's across multiple games i figured it wasn't their fault. I'm really at a loss here. I don't know what else to do as my trouble shooting experience isn't really seasoned. The games crash after an hour or more of playing, and i'm checking HWinfo after they crash for the numbers. Zero thermal throttling on anything. The games freeze, crash, and send me back to the desktop packing. Most of the time there's no reason or popup given,sometimes there is (see pics). Please let me know what to try. This problem is getting annoying. 

 

OS -Windows 10 64 bit

only Windows 10 ever on the system, not activated cause fuck that.

Most of the hardware was bought in November. Upgraded the CPU within the last 2 weeks. 

I have re-installed the OS one time, because enmotus royally screwed my StoreMI and corrupted my single bootable drive, so I had to start over. Don't use the service anymore.

CPU - Ryzen 5 2600X OC to 4.2ghz@1.45v cooled by Corsair H110i. I have never seen anything higher than 72C on it. And that was after hours of small data sets with OCCT. It never gets above 60C when gaming.

GPU - Powercolor RX580 Red Devil golden sample running at stock. Never gets above 75C when gaming due to my fan profile. On Adrenalin 19.2.1.

Mobo - Msi B450M Mortar on BIOS 1.2.

PSU - Corsair CX650M. 

RAM - G Skill TridentZ RGB 16gb @3000mhz

Storage - Kingston 240gb Ssd (boot) and WD 1tb for games. 

Case - Fractal Design Meshify C. 

dfhbzdfg.png

Untitled.png

Can you run 3.9ghz on your cpu instead and see if you still have problems?

Link to post
Share on other sites
Posted · Original PosterOP
5 minutes ago, narrdarr said:

Can you run 3.9ghz on your cpu instead and see if you still have problems?

i can absolutely do this but it'll take a full day to test, and i kinda don't want to see if it'll work, since according to AMD my rated boost is 4.1, and only getting 3.9 would piss me off.

Link to post
Share on other sites

it looks to be an issue with your gpu, hence the GXDI device error hung message

Try reinstalling your graphics drivers, and your directx, as well as re seating your graphics card and its power cable


CPU: i5-4690k @ 4.4 GHz | RAM: 12GB DDR3 1333MHz | GPU: Sapphire Pulse RX 580 4GB 

 

Link to post
Share on other sites
Posted · Original PosterOP
12 hours ago, DakotaWebber said:

it looks to be an issue with your gpu, hence the GXDI device error hung message

Try reinstalling your graphics drivers, and your directx, as well as re seating your graphics card and its power cable

reinstalling adrenalin is easy enough but how do i reinstall directx?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×