Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Carz728

Can I run metro exodus

Recommended Posts

Yes.


RIG#1 CPU: Intel i7 8700k | Motherboard: ASUS ROG Maximus X Hero | RAM: G.SKILL Ripjaws V Series 16GB DDR4 3200 | GPU: EVGA GeForce RTX 2080 ti FTW3 ULTRA | PSU: Corsair CORSAIR AX860W | Case: Cooler Master HAF 922 | Cooler: Noctua NH-D15 | SSD: Crucial MX300 2.5" 1TB


RIG#2 CPU: Intel i7 8086k | Motherboard: ASUS ROG Maximus X Hero | RAM: G.SKILL Ripjaws V Series 16GB DDR4 3200 | GPU: EVGA GeForce RTX 2080 ti XC | PSU: Corsair RMx1000W | Case: Cooler Master HAF X | Cooler: Noctua NH-D15 | SSD: Crucial MX300 2.5" 1TB  

Link to post
Share on other sites

I have an i5-7600, A gtx 1060 6gb and 8gb of ram but I can't run it on 1080p low. Is there anyone who knows what problem there could be on my computer or is my hardware not good enough.

Link to post
Share on other sites
Posted · Original PosterOP
2 minutes ago, Rasen said:

I have an i5-7600, A gtx 1060 6gb and 8gb of ram but I can't run it on 1080p low. Is there anyone who knows what problem there could be on my computer or is my hardware not good enough.

I am running at an average of 80 fps with a vega 56 on ultra.  You should probably be getting better performance then that what are the temps and usage st?

Link to post
Share on other sites
Posted · Original PosterOP
55 minutes ago, Rasen said:

I'm not sure how would i check

Sorry I meant what is your usage at use a program like msi afterburner

Link to post
Share on other sites
1 hour ago, Carz728 said:

Sorry I meant what is your usage at use a program like msi afterburner

So after installing msi afterburner I can check and see my usage and temperature but what would I do if the temperature or the usage of my hardware is too high?

Link to post
Share on other sites

I think I got 50 degrees Celsius I couldn't get it to load in game but on the msi afterburner tab it says 50 while the games is running. 

Link to post
Share on other sites
Posted · Original PosterOP
16 hours ago, Rasen said:

I think I got 50 degrees Celsius I couldn't get it to load in game but on the msi afterburner tab it says 50 while the games is running. 

Try turning tesselation off.

Link to post
Share on other sites
23 hours ago, Carz728 said:

You may also need more  then 8gb of ram

Tessellation is off and also would the 8gb of ram really be so insufficient that it can't run on 1080p but low on 900p for optimized settings

Link to post
Share on other sites

 

Runs well on WAY WAY WAY less.

 

Vega56 will do fine, but be aware AMD gets crippled hard in Metro vs Nvidia GPUs.


Maximums - Asus Z97-K /w i5 4690 Bclk @106.9Mhz * x39 = 4.17Ghz, 8GB of 2600Mhz DDR3,.. Gigabyte GTX970 G1-Gaming @ 1550Mhz

 

Link to post
Share on other sites
47 minutes ago, SkilledRebuilds said:

 

Runs well on WAY WAY WAY less.

 

Vega56 will do fine, but be aware AMD gets crippled hard in Metro vs Nvidia GPUs.

I have a 1060 6gb but I can't run without dropping frames on 1080p low

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×