Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Stalliongoose

SSD Trouble

Recommended Posts

Posted (edited) · Original PosterOP

hi, im not sure if this has been covered before or if its in the right thread, could anyone help or send me in the right direction.

im trying to recover use of my ssd, and i have also attached log files too.
is my ssd drive bricked or unuseable ever again, i have tried too use parted magic to secure erase a few times, to which always comes back failing.
 

i have been in contact with samsung about this and they not able to help me.
ATA Security is:  ENABLED, PW level HIGH, **LOCKED** [SEC4]


Update

 

root@PartedMagic:~# hdparm --user-master u --security-set-pass Eins /dev/sdb
security_password: "Eins"

/dev/sdb:
 Issuing SECURITY_SET_PASS command, password="Eins", user=user, mode=high
SG_IO: bad/missing sense data, sb[]:  70 00 05 00 00 00 00 0a 04 51 00 00 21 04 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
root@PartedMagic:~# 

 

another log file uploaded

 

SAMSUNG_MZHPV512HDGL-00000_S1X1NYAG410215_2019-02-13.txt

Secure-Erase-Log-2019-02-13-1713-Advanced.txt

Secure-Erase-Log-2019-02-13-1713-Basic.csv

Secure-Erase-Log-2019-02-13-1713-Basic.txt

logtxt

Edited by Stalliongoose
edited post
Link to post
Share on other sites
Posted · Original PosterOP
4 minutes ago, Slottr said:

Can we get a TL;DR

hi, im not sure if this has been covered before or if its in the right thread, could anyone help or send me in the right direction.

im trying to recover use of my ssd, and i have also attached log files too.
is my ssd drive bricked or unuseable ever again, i have tried too use parted magic to secure erase a few times, to which always comes back failing.
 

i have been in contact with samsung about this and they not able to help me.

Link to post
Share on other sites

I also encountered the same issue. The "ENABLED, PW level HIGH, **LOCKED** [SEC4]" text comes from the smartmontools utility.

 

I was using Parted Magic (a USB bootable rescue Linux operating system) to secure erase a server-grade hard drive before placing it in a new machine. Sadly the secure erase process, once started, cannot be stopped and it can take 4-5 hours for the task to finish. I wasn't willing to wait that long for the machine to be usable so I ended up holding down the power button on my machine and forced shutdown the computer.

 

Upon rebooting, I checked the hard drive, and it was now in a semi-bricked secure state, I followed the "Disable Security" dialog from Parted Magic's "Secure Erase" tool (which is a GUI frontend to the command line smartmontools utilities):

 

disable_security.jpg.9b573b20744f14e9cec32c810c5706ac.jpg

 

This then allowed me to unbrick the hard drive and gain access back to it. I was able to successfully secure erase it later once I could give it 4-5 hours to do the operation. The hard drive was fine and no errors cropped up.

 

Parted Magic's web site also has documentation on what to do if a power outage occurs during a secure erase task. Google query their site and look for their "Secure Erase Selection Dialog" help page. I cannot mention the link here as I'll get marked as a spammer (I just signed up a few minutes ago just to respond to you so that others can see my response in future Google search queries against this "**LOCKED** [SEC4]" text).

 

Good luck to you and I hope this helped!

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×