Jump to content
Phishing Emails & YouTube Messages - Fake Giveaway Read more... ×
Search In
  • More options...
Find results that contain...
Find results in...
Picsou

Low FPS in game with GTX 1070 ti and i5 3570k

I feel so dumb right now...

I found out my gpu was not on the "Pci-e 3.0 express" slot. After putting in on the right slot, my PC is running so much better ! The "link width" went from x1 to x16.

Thank you for your help!

Recommended Posts

Posted · Original PosterOP

Hi, i've recently bought a second hand GTX 1070ti and i've noticed i have extremely low FPS on games compared to same CPU+GPU combo. For example this video on Apex Legends, shows 70+ FPS when dropping in game while i am stuck at 20+ FPS on low settings.

I've tried reinstalling my GPU drivers with DDU already and i've only gained like 5 fps.

 

This is my config, i know the components are not really adaptated to the GPU but i do not believe it is the source of my low FPS.

CPU: Intel I5 3570k OC to 4.4GHz

GPU: GTX 1070 ti inno3d herculez design

SSD: Samsung evo 860

RAM: Kingston HyperX Fury 2x4 Gb DDR3 (1600Mhz)

          + Corsair Dominator 4Go 2x2 Go DDR3 (1600Mhz) -> 12GB in total 

PSU: EVGA 600 W1, 80+ WHITE 600W

MOBO: Asrock Z77 Pro-4 m

 

 

I'd like to give you some recordings of my PC activity to help you diagnostise my case but i don't know which software to use, tell me and i'll do it :)

English is not my main language, if anything isn't clear please ask me.

Thanks for your help

Link to post
Share on other sites

It could be a CPU bottleneck.


Main PC

------------

i3-8100 @3.6GHz | GTX 1060 6GB | EVGA 450 BT | Island Professional 120GB SSD | | Toshiba 2TB HDD | Corsair Vengeance 2x4 2666 DDR4  | Corsair 270R | Windows 10 Pro | CPU Cinebench Score - 444 cb | OpenGL FPS - 84.85 FPS | Novabench Score - 1770 (OC) Base - 1678

 

Streaming PC (HP Compaq 8100 SFF)

------------

i5-750 @2.66GHz | Radeon HD 6450 | HP Compaq 240watt PSU | Toshiba 1TB HDD | Samsung 1x4 DDR3 1333MHz | HP Compaq 8100 SFF | Windows 10 Pro | CPU Cinebench Score - 320 cb | OpenGL FPS - 16.65 FPS | Novabench Score - 713 (OC) Base - 703

 

Laptop

------------

i3-7100u @2.4GHz | Intel HD 620 | Random Amazon Laptop Ram 2x4 2133 DDR4 | Acer Laptop Shell |

 

Monitors

------------

AOC - 21.5" IPS LED FHD Model - l2279VWHE | AOC - 24" TN Panel FHD 144hz 1ms Response - Model G2460PF

 

Keyboard and Mouse

------------

Logitech G413 Silver | Logitech G203 White

 

Other Electrical Devices

------------

IPhone XS 64GB Gold | Elgato HD60 Capture Card | Xbox One 500GB | Samsung 32' 1080p Smart TVApple Airpods |

Link to post
Share on other sites

It is actually. At 2:30 in your video look at the left side. CPU Usage is all at 100%


Main PC

------------

i3-8100 @3.6GHz | GTX 1060 6GB | EVGA 450 BT | Island Professional 120GB SSD | | Toshiba 2TB HDD | Corsair Vengeance 2x4 2666 DDR4  | Corsair 270R | Windows 10 Pro | CPU Cinebench Score - 444 cb | OpenGL FPS - 84.85 FPS | Novabench Score - 1770 (OC) Base - 1678

 

Streaming PC (HP Compaq 8100 SFF)

------------

i5-750 @2.66GHz | Radeon HD 6450 | HP Compaq 240watt PSU | Toshiba 1TB HDD | Samsung 1x4 DDR3 1333MHz | HP Compaq 8100 SFF | Windows 10 Pro | CPU Cinebench Score - 320 cb | OpenGL FPS - 16.65 FPS | Novabench Score - 713 (OC) Base - 703

 

Laptop

------------

i3-7100u @2.4GHz | Intel HD 620 | Random Amazon Laptop Ram 2x4 2133 DDR4 | Acer Laptop Shell |

 

Monitors

------------

AOC - 21.5" IPS LED FHD Model - l2279VWHE | AOC - 24" TN Panel FHD 144hz 1ms Response - Model G2460PF

 

Keyboard and Mouse

------------

Logitech G413 Silver | Logitech G203 White

 

Other Electrical Devices

------------

IPhone XS 64GB Gold | Elgato HD60 Capture Card | Xbox One 500GB | Samsung 32' 1080p Smart TVApple Airpods |

Link to post
Share on other sites

Oh wait nevermind, I now understand what your talking about. You should try running your game 1080p medium settings so it puts more strain on the GPU and not the CPU.


Main PC

------------

i3-8100 @3.6GHz | GTX 1060 6GB | EVGA 450 BT | Island Professional 120GB SSD | | Toshiba 2TB HDD | Corsair Vengeance 2x4 2666 DDR4  | Corsair 270R | Windows 10 Pro | CPU Cinebench Score - 444 cb | OpenGL FPS - 84.85 FPS | Novabench Score - 1770 (OC) Base - 1678

 

Streaming PC (HP Compaq 8100 SFF)

------------

i5-750 @2.66GHz | Radeon HD 6450 | HP Compaq 240watt PSU | Toshiba 1TB HDD | Samsung 1x4 DDR3 1333MHz | HP Compaq 8100 SFF | Windows 10 Pro | CPU Cinebench Score - 320 cb | OpenGL FPS - 16.65 FPS | Novabench Score - 713 (OC) Base - 703

 

Laptop

------------

i3-7100u @2.4GHz | Intel HD 620 | Random Amazon Laptop Ram 2x4 2133 DDR4 | Acer Laptop Shell |

 

Monitors

------------

AOC - 21.5" IPS LED FHD Model - l2279VWHE | AOC - 24" TN Panel FHD 144hz 1ms Response - Model G2460PF

 

Keyboard and Mouse

------------

Logitech G413 Silver | Logitech G203 White

 

Other Electrical Devices

------------

IPhone XS 64GB Gold | Elgato HD60 Capture Card | Xbox One 500GB | Samsung 32' 1080p Smart TVApple Airpods |

Link to post
Share on other sites
Posted · Original PosterOP

I've tried to only use the 8Gb kingston RAM, and nothing changes. And about the CPU bottleneck, i don't know if it helps but on Apex my CPU is at 70% on all cores while my gpu is at 100%, adding to that, the video i linked shows the CPU is not the problem here.

Link to post
Share on other sites

Thats very weird.
can you install the drivers from 3xx series.
I also have GTX 1070 ti and 6 core xeon.
Im playing Apex Maxed out with 70-80fps 1080p.

Your CPU looks weak for this game, as my 6 core xeon only goes upto 30-40% cpu usage and GPU 99%.

PS: I have old drivers (399.24) they are stable, NEWER drivers might get me more fps

Link to post
Share on other sites
Posted · Original PosterOP
3 minutes ago, AirSocial said:

Oh wait nevermind, I now understand what your talking about. You should try running your game 1080p medium settings so it puts more strain on the GPU and not the CPU.

Trying that right now: my gpu is still at 100% and my CPU is at 70%, i've set everything on high and my fps dropped about ~15-20.

 

Link to post
Share on other sites
Posted · Original PosterOP

I also have not so high FPS on Minecraft for a 1070ti, and in the Blackout mode of the latest Call of Duty i was also forced to play with all low settings.

 

About the drivers : i have installed the version 399.24, i have the same results as with the newer drivers.

Link to post
Share on other sites

Run high settings.

Except post processing ,Bloom, and or motion blur.

Check for frame caps setting and v sync setting.

Make sure window power setting are set to preformance. Same in nvidia setting under 3d settings.

You can use smartclose software to ensure all background apps are shutdown.

Link to post
Share on other sites
Posted · Original PosterOP · Best Answer

I feel so dumb right now...

I found out my gpu was not on the "Pci-e 3.0 express" slot. After putting in on the right slot, my PC is running so much better ! The "link width" went from x1 to x16.

Thank you for your help!

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Buy VPN

×