Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Siddhant Mishra

Usb hub

Recommended Posts

I am using a USB 3 hub for a long time now and never noticed any input lag.


i7-8700K @ 5,1 GHz | Asus ROG Maximus X Hero | Gskill G4-3200C16Q 32GB | 2 x Asus GTX 1080 Ti | 2 x Samsung 960 Pro 1 TB (RAID0) | Asus ROG PG278Q, Asus PG348Q | Custom watercooling with EKWB components | Enthoo Primo SE Red

Link to post
Share on other sites

Good quality hubs don't generate an input lag, they just increase ports.

I've been using a powered Orico 7 port USB 3.0 hub for about 2 years now, its excellent.


Project Taiwan: Motherboard: ASRock Fatal1ty X370 Professional Gaming /// CPU: Ryzen 7 1700 @3.8ghz  /// CPU Cooler: 280mm Thermaltake Water 3.0 /// GPU: Zotac AMP Extreme RTX 2070 /// RAM: 2x 8gb Team T-Force Xtreem @3400mhz /// Chassis: InWin 805 (with MNPCtech handles) /// PSU: Thermaltake ToughPower Grand Gold 650W /// Storage: Intel 760p 256gb NVME SSD + Inland 480GB SSD + Toshiba X300 4TB HDD /// OS: Windows 10 Pro

 

Peripherals: Mice: Glorious Model O (glossy black), Elecom HUGE Trackball /// Keyboard: Logitech G613 (Romer Gs) /// Monitor: AOC Agon AG322FCX 32' (VA, 1080p @144hz) /// AMP: Onkyo Integra A-817XD /// DAC: Loxjie D10 (Red) /// Speakers: Polk Audio TSi100 /// Mike: Superlux E205U /// Headphones: Sony MDR-XB920 & Koss Pro4AAA Titanium /// Network hardware: TP-Link Archer C9 v.4 main router (with DD-WRT) + D-Link DIR-868L in AP mode (also with DD-WRT)

 

Living room: TV: Samsung QLED Q7FN 55' 4k /// Amplifier: Hegel H90 /// Speakers: DALI Zensor 7 /// Consoles: Sony PS4 Pro 1TB, Sony PS3 500gb /// LD/CD/DVD: Pioneer DVL-909 /// Power Supplies: Upsai ACF-2100T + GR Savage CDR2200EX

Link to post
Share on other sites

Input devices often don't saturate even USB 2.0 bandwidth, so you shouldn't notice any additional input lag. If, however, you plug in a lot of high draw or high bandwidth devices 'external drives, large backlit gaming keyboard etc.) you will notice drops in performance and possibly instability


Quote and tag people using @ otherwise they don't get notified of your response!

 

Desktop:

CPU: Intel Core i5 4590 CPU Cooler: Arctic Freezer i30 GPU: Gigabyte GTX1080 G1 RAM: Kingston HyperX 2x8GB 1866MHz Motherboard: ASUS Z97-P PSU: FSP Raider S 750W OS Drive: Samsung 850 Evo 500 GB Storage: 2 Seagate Barracuda 2TB drives in RAID1 Case: Zalman Z12 Monitor: LG 34UC88-B 34" 3440x1440p IPS curved Ultrawide Keyboard: Corsair STRAFE RGB Cherry MX Brown Mouse: Logitech G502 Proteus Core / Logitech MX Anywhere 2

 

Notebook:  HP Spectre x360 13" late 2018

Core i7 8550U, 16GB DDR3 RAM, 512GB NVMe SSD, 13" 1920x1080p 120 Hz IPS touchscreen, dual Thunderbolt 3

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×