Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Drupal console and composer work intermittently.

Recommended Posts

Posted · Original PosterOP

 Just as a preface, please be patient I am very new to all of these tools and web development in general; I've been working with Drupal and Acquia dev desktop to work on a website. With the help of someone else I cloned the site and the appropriate databases from the site's phpMyAdmin interface. Before all of this I installed Drupal console and composer to the workstation, globally I believe. We had to disable the simple SAML module on the site as it wouldn't function properly on my local copy, not allowing me to access the Drupal interface. To do this we utilized Drupal console, which worked fine. Each time the site gave us a new error we would figure out which module was causing it and we would proceed to uninstall it through the console. At one point, the console starting behaving erratically; simply trying to run drupal in cmd would cause it to say drupal isn't a program or a recognized  command. sometimes it would launch, but then certain commands would be recognized. By that I mean I would try to generate a module using the console (I made sure the syntax was correct) and it would say "module" wasn't a recognized command. With the same amount of  "randomness" composer wouldn't work, the cmd would say "cannot open composer.phar". Running any of the aforementioned things in Powershell fails significantly less , but still fails intermittently. We've tried reinstalling Acquia, uninstall composer and drupal console and even trying a slightly older version of the site. It works fine on my coworker's workstation (they're basically identical machines) and worked fine for the people who previously used the same machine (same install of windows just different users). Replies are appreciated!    

CPU: i7 3770 ( Cooled by H60)  GPU: GTX 970 STRIX  RAM16gb Hyperx fury 1600mhz ( 8GBx2)  MOBO: Asus P8Z77M  PSU: Corsair AX 760 Case: Corsair 350D    Storage: Kingston 240gb 3k SSD,  4 TB WD Red , 1TB segate HDD     Mouse: Logitech G pro Keyboard:Logitech G pro    Headphones: Sennheiser HD598 SE  DAC/AMP: Fiio EK10 Microphone: Blue Yeti




Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now