Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
truecrafting

Apex Legends stuttering

Recommended Posts

Posted · Original PosterOP

so i just downloaded apex legends and i have noticed it locked my fps to 75 (my monitor is 75hz) and it stutters just wondering if you guys are experiencing this and before you say I know  that it is a new game and they are still optimizing and updating the game i'm just concerned

Link to post
Share on other sites
Posted · Original PosterOP
12 minutes ago, Sam22ja said:

I have max fps and my game was running perfectly , until today it started stuttering .pls help 

Probably just a bad update

Link to post
Share on other sites

I know the game is locked at 144hz, but I heard someone say put adaptive V sync on and disable Vsync in your Nvidia CP or whatever GPU you have, Im not sure if that would work but you can try. I really hope they try to optimize it more because im getting like 70-120 FPS with a gtx 1060 3gb However, it seems to be pretty stable.


Main Computer :
CPU: 
Ryzen 5 2600x (STOCK)
GPU: Evga GTX 1060 3gb (STOCK)
RAM: Geil Potenza 8gb 
SSD/HDD: WD green 120gb SSD/ 1 TB HDD
MOBO: Asus x470-Plus Gaming
PSU: Evga 600w 80 plus
Cooling: Antec 120mm liquid cooler

 

Link to post
Share on other sites

Wonder the same myself i run i7 8700k 2080ti " think i have all drives "  also uses G sync but anything i do dosnt seem to help, i restart game it seems fine, jump out play for alittle and game starts stutter and "draw" back like i jump back a few MM each sec here and there, its super annoying as it makes it unplayable :c

Link to post
Share on other sites

Same for me, but running on Ryzen 1700@3.7Ghz and RX580. Everyone else saying they having the smoothest experience of their lifes while here I am with the game being almost unpleyable (when moving the mouse it "jumps" those frames most of the time).

Link to post
Share on other sites
On 2/8/2019 at 5:34 AM, pagaiba said:

Same for me, but running on Ryzen 1700@3.7Ghz and RX580. Everyone else saying they having the smoothest experience of their lifes while here I am with the game being almost unpleyable (when moving the mouse it "jumps" those frames most of the time).

Strange, they say AMD cards runs better with Apex.


Main Computer :
CPU: 
Ryzen 5 2600x (STOCK)
GPU: Evga GTX 1060 3gb (STOCK)
RAM: Geil Potenza 8gb 
SSD/HDD: WD green 120gb SSD/ 1 TB HDD
MOBO: Asus x470-Plus Gaming
PSU: Evga 600w 80 plus
Cooling: Antec 120mm liquid cooler

 

Link to post
Share on other sites

For anyone stumbling upon this post and still having the issue, I figured it out from an old Titanfall 2 thread somewhere else: try tuning your mouse polling rate from 1000hz down to 500hz. Apparently this games gets overloaded with the position updates or something.

Link to post
Share on other sites
On 2/14/2019 at 2:31 PM, pagaiba said:

For anyone stumbling upon this post and still having the issue, I figured it out from an old Titanfall 2 thread somewhere else: try tuning your mouse polling rate from 1000hz down to 500hz. Apparently this games gets overloaded with the position updates or something.

pagaiba you are an Apex Legend. Well you are probably not but you are my hero, thank you for this crazy but 100% effective tip, it solved my problem, thanks a lot.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×