Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
ScaryLarry38

Computer not turning on.

Recommended Posts

Posted · Original PosterOP

So basically we had just built this pc with a new cpu, Ryzen 5 2600x, with an ASUS ROG Strix B450 motherboard, all brand new. It was all hooked up, all the cables properly connected, but when we went to go turn it on it did not start. This is strange because the front panel IO connectors are all in the right place based on the manual, and the ethernet cord is even lighting up on the motherboard, an indication that it is receiving power. I have tried putting the power switch IO connector into every single io connector pin slot, tried the switch, and nothing. Maybe its the internal PSU power switch? The case is the corsair crystal 570X.

Link to post
Share on other sites

Try shorting any black and any green wire on the power supply. If the fan turns on and it sounds/looks like a functioning power supply, it's not likely it's the power supply.


      __             __
   .-'.'     .-.     '.'-.
 .'.((      ( ^ `>     )).'.
/`'- \'._____\ (_____.'/ -'`\
|-''`.'------' '------'.`''-|
|.-'`.'.'.`/ | | \`.'.'.`'-.|
 \ .' . /  | | | |  \ . '. /
  '._. :  _|_| |_|_  : ._.'
     ````` /T"Y"T\ `````
          / | | | \
         `'`'`'`'`'`
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×