Jump to content
Phishing Emails & YouTube Messages - Fake Giveaway Read more... ×
Search In
  • More options...
Find results that contain...
Find results in...
jogijs

Monitor randomly loses signal and turns off

Recommended Posts

Posted · Original PosterOP

So recently my computer and monitor started to acting weird. At randomly monitor says ''no signal'' and turns it self of in games, watching movies or just browsing. But when it happens the computer works just fine just black screen. I tried turning power for monitor on and off  and unplugging display port cable and nothing helps unless I restart whole computer. And earlier today all the gpu drivers just disappeared. I did DDU and no changes. Any ideas what might be wrong ? Ihave i7 8700k, 16gb ram, gtx 1080ti and everthing is water cooled. Monitor is Acer Predator XB271HU A

Link to post
Share on other sites

First of all, check that all your internal and external cables are connected properly, including your monitor's power cable, your GPU's power cable, and make sure that your GPU is fully pushed into your PCi-e slot.


Please, take everything I say with a grain of salt. I'm not a professional, just a moderately knowledgeable nerd. 

 

"They misunderestimated me."

-George W. Bush

Link to post
Share on other sites

If you listened to bellabichon and still it gives same problem, try a different power cable.  Also make sure your BIOS is set to defaults and not OCed same as your video card. and what not.


Asus Sabertooth x79 / 4930k Hexa @ 4600 @ 1.440v / Gigabyte WF 2080 RTX / Corsair VG 64GB @ 1866 & AX1600i & H115i Pro @ 2x Noctua NF-A14 / Carbide 330r Blackout Edition

AOC 40" 4k Curved Monitor / Samsung 40" 4k HDR TV Flat 120 MR / LaCie Porsche Design 2TB & 500GB / Samsung 950 Pro 500GB / 850 Pro 500GB / Crucial m4 500GB

Scarlett 2i2 Audio Interface / KRK Rokits 10" / Sennheiser HD 650 & HD 4.50BT SE / Logitech G910 / G700s / C920 /  SL 88 Grand / Cakewalk / Win10 / NF-A14 Intake / NF-P12 Exhaust

Link to post
Share on other sites
Posted · Original PosterOP

I am so dumb I should have realized that my self. Yes the problem was power cable coming from psu to gpu it had to sharp of a bend and I barely touched the cable and the screen went black.

Link to post
Share on other sites
7 minutes ago, jogijs said:

I am so dumb I should have realized that my self. Yes the problem was power cable coming from psu to gpu it had to sharp of a bend and I barely touched the cable and the screen went black.

That'd be it! Nice catch. 


Please, take everything I say with a grain of salt. I'm not a professional, just a moderately knowledgeable nerd. 

 

"They misunderestimated me."

-George W. Bush

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×