Jump to content
Phishing Emails & YouTube Messages - Fake Giveaway Read more... ×
Search In
  • More options...
Find results that contain...
Find results in...
MazeJoaco

Windows reboots when I try to shut it down

Recommended Posts

Posted · Original PosterOP

So this has been happening to me for the last few months. At first I didn't pay attention to it, I thought it would fix by itself but that hasn´t been the case.

Everytime I try to shut down my PC, no matter what method I use, it shuts down, stays off for two seconds and then,it automatically reboots. This usually happens only the first time I shut it down but this could happen 2 or 3 times. Eventually it turns off and stays off.

When the PC reboots I always get the DistributedCOM error at the event viewer(in case that's helpful). I've tried every method I've come across to fix this but it has been useless.

Any ideas?

 

Link to post
Share on other sites

I used to have this issue, my power supply was to blame. What happens when you shut it off the PSU with the switch after you turn off your PC?


I WILL find your ITX build thread, and I WILL recommend the SIlverstone Sugo SG13B

 

Primary PC:

i7 8086k (won) - EVGA Z370 Classified K - G.Kill Trident Z RGB - Force MP500 - Jedi Order Titan Xp - The venerated Hyper 212 Evo (with RGB Riing flair) - EVGA G2 650W - Black and green theme, Razer branwashed me.

Draws 400 watts under max load, for reference.

 

Linux Proliant ML150 G6:

Xeon X5560 - 24GB ECC DDR3 - MSI GTX 650 - some 7200RPM SATA II thing - Ubuntu (at the moment)

 

Feel free to critique my website. I am but a young entrepreneur.

Link to post
Share on other sites
Posted · Original PosterOP

I turn the switch off everytime now to avoid facing the problem. I only don't do it when I forget or when I want to check if the problem is still happening.

Link to post
Share on other sites

let-me-guess-windows-10.jpg


ASUS X470-PRO • R7 1700 4GHz • Corsair H110i GT P/P • 2x MSI RX 480 8G • Corsair DP 2x8 @3466 • EVGA 750 G2 • Corsair 730T • Crucial MX500 250GB • WD 4TB

Link to post
Share on other sites
Posted · Original PosterOP

My BIOS doesn't have that feature, I guess I can do that by disabling the box "allow this device to wake the computer" on properties of the network adapter(?)

Link to post
Share on other sites
Posted · Original PosterOP
Just now, homeap5 said:

Every BIOS has that option somewhere. Except maybe very old ones.

Swear to god I can´t find it. And I've looked several times.

Link to post
Share on other sites
7 hours ago, MazeJoaco said:

GIGABYTE B85M-DS3H 

Power Management -> Resume by alarm - disabled

Power Management -> AC BACK -> Always Off

Power Management -> ErP - > Enabled (this is important, it disables Wake on Lan which is enabled by default on this Gigabyte motherboard).

 

Link to post
Share on other sites
Posted · Original PosterOP
On 1/21/2019 at 7:39 AM, homeap5 said:

Power Management -> Resume by alarm - disabled

Power Management -> AC BACK -> Always Off

Power Management -> ErP - > Enabled (this is important, it disables Wake on Lan which is enabled by default on this Gigabyte motherboard).

 

I unchecked that "allow this device to wake the computer"  box and it stopped rebooting. Now I checked it again to set the ErP to enabled and didn't reboot either. Now with the ErP enabled it doesn't reboot either. I don't know what's going on but I'll let you know if it happens again. Thank you!

Link to post
Share on other sites
39 minutes ago, MazeJoaco said:

I unchecked that "allow this device to wake the computer"  box and it stopped rebooting. Now I checked it again to set the ErP to enabled and didn't reboot either. Now with the ErP enabled it doesn't reboot either. I don't know what's going on but I'll let you know if it happens again. Thank you!

It's something related to "wake on pattern match". Turning on Magic Packet is not affected (if you want to turn on your computer remotely), only that "pattern match". Some routers or switches, or maybe other computers in network, sends some packets that wakes computer. I saw that few times.

 

BTW. Unchecking "allow this device to wake the computer" and disabling WOL (enabling ErP) in BIOS will give you less power consumption (just a little) when your computer is turned off (look at your LAN card led). So it's more "green" solution. Especially if you don't use Wake On Lan anyway.

Link to post
Share on other sites
Posted · Original PosterOP

No, I don't use WOL, and I've never changed any settings related to it, not in BIOS nor in network adapter properties, that's why it was so strange to me that this suddenly started to happen. Anyway, it seems that the rebooting problem ain't happening anymore so I'll leave the "green solution" on for now. I don't have any reasons not to as you said.

Thanks again.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Buy VPN

×