Jump to content
Phishing Emails & YouTube Messages - Fake Giveaway Read more... ×
Search In
  • More options...
Find results that contain...
Find results in...
lavablade02

No Ethernet after adding ssd as a boot drive

Recommended Posts

Posted · Original PosterOP
4 minutes ago, Brooksie359 said:

Get a usd drive and download the required Ethernet drives to the drive using a laptop or another computer. Then plug the usb drive into your z370 motherboard and install the drivers. 

Link? Couldn’t find working ones


i5-8600k, MSI Z370-A Pro, 2x 8GB DDR4-3k, MSI Gaming X 1060, NZXT S340, 2TB HDD, 750w Corsair PSU, AOC 2775 OC'd to 80Hz and CFG73 at 144hz

Comic sans is the worst font

Check out my monitor overclocking guide

Link to post
Share on other sites
Posted · Original PosterOP
2 hours ago, Brooksie359 said:

You go to msi website and download the Ethernet drivers under the support page for your specific motherboard. 

This worked. I knew it would and don't know why I didn't do this before asking. Thanks.


i5-8600k, MSI Z370-A Pro, 2x 8GB DDR4-3k, MSI Gaming X 1060, NZXT S340, 2TB HDD, 750w Corsair PSU, AOC 2775 OC'd to 80Hz and CFG73 at 144hz

Comic sans is the worst font

Check out my monitor overclocking guide

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×