Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
dragonxt

i9-9900k with Z370-E Need Help

Recommended Posts

Posted · Original PosterOP

So, I tried powering on my PC with a 9900k and a z370 Mobo, but I wasn't getting any error lights or video signal. Tech support is confused and said I should just return it. Ram and gpu works fine. 

 

Is this because I need to update the bios for the new cpu? Or would an error light show up for that problem. 

Link to post
Share on other sites

You will need to update the BIOS, yes. You can do that with a Celeron or something


My PCs:

VALENTINIAN : CPU: Ryzen 7 2700X || CPU COOLER : Corsair H115i Pro || MOBO : MSi B450 Tomahawk Max || GPU: ASUS GTX 1080 Ti Strix OC || RAM: 4x8GB Corsair Vengeance (3200) || SSDs: Samsung 970 Evo 250GB, Samsung 850 Evo 1TB x2 || PSU: EVGA G2 850W w/ Cablemod Black & White Cables || CASE: NZXT H510 White || MONITOR: Acer Predator X34A, HP 27yh || KEYBOARD: Corsair K95 RGB Platinum (MX Brown, White Keycaps) || MOUSE: Logitech G502 Hero || AUDIO: HyperX Cloud Alpha, Logitech C920 || CASE FANS : 2x Corsair ML140, 2x Corsair ML120 ||

DIOCLETIAN III (HTPC) : CPU: Ryzen 5 1600 || CPU COOLER : Cooler Master Hyper 212 Black Edition || MOBO : MSi X370 Gaming Pro Carbon || GPU: ASUS GTX 1080 Strix OC || RAM: 2x8GB G.SKILL Ripjaws V (3200) || SSDs: Crucial P1 500GB, Crucial MX500 1TB || HDD: Seagate Barracuda 2TB || PSU: Seasonic 650W w/ Black & Red Extensions || CASE: Phanteks P300 || Monitor: Samsung Q60 65" QLED || KEYBOARD: Logitech G613 || Mouse: Logitech G305 || CONTROLLER: Xbox One Controller x2 || AUDIO: Samsung Q60R Soundbar || Case Fans : 2x Cooler Master Masterfan Pro 120, Noctua NF-F12 iPPC-2000 ||

JUSTINIAN - Dell XPS 15": CPU: Core i7-9750H || GPU: GTX 1650 || RAM: 2*8GB 2666MhZ DDR4 SODIMM || SSD: 1TB M.2 PCIe || CASE: 15.6" Laptop with dBrand skin || MONITOR: 15" 1920 * 1080 IPS || KEYBOARD: Dell Keyboard || MOUSE: Logitech G305 White || AUDIO: HyperX Cloud II ||

OTHER : Dell Latitude (i7-6600U, 16GB RAM, 500GB SSD) || HP All-in-One (Unspecified Haswell i7, 8GB DDR3, Crucial MX500 500GB ||

MOBILE : Galaxy S9 (64GB + 64GB uSD) || Galaxy S7 (32GB) || FitBit Blaze || Kindle Fire 10" ||

CONSOLE : Nintendo Switch (Pro Controller x3, Joy-Con Grip x1, PowerA Enhanced Controller x1) ||

POLITICAL ALIGNMENT: Social Democratic || Centre-Left ||

 

 

 

Link to post
Share on other sites

As stated above, you need CPU that works with Z370 out of the box to do a Bios update.  You won't get any errors when trying to boot newer chip on old bios.


Main system: i7 8700k 5Ghz / Asus Prime Z370-A / Corsair Vengeance 2x8GB 3000Mhz / Gigabyte RTX2080 Aorus Extreme / EVGA 750W GQ / Fractal Design Meshify C

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×