Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
FunKaLiTy

SSD not showing up under My Computer???

YES! I found the solution, I had to right click just a little further to the right from where I did in the Disk Manager ^^

 

When clicking in the big area where it said it was unallocated I had the option to give it a drive letter thus allocating it and now it's available for use again :D

Recommended Posts

Posted · Original PosterOP

Hi, once again I need your help :P

 

Okay so I had some issues with my M.2 NVMe SSD after I did a clean wipe using the manufacturers software (Toshiba SSD Utility Tool), I could no longer boot from my other SSD which is the one I had installed Windows on.
I believe this happened because Windows was stupid and chose to partition up my other SSD (not the one I installed Windows on) for it's MSR part or whatever you call it, so when I did a full wipe of what should have been an empty SSD Windows could no longer launch. (Reason I did the wipe was that I was getting a BSOD about half the time when booting up giving me an error I read up on how to remove, but could not remove using the described method...long story short)

So I ended up doing a clean wipe of my other SSD as well and reinstalling Windows with only that SSD installed to the motherboard, it's now working fine without BSOD issues.

 

However....of course there had to be more issues....when I reinstalled the Toshiba SSD on the motherboard it's not showing up under My Computer, meaning it's inaccessible and completely useless.

 

I tried going to device management and uninstall the SSD, turn of computer, remove SSD from motherboard, reboot computer, turn it off again, reinstall the SSD, reboot, check for drivers, initialize the SSD using Acron True Image, but still it's not showing up :(

 

The C drive is my other SSD (WD Black 500GB).

 

Please anyone know what else I can try? Please check screenshot for some details

SSD.PNG

Link to post
Share on other sites
Posted · Original PosterOP
5 minutes ago, Belzebuth said:

you just need to format your disk 1 under disk management, as it is for now unallocated.

But as you can see it's not showing up under disk management :(

Link to post
Share on other sites
5 minutes ago, FunKaLiTy said:

But as you can see it's not showing up under disk management :(

I can see on the disk management screenshot a Disk 1 that is unallocated, you need to right click on it and format to ntfs

Link to post
Share on other sites
Posted · Original PosterOP
10 minutes ago, Belzebuth said:

I can see on the disk management screenshot a Disk 1 that is unallocated, you need to right click on it and format to ntfs

Ah I see now where you mean, but when i right click there the top 4 options are greyed out (none of them say format, they just say "New something volume"), my options are to either convert to dynamic disk or convert to GPT-disk, Disconnect or go into Properties.

Link to post
Share on other sites
10 minutes ago, FunKaLiTy said:

Ah I see now where you mean, but when i right click there the top 4 options are greyed out (none of them say format, they just say "New something volume"), my options are to either convert to dynamic disk or convert to GPT-disk, Disconnect or go into Properties.

can you make a screenshot of the context menu when you right click on disk1 ?

 

Link to post
Share on other sites
Posted · Original PosterOP
9 minutes ago, Belzebuth said:

can you make a screenshot of the context menu when you right click on disk1 ?

 

Back to the good old paint copy pasting for screenshots made it possible :D
It is in Norwegian tho ^^

SSD2.png

Link to post
Share on other sites
30 minutes ago, FunKaLiTy said:

Back to the good old paint copy pasting for screenshots made it possible :D
It is in Norwegian tho ^^

luckilly I can use google translate ahah !

 

But what happend if you convert it to GPT ? 

Link to post
Share on other sites
Posted · Original PosterOP

I converted, checked, rebooted checked and seemingly nothing happened, but now it seems I can re-initialize the disk using the Acron True Image software.
I could not do that before, don't remember exactly what happened when I did the "Add new disk" thing earlier, but since the first time I initialized it after having removed it and reinstalled it again I didn't get this initialize option anymore when doing the Add new disk thing with the Acron True Image, now I did as you can see in screenshot, which option should I choose? Last time I chose MBR layout

 

Skjermbilde.PNG

Link to post
Share on other sites
Posted · Original PosterOP · Best Answer

YES! I found the solution, I had to right click just a little further to the right from where I did in the Disk Manager ^^

 

When clicking in the big area where it said it was unallocated I had the option to give it a drive letter thus allocating it and now it's available for use again :D

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×