Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Liamhijak

Bent i7 7700k and ram won't dual boot

41 minutes ago, Dylanc1500 said:

By "dual mode" are you meaning dual channel? The reason the other slots are working is because the section that got bent, the pads on it are for memory and that would be the reason for it not detecting your second channel. You will have notice a difference it performance due to having half the available memory bandwidth.

 

All of the pads within the red border are not making proper contact if not completely severed within the substrate. The blue pads within said boundary are for memory.

pETOP8DLTnZlZ7TN.jpg

So you think if I can push it back down flat (which I've seen couple of people do on here) it'll make connection? 

Recommended Posts

Posted · Original PosterOP

Hi guys I bent my chip with heats ink... It works but my x2 8gb lx vengeance won't dual boot it only works in slots 3 and 4. Will this affect proformance.. My pc seems very slow especially starting up. 

 

I'm too scared to force it flat in case the crack gets worse. 

 

I7 7700k 

Msi z270 m5 gaming mobo

Gtx 1080ti 

2 x 8gb lx vengeance ddr4

 

Screenshot_20181214-053457_Messenger.jpg

Link to post
Share on other sites
1 hour ago, Liamhijak said:

It's been working for about a year now.. But like I say won't boot in dual mode. Will that affect perormance 

By "dual mode" are you meaning dual channel? The reason the other slots are working is because the section that got bent, the pads on it are for memory and that would be the reason for it not detecting your second channel. You will have notice a difference it performance due to having half the available memory bandwidth.

 

All of the pads within the red border are not making proper contact if not completely severed within the substrate. The blue pads within said boundary are for memory.

pETOP8DLTnZlZ7TN.jpg

Link to post
Share on other sites
Posted · Original PosterOP · Best Answer
41 minutes ago, Dylanc1500 said:

By "dual mode" are you meaning dual channel? The reason the other slots are working is because the section that got bent, the pads on it are for memory and that would be the reason for it not detecting your second channel. You will have notice a difference it performance due to having half the available memory bandwidth.

 

All of the pads within the red border are not making proper contact if not completely severed within the substrate. The blue pads within said boundary are for memory.

pETOP8DLTnZlZ7TN.jpg

So you think if I can push it back down flat (which I've seen couple of people do on here) it'll make connection? 

Link to post
Share on other sites
1 hour ago, Liamhijak said:

So you think if I can push it back down flat (which I've seen couple of people do on here) it'll make connection? 

It is definitely possible, as I've seen it done myself. Just don't hold your breath because it may not. Note: if you do attempt to straighten it out, do so against a flat surface. You don't want to take a chance in over bending and breaking it off entirely since the strength of it has been compromised now.

Link to post
Share on other sites
Posted · Original PosterOP
On 12/14/2018 at 8:51 AM, Dylanc1500 said:

It is definitely possible, as I've seen it done myself. Just don't hold your breath because it may not. Note: if you do attempt to straighten it out, do so against a flat surface. You don't want to take a chance in over bending and breaking it off entirely since the strength of it has been compromised now.

Could you give us more info how you've seen it done please 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×