Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Mifyou

Refresh rate help.

im just buying a new monitor, thanks for the help though guys!

 

Recommended Posts

1 minute ago, Mifyou said:

image.png.a7d0590c7f15e77d958559b33371a7a6.pngits grayed out :I 

 

Have you tried another HDMI cable ? Maybe the PC res is limited by your cable... otherwise DP to DUAL LINK DVI it is.

Link to post
Share on other sites

or new monitor, as awful as that may sound... and maybe 1440p at that if you had to go to new monitor. but yeah, DP to dual link DVI is the only way otherwise. 


Rig 1: i7-9700k OC'd to 5.0ghz all core | EVGA XC RTX 2080Ti | ADATA DDR4 2400mhz 4x8gb | ASUS PRIME Z370-P | Asetek 550LC 120mm | ADATA 480GB SSD & Toshiba P300 3TB | Cooler Master Masterbox MB500 | Win 10 Home | Logitech G910 Orion Spectrum, G502 Proteus Spectrum, G933 Artemis Spectrum Snow Wireless Limited Edition, Corsair MM300 Mouse Pad | 2 MSI Optix Curved 27" FHD Monitors 

 

(before i sold the WD drive and MSI gpu - https://www.userbenchmark.com/UserRun/11946219 171 gaming. felt good.)

 

Rig 2: i7-7700k Stock clocks | MSI Armor GTX 1070 | ADATA DDR4 2400mhz 2x8GB | MSI Z270 A-Pro | WD Green 240GB SSD & 2TB Seagate HDD | Thermaltake Core G21 Tempered Glass Edition | Win 10 Home | 2 HP Omen FHD 144hz 24.5" Monitors 

 

Rig 3: i7-6700 | GT 730 & GT 645 OEM | Some random DDR4 2133mhz 2x8gb sticks | OEM Dell Mobo | WD Black 2TB HDD & Toshiba 1TB HDD | Win 10 Home | 3 27" Dell FHD Monitors 

 

Rig 4: i7-4770 | EVGA SSC 1050ti | Some random DDR3 ram 2x2gb and 2x4gb sticks | OEM Dell Mobo | Stock Cooler | 1TB WD Black HDD | Win 7 Home 

 

RIP 

 

Rig 5 (dead and dismantled and sold) : i7-7820X OC'd to 4.8ghz all core | MSI DUKE 1080ti | ADATA DDR4 2400mhz 4x8gb | Gigabyte X299 UD4 PRO | Asetek 240mm AIO | WD Green 240gb SSD | Other various components that I can't remember

 

Rig 6 (same fate as rig 5) i7-8700k stock clocks | MSI DUKE 1080ti | ADATA DDR4 2400mhz 2x8gb | MSI Z370 A-Pro | Asetek 550LC 120mm | WD Green 240GB SSD & Toshiba 2TB HDD | Other various components that I can't Remember 

Link to post
Share on other sites
Posted · Original PosterOP
Just now, Belzebuth said:

Have you tried another HDMI cable ? Maybe the PC res is limited by your cable... otherwise DP to DUAL LINK DVI it is.

cant find any DP to DVI-D adapters that support 144hz though, im looking for them now and all of them say "Does not support 144hz"

Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, TH3R34P3R said:

or new monitor, as awful as that may sound... and maybe 1440p at that if you had to go to new monitor. but yeah, DP to dual link DVI is the only way otherwise. 

cant find any DP to DVI-D adapters that support 144hz though, im looking for them now and all of them say "Does not support 144hz"

 
 
Link to post
Share on other sites

Case: Corsair 760T  |  Psu: Evga  650w p2 | Cpu-Cooler : Noctua Nh-d15 | Cpu : 8600k  | Gpu: Gygabyte 1070 g1 | Ram: 2x8gb Gskill Trident-Z 3000mhz |  Mobo : Aorus GA-Z370 Gaming K3 | Storage : Ocz 120gb sata ssd , sandisk 480gb ssd , wd 1gb hdd | Keyboard : Corsair k95 rgb plat. | Mouse : Razer deathadder elite | Monitor: Dell s2417DG (1440p 165hz gsync) & a crappy hp 24' ips 1080p | Audio: Schiit stack + Akg k712pro + Blue yeti.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×