Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
jakkuh_t

Making a $300 Pixel Clone

Recommended Posts

I have to say this is one of the worst guides to do this. It skips certain things that beginners like me will not know, is super vague for some reason. I mean if you want to post a shorter video thats fine but this really isn't a comprehensive guide. I have not managed to install those google apps but I managed to somehow install Lineage. 
Hope I don't brick this. :/

Link to post
Share on other sites

C:\adb>fastboot flash recovery "recovery-20181012" fastboot: error: cannot load 'recovery-20181012': No such file or directory What did i do wrong? the file is there but i get this error message.

Link to post
Share on other sites
3 hours ago, mze said:

I have to say this is one of the worst guides to do this. It skips certain things that beginners like me will not know, is super vague for some reason. I mean if you want to post a shorter video thats fine but this really isn't a comprehensive guide. I have not managed to install those google apps but I managed to somehow install Lineage. 
Hope I don't brick this. :/

I'm having to manually download all google apps.  You are right, this guide is shit.  I wish I'd known that going into it.  I still can't get magisk (at the 6 minute point of the video) installed as there is no explanation on how to do this and every method I've tried doesn't even see it on my phone.  I'm not even sure what the hell it does so I've just moved on and skipped everything after it.  Its not perfect, but I guess its better than what it could have been.

 

Give this was my first time trying it and I didn't manage to brick the phone you should be fine.

Link to post
Share on other sites
19 hours ago, Bill_a said:

I'm having to manually download all google apps.  You are right, this guide is shit.  I wish I'd known that going into it.  I still can't get magisk (at the 6 minute point of the video) installed as there is no explanation on how to do this and every method I've tried doesn't even see it on my phone.  I'm not even sure what the hell it does so I've just moved on and skipped everything after it.  Its not perfect, but I guess its better than what it could have been.

 

Give this was my first time trying it and I didn't manage to brick the phone you should be fine.

Ok, Bill, and many many others who had trouble with this process.. so did I.. so here's a list of things that can/did/will go wrong.

 

1:  The Unlock app process must not be run on a Windows machine running an AMD Ryzen processor. Please find an Intel-buddy and get it done there.

2:  The mi-unlock zip when you unzip it comes with a driver installer file.. Run this as Admin, then plug in your 'fastbooted' pocophone.. Make sure the software reports that the driver was installed.

3:  Unplug the phone again, Then run your miflash_unlock.exe and re-plug in your pocophone again.. or try a number of combinations of not unplugging and unplugging.. and it should figure its way out..

4:  Once you finally get to beyond 50% on the unlocking process (which is where it stops on Ryzen), you may then get to 99% and it might tell you to come back again in XX hours.. mine said 62.. ?

5:  After 62 hours, you're around 2 hours away from done..

6:  Once unlocked, you should reboot again and get back into 'fastboot' on your phone, and then go to your c:\adb\ location and run the fastboot commands..

7:  The fastboot commands, not well documented from the video, or the post links, are:

     7a:   fastboot devices           (checks whether or not it sees the device)

     7b:   fastboot flash recovery recovery_20181211.img          (you must have copied the recovery-20181211.img file to c:\adb\ for this to work!)

     7c:   fastboot boot recovery-20181211.img          (tells the phone to boot into twrp!)

8:  You then can see the pocophone in your windows "this computer" and can copy files to the TWRP directory inside.. once TWRP is loaded.

9:  Flashing Magisk helps with the unlocking process.. to the best of my knowledge..

10:  go SLOWLY inside TWRP, you can really mess stuff up.. !

11:  Once you've deleted the directory mentioned in the video, you can follow the next few steps kinda easily..

12:  If you ever boot the phone, and you still need TWRP, go back to step 7 with a fastbooted pocophone, and repeat a, b, c.

13:  replacing the bootloader with ruthless isn't painless, and then getting to the ruthless pixel launcher settings is even more of a pain.. but it is possible with a little fumbling around.. I can't remember the steps, and would have to go through them again to get there..

14:  to get to ruthless pixel launcher settings,, flick up to get the search bar at the top.. type ruthless, press and hold when the app displays, and select "app Info" then scroll to the bottom and do 'advanced' then scroll further down and tap "additional settings in app".

15:  the dock settings are under 'dock' then under advanced settings, and then you put the searchbar radius at 100, turn ON custom bottom searchbar color, and set it to WHITE in the next box, and then put searchbar transparency at 100.

16:  I can't get the ruthless pixel launcher to show weather at the top of the screen next to the date..   can anyone help me?

17:  I have no idea "what google apps" i really want.. especially since I was considering coming from an iPhone.

18:  Re-Magisk-ing after you get it all set up stops the warnings about this being built with public keys or somesuch, likely to do with phone security measures and detections..

19: I can't replace the default camera app, so you just have to be careful to run the Google Pixel camera app every time you want a camera.. ?

20:  You lose the 'swipe' to do stuff functionality of MIUI 9/10 when you move to Lineage..

21:  There appears to be no way to go from lock screen to camera quickly, you must unlock.

22:  Fingerprint scanning works real fast on lineage, never tried to set it up on MIUI.

23:  I can't seem to find any option that turns on "IR Face Unlock" even tho the latest lineage supports it, or claims to, back to google for me.

24:  why is there no default 'weather' app on google play?

25:  I haven't tried installing any other app stores, but XDA's does work ok.

26:  I wish there was a way i could perma-tether this to my iPhone's internet connection while I dared to set it up..and I'm going to desperately miss iMessage if I switch.

27:  Anyone wanna buy a Red 128GB Pocophone F1 ?  I have no idea if I'll keep using it.. In the USA. 

 

Link to post
Share on other sites

Hi, an Issue I am coming up against, is when I go running the command (in C:/adb): fastboot flash recovery "recovery-20181012.img"   

The phone just disconnects and shows the "press any button to shut down" in the top left of fastboot. The command prompt returns: FAILED (Write to device failed(invalid argument)) 

I have already unlocked the bootloader, enabled USB Debugging, etc. 

Note: Before running this command I did check it was there through: Fastboot devices   command.

The recovery-20181012 is in the adb folder.

Any help?

 

 

(I have Redmi Note 5 CN (Dual Camera))

Which is the Redmi Note 5 pro india but with Chinese rom.

I live in New Zealand and got the phone from China.

Link to post
Share on other sites
13 hours ago, Skwangles said:

Hi, an Issue I am coming up against, is when I go running the command (in C:/adb): fastboot flash recovery "recovery-20181012.img"   

The phone just disconnects and shows the "press any button to shut down" in the top left of fastboot. The command prompt returns: FAILED (Write to device failed(invalid argument)) 

I have already unlocked the bootloader, enabled USB Debugging, etc. 

Note: Before running this command I did check it was there through: Fastboot devices   command.

The recovery-20181012 is in the adb folder.

Any help?

I had the same problem and the solution is actually pretty simple. Just put your Phone into Fastboot mode but don't connect it to your PC yet. First type fastboot flash recovery "recovery-20181012.img" and then connect your Phone to your PC. That should work it worked perfectly for me after that. :)

Link to post
Share on other sites

Just registered to share my issue... Hello everyone!

As soon as i started Lineage OS i started getting 2 Errors, 5 times a second. Just popping up non stop..

android.process.media keeps stopping and

android.process.acore keeps stopping

 

for "android.process.media" i stopped Download manager / cleared all data and Cache, it seems to be working now..

for "android.process.acore" nothing worked. It seems to be a problem with Contacts app. So i cleared all data and Cache but no good. 
Another "Method" is to rest app preferences and reboot, it didnt help either and now i get the first error again.

I also tried factory resetting. No good.

Can anyone help me with that?
I liked lineage OS and i would like to keep it. It is just a bit frustrating.

 

Just as a backup plan, how can i get back to Miui? 

Thanks!

Link to post
Share on other sites

For all the help they've been they really should change the name of their yt channel from linustechtips to linusaffiliatelinks.  They get your cash and their forum is pretty empty of help after they put the idea in your head to trust that they wouldn't fuck you.  But you clicked on their affiliate link and now you have a brick for a phone.  Zero fucks given from linusaffiliatelinks

Link to post
Share on other sites

If any of you are having trouble with the Mi Unlock tool not connecting to your phone check if your computer uses Ryzen cpu. The program for some reason doesn't work properly with computers that use Ryzen.

Link to post
Share on other sites

I didn't want to do this after reading all the comments here, but I gave it a shot and tried to find a better "how to". Found this indian guy on youtube, Munchy, a small channel. Nice and slow and much more detailed. Plus personal support when I had questions. Real nice!

 

I had a couple of issues during the process, the bigger one you can read in the comments of the third video, user dangoran. I think I messed up there but it worked out ok. Some small details are left out of the videos but they are the type of details you can figure out if you are a somewhat technical person.

 

The videos (with links in the description):

Step 1, How to Xiaomi Poco F1 Bootloader Unlock; Bootloader Unlock Xiaomi Pocophone F1
https://www.youtube.com/watch?v=vtI_oQKyQV8

 

Step 2, How to Install TWRP Recovery & Root Poco F1; Xiaomi Pocophone F1 Root
https://www.youtube.com/watch?v=zw-4n6ElwU4

 

Step 3, Install; PocoPhone F1 Lineage OS 16 
https://www.youtube.com/watch?v=CY9mkiUCXak (instructions start 7:30 into the video)

 

I used Muchys link to the Google Pixel camera app (they are all the same links with this exception). Looks like the same file that LTT links to but Muchys link goes to a page that looks like the one in the LTT video. The LTT linked page looks way different. Works great so far.

Link to post
Share on other sites
On 11/27/2018 at 1:42 AM, jakkuh_t said:

Can we have the link for the ruthless launcher pls

Link to post
Share on other sites
On 12/27/2018 at 4:56 PM, dodampi said:

Just registered to share my issue... Hello everyone!

As soon as i started Lineage OS i started getting 2 Errors, 5 times a second. Just popping up non stop..

android.process.media keeps stopping and

android.process.acore keeps stopping

 

for "android.process.media" i stopped Download manager / cleared all data and Cache, it seems to be working now..

for "android.process.acore" nothing worked. It seems to be a problem with Contacts app. So i cleared all data and Cache but no good. 
Another "Method" is to rest app preferences and reboot, it didnt help either and now i get the first error again.

I also tried factory resetting. No good.

Can anyone help me with that?
I liked lineage OS and i would like to keep it. It is just a bit frustrating.

 

Just as a backup plan, how can i get back to Miui? 

Thanks!

I'm having the very same problem, tried the same fixes. Is there a way to get in touch with someone from Linus's Team?

Link to post
Share on other sites
On 11/26/2018 at 8:12 PM, jakkuh_t said:

We make a Pixel clone with a $300 Xiaomi Phone - The Poco F1

 

 

Hi Jakkuh,

 

Is there a fix to stop the error prompts "android.process.media" and "android.process.acore" from constantly popping up, I cleared the cache but still no good. 

 

Someone above seems to be having the same issue too.

Link to post
Share on other sites
Posted · Original PosterOP
On 4/7/2019 at 12:50 PM, ShenPanda said:

Hi Jakkuh,

 

Is there a fix to stop the error prompts "android.process.media" and "android.process.acore" from constantly popping up, I cleared the cache but still no good. 

 

Someone above seems to be having the same issue too.

I'd try factory resetting LineageOS and see if that works.

 

(via the settings app)


widget.png?style=banner2   -  7700K, 16GB RAM, GTX 1080 Ti FE, 2*4TB, 512GB 850 Evo


 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×