Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

CosmicNoob

Member
  • Content Count

    3
  • Joined

  • Last visited

Awards


This user doesn't have any awards

About CosmicNoob

  • Title
    Newbie
  1. Well thing is I haven't been twisting them and I've been extremely careful. I've also been using them wireless right up until this issue started so there is no way I stressed anything. Unless maybe something inside the left speaker became loose but even then I've been so careful I would find that hard to believe.
  2. Yeah I've already emailed them about it to see if they know what's wrong, just waiting on a reply. Either way I'll likely try to get a replacement. In the mean time though I do want to try and see if there is any other way to fix them without taking them apart or anything, hence coming here.
  3. So I bought a Razer Nari Ultimate Headset roughly a month and a half ago and everything was working fine up until yesterday when the left speaker suddenly started making a crackling sound any time audio played out of it. I had no idea what was wrong. I restarted it, tried it with my laptop, uninstalled and reinstalled the drivers, uninstalled and reinstalled the Razer Synapse 3 software and nothing worked. I then realized that when using the headset wired the issue disappears and they work fine however the vibration won't work and the Synapse software doesn't detect it. I can't seem to find anyone else with the same issue or solutions for it either and after spending €200 on it I'm pretty disappointed that there is a problem this soon. Anything new I could try would be greatly appreciated.
×