Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Snusmakaren

Member
  • Content Count

    3
  • Joined

  • Last visited

Awards


This user doesn't have any awards

About Snusmakaren

  • Title
    Newbie

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Hello! Sorry if it's wrong forum section. I recently bought a new PC (2 months ago). I have sent it back 2 times to the company so they can repair it, but they didn't manage to find any errors, so I will ask here instead! My problem is that im stuttering and FPS dropping and low GPU Usage in most games, and i can't seem to understand why. The temperatures in all games are extremely good though, nothing is too high.I dont think there's any bottleneck... Here's my specs: Processor: AMD Ryzen 9 3900X Processor 12 cores / 24 threads / 4.6 GHz Motherboard: ASUS Rog Strix x570F-Gaming- ATX/X570 Case: Corsair Obsidian 500D +3 fläktar ingick Power: Corsair RM750X V2/ 80+ Cooling: Corsair H100i RGB Platinum / iCUE-RGB / 240mm GPU: MSI Geforce Rtx 2080 SuperGaming X Trio RAM: Corsair Vengeance RGB PRO 32GB (2x16GB) / Ryzen / 3600MHz / DDR4 / CL18 / CMW32GX4M2Z3600C18 Monitor: Acer Nitro XZ272UP / 27" / VA / WQHD / 165Hz / 4ms / Curved / 2xHDMI,DP / VESA / Justerbar / Freesyn SSD: Samsung SSD 860 QVO 2TB I can run Assassins creed Oddyseus for no problems at all, it runs very smooth. However, once I try to play games such as Dead by Daylight, SMITE, Ryse: Son of Rome, Crysis 3, Age of Empires 3, the GPU usage is low, average around 54 in those games. I also stutter incredibly bad in these games, and FPS dropping. My costs around 2,500 euro. Waste of money, it doesnt work. Things I have tried: - Setting power to maximum performance - Tried vsync off and on, no difference - Updated every single driver in my PC - Disable Xbox app - Look for virus, nothing detected - Reinstall windows - Reinstalling games, no difference I have used MSI Afterburner as well. the PC is kinda slow as well, it takes up to 3-4 minutes every day to start the PC, even if I got an SSD. I haven't overcloacked the PC. I'd appreciate all the help I can get. I spoke to the company I bought the PC from, and they want to check the PC for a 3rd time now. And I can't send them back PC and get money back because the company doesn't allow it. Only if problems are found. Thanks a lot! /Snusmakaren
  2. Is it the same as dcop? My ram is in slot 2 and 4. Dcop is enable. Thanks for your fast replies, appreciate it
  3. Hello! Sorry if it's wrong forum section. I recently bought a new PC (2 months ago). I have sent it back 2 times to the company so they can repair it, but they didn't manage to find any errors, so I will ask here instead! My problem is that im stuttering and FPS dropping and low GPU Usage in most games, and i can't seem to understand why. The temperatures in all games are extremely good though, nothing is too high.I dont think there's any bottleneck... Here's my specs: Processor: AMD Ryzen 9 3900X Processor 12 cores / 24 threads / 4.6 GHz Motherboard: ASUS Rog Strix x570F-Gaming- ATX/X570 Case: Corsair Obsidian 500D +3 fläktar ingick Power: Corsair RM750X V2/ 80+ Cooling: Corsair H100i RGB Platinum / iCUE-RGB / 240mm GPU: MSI Geforce Rtx 2080 SuperGaming X Trio RAM: Corsair Vengeance RGB PRO 32GB (2x16GB) / Ryzen / 3600MHz / DDR4 / CL18 / CMW32GX4M2Z3600C18 Monitor: Acer Nitro XZ272UP / 27" / VA / WQHD / 165Hz / 4ms / Curved / 2xHDMI,DP / VESA / Justerbar / Freesyn SSD: Samsung SSD 860 QVO 2TB I can run Assassins creed Oddyseus for no problems at all, it runs very smooth. However, once I try to play games such as Dead by Daylight, SMITE, Ryse: Son of Rome, Crysis 3, Age of Empires 3, the GPU usage is low, average around 54 in those games. I also stutter incredibly bad in these games, and FPS dropping. My costs around 2,500 euro. Waste of money, it doesnt work. Things I have tried: - Setting power to maximum performance - Tried vsync off and on, no difference - Updated every single driver in my PC - Disable Xbox app - Look for virus, nothing detected - Reinstall windows - Reinstalling games, no difference I have used MSI Afterburner as well. the PC is kinda slow as well, it takes up to 3-4 minutes every day to start the PC, even if I got an SSD. I haven't overcloacked the PC. I'd appreciate all the help I can get. I spoke to the company I bought the PC from, and they want to check the PC for a 3rd time now. And I can't send them back PC and get money back because the company doesn't allow it. Only if problems are found. Thanks a lot! /Snusmakaren
×