Jump to content
To encourage social distancing, you must leave two blank lines at the start and end of every post, and before and after every quote. Failure to comply may result in non-essential parts of the forum closing. Click for more details. ×
Search In
  • More options...
Find results that contain...
Find results in...

minibois

Member
  • Content Count

    23,093
  • Joined

  • Last visited

Awards


About minibois

Profile Information

  • Interests
    Programming, hardware design, graphic design, video editing, PC's, peripherals, mechanical keyboards, gaming controllers, old Trance/Eurodance music.
  • Biography
    sometimes i don't even know who i am

System

  • CPU
    Ryzen 7 1700
  • Motherboard
    MSI X370 Gaming Pro Carbon
  • RAM
    G.Skill TridentZ RGB (2x8GB, 3200Mhz running at 2666Mhz)
  • GPU
    EVGA RTX 2070 Super XC Gaming
  • Case
    Thermaltake Core G21
  • Storage
    Samsung 960 EVO 250GB, 860 EVO 1TB (M.2), Seagate Barracuda Compute 2TB
  • PSU
    Corsair RM750X
  • Display(s)
    LG 27UD68-B, BenQ GL2460HM, ASUS VH222
  • Cooling
    Be Quiet! Dark Rock 3
  • Keyboard
    Coolermaster Masterkeys Pro S RGB
  • Mouse
    ASUS ROG Gladius
  • Sound
    Beyerdynamic DT-990 250 Ohm
  • Operating System
    Windows 10 Home
  • Laptop
    Asus Vivobook Pro N580VD
  • PCPartPicker URL

Recent Profile Visitors

93,713 profile views

Single Status Update

See all updates by minibois

  1. Oh nooo.... The NEW PSU tier list released yesterday and I was already able to use it. I commented something on that thread already, which that post included a picture.

    This is something I mention, because this website can embed forum threads (so you don't just see the link, but you see the title, OP, amount of replies, etc. of the thread), which is an awesome feature! But apparently, I did not exactly know this, but I guess it's somewhat obvious.. This forum uses the first posted image of the thread, as the banner in the embed feature..

    My post just happened to feature the first image, as it turns out:

     

    So... (at least on my end) the PSU tier list shows up like this:

    (Screenshot):

     image.png.9f785b3be97a9a1db3a239941bb5dada.png

    Actual link:

     

    Because of this post I made in that thread:

    Spoiler

     

     

    Well if anyone (related to that PSU tier list) cares that it shows up like this for other users (because it might look kind of meme-y); be sure to edit a picture into one of your post on that thread, so it won't show up like that :P 

    @LienusLateTips @seon123 @Stefan Payne @LukeSavenije

     

     

    P.S. By the way, I checked just to be sure it isn't just something that shows up just for me.. It shows up on two different devices, on Chrome, Chrome Incognito and Edge (on both devices).

     

    P.P.S. great job on the list guys, everyone on the forum appreciates the effort you have put into it ❤️ 

    1. Show previous comments  5 more
    2. LienusLateTips

      LienusLateTips

      @Minibois It didn't show the pic 5 mins ago when I wrote that, but now it does... odd.

    3. LukeSavenije

      LukeSavenije

      it's magic

       

      and a fox

    4. minibois

      minibois

      I edited my status update, I added a link to the PSU tier list thread; where-as I previously had a link to my own post in that thread.

      So yeah that's correct.

×