Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

takadii

Member
  • Content Count

    10
  • Joined

  • Last visited

Everything posted by takadii

  1. i managed to take off Now how can i separate them? Also . my previous Motherboard is dead
  2. title says it all , so i went and got a new motherboard to swap my CPU and after screwing all fan screws it won't get off and found out that its stuck and i can't get it off the motherboard
  3. it should be under warranty, im waiting for a reply from my seller ,he is from another city also it's close to end i bought this motherboard at this month last year ... so there are few days
  4. i think i will buy a New Motherboard and PSU and check exactly where's the problem thank you so much for your time
  5. Thank you so much for your Reply I cleaned the ram slots and reseated all cables i double checked the Manuel you sent and and im Stuck between two steps PSU works fine , but the PC doesn't make any sounds/beeps/lights when i try to turn it on i double Check Psu using paperclip and still works , again i plug all cords in and try to turn it on and nothing happens
  6. Hi so i woke up this morning and went to turn on my PC and it doesn't work i tested power supply and it works fine , fan spinning but still no turn on , how can see if the issue if the from the motherboard? PS : Motherboard > Gigabyte B450M S2H
  7. Thank you so much for the quick Reply I toke another look at the fans and they seem stable ... but as you said something might be shaking inside, I don't want to open it up but ... is the sounds noraml? it won't get damaged right ? i can keep playing with this ? Again Thank you so much and yea the figure looks beautiful inside a PC than a shelf
  8. I got this Used GPU Gigabyte Gtx 1660 TI this week and it's and i was confused about this sound when i play Games ... they are set At Mid-High ... same settings when i had 1050 Ti but i wasn't hearing any noises tho but in this one i have no clue if it's Normal or no Ps : it happens only when i game ... it's quite when I'm browsing or Editing Here's a clip https://drive.google.com/file/d/1F8ETmTBhsJOPyUrLLOgO7VUbqQbfEidh/view?usp=drivesdk
×