Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Serftion

Member
  • Content Count

    4
  • Joined

  • Last visited

Awards


This user doesn't have any awards

About Serftion

  • Title
    Newbie
  1. Tried that already, still nothing I guess so. I will try updating my bios as soon as possible. Thank you!
  2. The board is brand new. It said on the box that it is Ryzen 3rd gen ready so I didn't really think I'll run into this problem. We haven't tried this yet so maybe this might do it
  3. My external keyboard, mouse, and gamepad (this one worked before) won't work because it is detected as a USBDeviceShare USB Device Stub on Device Manager. Any tips on how to fix this?
  4. Specs: ASRock B450M Pro4-F AMD Ryzen 5 3600 Nvidia GTX 1050ti (used) 16gb (dual) ddr4 3200 Klevv Cras X RGB 256gb Adata XPG SX8200 Pro SSD M.2 NVMe 2tb Seagate Barracuda 7200rpm Silver Stone SST, 550watts, Strider Essential, PSU, 80PLUS gold Tecware Alpha (used) Dell 24' IPS monitor (used) So I installed everything properly and I thought everything was running fine when the fans started spinning and the RAM light up but it displayed nothing on my monitor. Another thing to note is that it seems that it's booting fine because the NumLock on the keyboard responds. I used an HDMI 2 volts cable inserted to the GPU. I also tried plugging it to the motherboard, and also tried a VGA cable. Nothing happened. The available ports for the monitor are DVI and DisplayPort (and among others) and I haven't tried it yet. I reseated every part but to no avail. Also changed the CMOS battery. Still, nothing happened. Plugged my CPU to a direct power outlet, still nothing. I suspect that this may be from the motherboard's BIOS (which I can't flash because there's no display), or this may be a compatibility issue with B450 boards and 3rd gen Ryzens. Another possible problem is from the GPU (I already cleaned it, changed the heatsink, reapplied thermal paste) and from the cables or the monitor itself. Any tips on how to fix this?
×